Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.98.0, 0.96.1.1
    • Fix Version/s: 0.98.0, 0.99.0
    • Component/s: None
    • Labels:
      None

      Description

      I can reproduce this using JDK 6 on Ubuntu 13.10.

      Running org.apache.hadoop.hbase.TestIOFencing
      Tests run: 2, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 111.55 sec <<< FAILURE!
      

      No failure trace captured yet. Fix or disable.

      1. 10298.patch
        1 kB
        Andrew Purtell

        Issue Links

          Activity

          Andrew Purtell added a comment -

          Ted Yu has been looking at this on HBASE-8889 (Reopened) recently. This JIRA is about how to resolve this for 0.98, perhaps by disabling the test for release 0.98.0.

          Andrew Purtell added a comment -

          Attaching what I am going to commit to disable TestIOFencing for the 0.98.0 release. Will commit trivial test change using CTR shortly unless objection. We should make one of the other related issues a blocker for 1.0.

          Andrew Purtell added a comment -

          Made this a blocker for 0.98.1 and 1.0.0.

          Hudson added a comment -

          SUCCESS: Integrated in HBase-0.98 #63 (See https://builds.apache.org/job/HBase-0.98/63/)
          HBASE-10298. TestIOFencing occasionally fails

          This flapping test produces low confidence results so temporarily
          disable it while tracking down the cause. (apurtell: rev 1556597)

          • /hbase/branches/0.98/hbase-server/src/test/java/org/apache/hadoop/hbase/TestIOFencing.java
          Hudson added a comment -

          SUCCESS: Integrated in HBase-0.98-on-Hadoop-1.1 #57 (See https://builds.apache.org/job/HBase-0.98-on-Hadoop-1.1/57/)
          HBASE-10298. TestIOFencing occasionally fails

          This flapping test produces low confidence results so temporarily
          disable it while tracking down the cause. (apurtell: rev 1556597)

          • /hbase/branches/0.98/hbase-server/src/test/java/org/apache/hadoop/hbase/TestIOFencing.java
          Hudson added a comment -

          SUCCESS: Integrated in HBase-TRUNK #4798 (See https://builds.apache.org/job/HBase-TRUNK/4798/)
          HBASE-10298. TestIOFencing occasionally fails

          This flapping test produces low confidence results so temporarily
          disable it while tracking down the cause. (apurtell: rev 1556596)

          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/TestIOFencing.java
          Andrew Purtell added a comment -

          I see Ted made HBASE-8889 a blocker for 1.0 so I will change the scope of this JIRA for just the test disable change.

          Andrew Purtell added a comment -

          Patch disabling this test for now committed to trunk and 0.98, resolving

          Hudson added a comment -

          SUCCESS: Integrated in HBase-TRUNK-on-Hadoop-1.1 #46 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-1.1/46/)
          HBASE-10298. TestIOFencing occasionally fails

          This flapping test produces low confidence results so temporarily
          disable it while tracking down the cause. (apurtell: rev 1556596)

          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/TestIOFencing.java

            People

            • Assignee:
              Andrew Purtell
              Reporter:
              Andrew Purtell
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development