Uploaded image for project: 'Harmony'
  1. Harmony
  2. HARMONY-6318

[drlvm][kernel] Attempting to load unsupported class version throws wrong exception type

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 5.0M12
    • Component/s: DRLVM
    • Labels:
      None

      Description

      When running the 5.0 build of Harmony and attempting to load class files compiled with 1.6 target version, Harmony throws a verify error, whereas the RI throws an UnsupportedClassVersionError.

      See HARMONY-6317 for an example.

        Attachments

          Activity

            People

            • Assignee:
              tellison Tim Ellison
              Reporter:
              tellison Tim Ellison
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: