Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.0M8
    • Component/s: JDK
    • Labels:
      None
    • Environment:
      Should run in all environments.
    • Patch Info:
      Patch Available
    • Estimated Complexity:
      Moderate

      Description

      Changes since https://issues.apache.org/jira/browse/HARMONY-5949

      -WarningLogDialog class to display and store the warning and error messages.
      New feature (compared to Sun's policytool): the warning log dialog is non-modal which is a lot more useful here because we support
      direct editing, and switching between the editor panels can generate errors/warnings frequently (not just when opening a new file or
      validating form values).
      The warning log can be open while we edit the policy text in any editor.
      If we use the "View warnign Log" menu while it's visible, it will be centered again.
      -Fixed a bug where permission signedBy caused a parse exception.
      -Validation to form dialogs.
      -Fixed the following bug: If we edit an item of a ListAndEditPanel, we change it in a way that its toString() method will return
      a very long string (long as it won't fit in the displayed width), its string will be truncated (ended with "..."),
      and no scrollbars will be displayed.

      1. apache.gif
        0.4 kB
        András Belicza
      2. policytool 2008-08-18_B.patch
        23 kB
        András Belicza
      3. policytool 2008-08-18_C.patch
        26 kB
        András Belicza
      4. policytool 2008-08-18.patch
        21 kB
        András Belicza

        Activity

        András Belicza added a comment -

        The patch containing the changes.

        András Belicza added a comment -

        The patch containing the changes aboue and below:

        -URL validation for Grant entry codeBase field, keystoreURL and keystorePasswordURL
        -fixed a NullPointerException caused by "New" menu on the graphical editor panel

        András Belicza added a comment -

        All the changes mentioned above and below:

        -Apache Harmony icon for all frames/dialogs.

        Apache.gif is not included since it is a binary file.

        András Belicza added a comment -

        This is the apache Harmony icon used to set as the frame icons to all frames/dialogs.

        It has to be placed in the directory next to MainFrame.java.
        It also has to be included in the tools.jar when it is created.

        Sian January added a comment -

        Applied patch at r687695. Please check that it was applied as you expected.


          People

          • Assignee:
            Sian January
            Reporter:
            András Belicza
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development