Details
-
Improvement
-
Status: Closed
-
Major
-
Resolution: Fixed
-
None
-
None
-
None
-
Patch Available
Description
Andrew,
Please review the patch. Here goes change list:
- Added a new EventListener which sets public test fields on start up. Added listener package and a test for a new functionality.
- Renamed Parameterizable -> Parameterized. The latter one has fewer letters and my spellchecker doesn't underline it with red.
- Renamed setup -> setUp to be consistent with JUnit.
- Enhanced before/after class events to take a test instance instead a class, fixed TODO comment to supply an exception to an after class listener.
- Fixed a number of misspells and added few lines of javadoc.
- Removed TypeUtil class, moved the checks to the Convention interface. Added org.punit.convention.AbstractConvention minimizing code duplication.
- Removed toAbort() timeout from the Loop interface.
Please don't hesitate to let me know if you disagree with changes (renaming issues in particular) - this won't take too much to rollback them.