Harmony
  1. Harmony
  2. HARMONY-333

AttributedCharacterIterator taken from DecimalFormat failed to retreive attributes.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None
    • Environment:
      J9 + Harmony classlib

      Description

      See test case below to understand the problem:

      public void testAttributedCharacterIterator() throws Exception

      { AttributedCharacterIterator iterator = new DecimalFormat().formatToCharacterIterator(new Integer(1)); assertFalse("attributes should exist", iterator.getAttributes().isEmpty()); }

        Activity

        Nathan Beyer made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Nathan Beyer added a comment -

        Closing; assuming everything is fine, since there weren't any responses.

        Nathan Beyer made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Nathan Beyer added a comment -

        I added a regression test to DecimalFormatTest, based on the original issue, which seems to be resolved now. Can someone please verify that this is working for them as well? Thanks.

        Nathan Beyer made changes -
        Field Original Value New Value
        Assignee Nathan Beyer [ nbeyer ]
        Nathan Beyer added a comment -

        According to the ICU bug site, this issue has been fixed. Has it been fixed in ICU 3.4, which is already packaged, or do we need to wait until the latest ICU (3.6?) gets integrated.

        Paulex Yang added a comment -

        For those who are interest in this issue, Richard has raised bug to ICU project, pls. see [1] for details on the progress.

        [1] http://bugs.icu-project.org/cgi-bin/icu-bugs/incoming?findid=5176

        Paulex Yang added a comment -

        Have got response from ICU team and confirmed that ICU didn't support this feature so far, I'll work with them to see if we can fix it by add this feature to ICU, so that our codes don't need any modification.

        Paulex Yang added a comment -

        After a quick review of codes, I found the cause is ICU4J doesn't define the NumberFormat.Fields like Java spec, so that it probably doesn't support the attributes parsing. I'll invetigate more inside to see if any action we can take to walk around this bug.

        Anton Avtamonov created issue -

          People

          • Assignee:
            Nathan Beyer
            Reporter:
            Anton Avtamonov
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development