Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: build - test - ci
    • Labels:
      None
    • Environment:
      RHEL4 update 4, gcc 3.4.6, core2 (i386)
    • Estimated Complexity:
      Unknown

      Description

      This test consistently hangs on RHEL4 update 4 for i386. It has been preventing Cruise Control from making any progress.

      1. Mix.java.noload.patch
        0.8 kB
        Naveen Neelakantam
      2. Mix.java.load.patch
        0.6 kB
        Naveen Neelakantam
      3. MegaSpawn.java
        2 kB
        weldon washburn

        Issue Links

        There are no Sub-Tasks for this issue.

          Activity

          weldon washburn added a comment -

          I am also observing that stress.Mix consistently hangs on 2cpu RHEL4. I will start looking into stress.Mix problems soon and also start a discussion on dev list.

          weldon washburn added a comment -

          I attached MegaSpawn.java, a test that seems to aggrevate the hang problem. MegaSpawn.java is basically stress.Mix with all the non-essentials removed.

          Vasily Zakharov added a comment -

          Can this issue be related to HARMONY-2187? Adding a link, just in case.

          Elena Semukhina added a comment -

          MegaSpawn crashes with Segmentation fault on SUSE9 linux em64t. The same is reported in HARMONY-2772 for stress.Mix so I add the link to that issue.

          Gregory Shimansky added a comment -

          AFAIK HARMONY-2187 is different. It doesn't finish because AWT code create a new thread for getting windows messages, so this thread loops entirely inside of native code. DRLVM can interrupt a thread only if it sometimes executes VM code (either from Java via helper e.g. GC safe point or from native through JNI). But this AWT thread doesn't execute VM code because no window messages are received. So this daemon thread cannot be interrupted by VM.

          Peter Novodvorsky added a comment -

          Does patch from HARMONY-2963 fix the problem? isn't it the same bug?

          Naveen Neelakantam added a comment -

          oddly enough, the patch from HARMONY-2963 does not fix this issue.

          I tried running stress.Mix a handful of times and it continues to hang (although now it only hangs occasionally)

          Naveen Neelakantam added a comment -

          I took a play out of the Washburn playbook:

          The issue can be reproduces by patching Mix.java so that it only "load"s. The attached patch (Mix.java.load.patch) does the trick.

          the patched stress.Mix will still only hang intermittently.

          Peter Novodvorsky added a comment -

          Naveen, how many times did you run the test. I've ran it 100 times on Windows uniprocessor and Linux smp (with latest classlib/vm, the patch is already commited) and didn't catch the bug.

          Naveen Neelakantam added a comment -

          What version of Linux did you try? It could be RHEL4 specific.

          It hangs for me after only a couple runs (I just tried latest classlib/vm, r512413). I've even seen a Segfault with the following message:

          java.lang.OutOfMemoryError: Failed to create new thread
          at java.lang.Thread.start(Thread.java:743)
          at stress.Mix.spawn(Mix.java:268)
          at stress.Mix.run(Mix.java:77)
          Cannot allocate pool storage: 0x10000 bytes of virtual memory for code or data.
          Error code = 12
          SIGABRT in VM code.
          Stack trace:

          Naveen Neelakantam added a comment -

          NOTE, my environment has changes since I reported this bug. I now use gcc 4.1.0

          Naveen Neelakantam added a comment -

          Per Weldon's suggestion on the dev list, and considering that HARMONY-2963 has been fixed, it makes sense to downgrade this issue.

          Naveen Neelakantam added a comment -

          If someone does remove stress.Mix from the x86 excludes list, please apply Mix.java.noload.patch.

          It removes the "load" test from stress.Mix, which prevents it from hanging on RHEL4 systems.

          Naveen Neelakantam added a comment -

          The patches from HARMONY-2982 resolves this issue (including the load-only stress test).


            People

            • Assignee:
              weldon washburn
              Reporter:
              Naveen Neelakantam
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development