Harmony
  1. Harmony
  2. HARMONY-2448

[classlib][beans] java.beans.VetoableChangeListenerProxy.vetoableChange() does not throw NPE

    Details

      Description

      VetoableChangeListenerProxy.vetoableChange() does not throw NPE if
      object was created with VetoableChangeListener listener == null. Specification does not mention this, but RI throws NPE.

        Activity

        Nikolay Kuznetsov created issue -
        Nikolay Kuznetsov added a comment -

        Attached test demonstrated this problem:
        Output on Harmony VM:
        getListener()=null
        FAIL: NullPointerExceptin is expected

        Output on BEA:
        getListener()=null
        PASS
        java.lang.NullPointerException
        at
        java.beans.VetoableChangeListenerProxy.vetoableChange(Ljava.beans.Pro
        pertyChangeEvent;)V(VetoableChangeListenerProxy.java:54)
        at test.main([Ljava.lang.String;)V(test.java:14)

        Nikolay Kuznetsov made changes -
        Field Original Value New Value
        Attachment test_VetoableChangeListener.java [ 12346356 ]
        Alexei Zakharov made changes -
        Summary java.beans.VetoableChangeListenerProxy.vetoableChange() does not throw NPE [classlib][beans] java.beans.VetoableChangeListenerProxy.vetoableChange() does not throw NPE
        Kevin Zhou added a comment -

        I can not reproduce it any more on the latest version of HDK.

        Thanks

        Kevin Zhou made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Kevin Zhou [ zhoukevin ]
        Fix Version/s 6.0M2 [ 12314804 ]
        Fix Version/s 5.0M14 [ 12314803 ]
        Resolution Cannot Reproduce [ 5 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1266d 14h 34m 1 Kevin Zhou 24/May/10 09:04

          People

          • Assignee:
            Kevin Zhou
            Reporter:
            Nikolay Kuznetsov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development