Harmony
  1. Harmony
  2. HARMONY-1438

[class][luni] new methods java.lang.Math.ulp(double), java.lang.Math.ulp(float),java.lang.StrictMath.ulp(double), java.lang.StrictMath.ulp(float)

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      new methods java.lang.Math.ulp(double),
      java.lang.Math.ulp(float),java.lang.StrictMath.ulp(double),
      java.lang.StrictMath.ulp(float) in Java 5 but not implemented in
      Harmony(project luni).

      In this patch,I will refactor the math.c.

        Activity

        spark shen added a comment -

        Would you please try this patch? Since this patch will also modify native code, you may need a rebuild.

        Best regards

        Paulex Yang added a comment -

        Spark, patch applied at revision r442564 with minor changes, thanks a lot for this enhancement, please verify that the problem is fully resolved as you expected.

        spark shen added a comment -

        Hi Paulex, thank you for the genius change. The patch looks OK.

        Best regards

        Paulex Yang added a comment -

        Verified by Spark.


          People

          • Assignee:
            Paulex Yang
            Reporter:
            spark shen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development