Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.5.0
    • Fix Version/s: 0.6.0
    • Component/s: machine learning
    • Labels:
      None

      Description

      A gradient descent (http://en.wikipedia.org/wiki/Gradient_descent) BSP based algorithm should be implemented.

        Activity

        Tommaso Teofili created issue -
        Hudson added a comment -

        Integrated in Hama-Nightly #697 (See https://builds.apache.org/job/Hama-Nightly/697/)
        HAMA-651 - fixed format and added input reset on #getXSize (Revision 1394791)
        HAMA-651 - adding first basic unregularized version of a gradient descent BSP (Revision 1394783)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Hudson added a comment -

        Integrated in Hama trunk #17 (See https://builds.apache.org/job/Hama%20trunk/17/)
        HAMA-651 - fixed format and added input reset on #getXSize (Revision 1394791)
        HAMA-651 - adding first basic unregularized version of a gradient descent BSP (Revision 1394783)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Thomas Jungblut added a comment -

        Nice addition! Can you provide a basic logistic regression as well? Thanks!

        Hudson added a comment -

        Integrated in Hama trunk #18 (See https://builds.apache.org/job/Hama%20trunk/18/)
        HAMA-651 - adding collecting of cost and theta as output (Revision 1395024)

        Result = FAILURE
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Hudson added a comment -

        Integrated in Hama trunk #19 (See https://builds.apache.org/job/Hama%20trunk/19/)
        HAMA-651 - added calculateCostForItem method since also cost function is dependent from the specific algorithm used (Revision 1395161)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Tommaso Teofili added a comment -

        Nice addition! Can you provide a basic logistic regression as well? Thanks!

        thanks it's still work in progress but it should be possible to use both linear and logistic regression with it as soon as it's finished.

        Hudson added a comment -

        Integrated in Hama-Nightly #698 (See https://builds.apache.org/job/Hama-Nightly/698/)
        HAMA-651 - added calculateCostForItem method since also cost function is dependent from the specific algorithm used (Revision 1395161)
        HAMA-651 - adding collecting of cost and theta as output (Revision 1395024)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Thomas Jungblut added a comment -

        Good. Just a tiny suggestion: I would extract an costfunction interface that can be supplied from outside and reflectively instantiated in your BSP.
        Subclassing an algorithm is not so good for everybody.

        Tommaso Teofili added a comment -

        +1, that's what I've in mind as well. I need to refactor the current implementation a bit in order to do that since currently the total number of inputs is not known in advance while the cost function (which usually needs such an information) has to be calculated per each item.
        I'll work in the next weeks on this and some tests / benchmarks.

        Hudson added a comment -

        Integrated in Hama trunk #20 (See https://builds.apache.org/job/Hama%20trunk/20/)
        HAMA-651 - added gradient descent cost check with threashold (Revision 1395322)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Hudson added a comment -

        Integrated in Hama-Nightly #699 (See https://builds.apache.org/job/Hama-Nightly/699/)
        HAMA-651 - added gradient descent cost check with threashold (Revision 1395322)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Hudson added a comment -

        Integrated in Hama trunk #21 (See https://builds.apache.org/job/Hama%20trunk/21/)
        HAMA-651 - fixed typos and constant abstractions (Revision 1395607)
        HAMA-651 - fixed javadoc (Revision 1395606)
        HAMA-651 - fixed format (Revision 1395605)
        HAMA-651 - added some model classes to abstract cost function and hypothesis from the gradient descent bsp (Revision 1395604)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/HypothesisFunction.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/CostFunction.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/HypothesisFunction.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/LinearRegressionModel.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/LogisticRegressionModel.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/RegressionModel.java
        Tommaso Teofili added a comment -

        first version of model / cost function in place, however it's likely to be changing a bit before finishing this.

        Hudson added a comment -

        Integrated in Hama trunk #22 (See https://builds.apache.org/job/Hama%20trunk/22/)
        HAMA-651 - fixed format (Revision 1395756)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/CostFunction.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/LinearRegressionModel.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/RegressionModel.java
        Hudson added a comment -

        Integrated in Hama-Nightly #700 (See https://builds.apache.org/job/Hama-Nightly/700/)
        HAMA-651 - fixed format (Revision 1395756)
        HAMA-651 - fixed typos and constant abstractions (Revision 1395607)
        HAMA-651 - fixed javadoc (Revision 1395606)
        HAMA-651 - fixed format (Revision 1395605)
        HAMA-651 - added some model classes to abstract cost function and hypothesis from the gradient descent bsp (Revision 1395604)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/CostFunction.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/LinearRegressionModel.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/RegressionModel.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/HypothesisFunction.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/CostFunction.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/HypothesisFunction.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/LinearRegressionModel.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/LogisticRegressionModel.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/RegressionModel.java
        Hudson added a comment -

        Integrated in Hama trunk #23 (See https://builds.apache.org/job/Hama%20trunk/23/)
        HAMA-651 - added theta/cost writedown on cleanup (Revision 1395878)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Hudson added a comment -

        Integrated in Hama-Nightly #701 (See https://builds.apache.org/job/Hama-Nightly/701/)
        HAMA-651 - added theta/cost writedown on cleanup (Revision 1395878)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Hudson added a comment -

        Integrated in Hama trunk #24 (See https://builds.apache.org/job/Hama%20trunk/24/)
        HAMA-651 - added a couple of TODOs (Revision 1397446)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Tommaso Teofili added a comment - - edited

        first working version committed along with sample code in the examples module

        Hudson added a comment -

        Integrated in Hama trunk #25 (See https://builds.apache.org/job/Hama%20trunk/25/)
        HAMA-651 - adding gradient descent to examples (Revision 1397525)
        HAMA-651 - adding a sample input format for gd, plus adding #set method to VectorWritable (Revision 1397521)
        HAMA-651 - adjusting defaults a bit, plus fixing input reopenings, theta initialization and derivatives aggregation (Revision 1397520)

        Result = FAILURE
        tommaso :
        Files :

        • /hama/trunk/examples/src/main/java/org/apache/hama/examples/GradientDescentExample.java
        • /hama/trunk/examples/src/test/java/org/apache/hama/examples/GradientDescentTest.java
        • /hama/trunk/examples/src/test/resources
        • /hama/trunk/examples/src/test/resources/gd_file_format.txt

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/VectorDoubleFileInputFormat.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/writable/VectorWritable.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Thomas Jungblut added a comment -

        We should add a testcase for it and it seems that we have to run a formatter over it

        But everything else looks kinda nice. Good work!

        Hudson added a comment -

        Integrated in Hama-Nightly #704 (See https://builds.apache.org/job/Hama-Nightly/704/)
        HAMA-651 - added iterations threshold (Revision 1397550)
        HAMA-651 - fixing examples for gd (Revision 1397539)
        HAMA-651 - fixing log and Strings (Revision 1397538)
        HAMA-651 - renaming gd sample file and adding rat exclusion (Revision 1397532)
        HAMA-651 - adding gradient descent to examples (Revision 1397525)
        HAMA-651 - adding a sample input format for gd, plus adding #set method to VectorWritable (Revision 1397521)
        HAMA-651 - adjusting defaults a bit, plus fixing input reopenings, theta initialization and derivatives aggregation (Revision 1397520)
        HAMA-651 - added a couple of TODOs (Revision 1397446)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/examples/src/main/java/org/apache/hama/examples/GradientDescentExample.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java

        tommaso :
        Files :

        • /hama/trunk/examples/src/main/java/org/apache/hama/examples/GradientDescentExample.java
        • /hama/trunk/examples/src/test/java/org/apache/hama/examples/GradientDescentTest.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java

        tommaso :
        Files :

        • /hama/trunk/examples/src/test/resources/gd_file_format.txt
        • /hama/trunk/examples/src/test/resources/gd_file_sample.txt
        • /hama/trunk/pom.xml

        tommaso :
        Files :

        • /hama/trunk/examples/src/main/java/org/apache/hama/examples/GradientDescentExample.java
        • /hama/trunk/examples/src/test/java/org/apache/hama/examples/GradientDescentTest.java
        • /hama/trunk/examples/src/test/resources
        • /hama/trunk/examples/src/test/resources/gd_file_format.txt

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/VectorDoubleFileInputFormat.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/writable/VectorWritable.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java

        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Thomas Jungblut added a comment -

        Apparently there is a tiny bug as well, arround line 218 when reading a vector it should better be "if (key.getVector() == null) {" instead of "if (key == null) {"

        Tommaso Teofili added a comment -

        correct thanks, I'll fix it

        Hudson added a comment -

        Integrated in Hama-Nightly #705 (See https://builds.apache.org/job/Hama-Nightly/705/)
        HAMA-651 - fixed bug in input size reading and removed fixed bsp tasks no. in example (Revision 1397963)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/examples/src/main/java/org/apache/hama/examples/GradientDescentExample.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Hudson added a comment -

        Integrated in Hama trunk #28 (See https://builds.apache.org/job/Hama%20trunk/28/)
        HAMA-651 - fixed bug in input size reading and removed fixed bsp tasks no. in example (Revision 1397963)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/examples/src/main/java/org/apache/hama/examples/GradientDescentExample.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        Hudson added a comment -

        Integrated in Hama trunk #29 (See https://builds.apache.org/job/Hama%20trunk/29/)
        HAMA-651 - added unit test for VectorDoubleFileInputFormat (Revision 1398665)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/test/java/org/apache/hama/ml/regression
        • /hama/trunk/ml/src/test/java/org/apache/hama/ml/regression/VectorDoubleFileInputFormatTest.java
        • /hama/trunk/ml/src/test/resources/vd_file_sample.txt
        Hudson added a comment -

        Integrated in Hama-Nightly #708 (See https://builds.apache.org/job/Hama-Nightly/708/)
        HAMA-651 - added unit test for VectorDoubleFileInputFormat (Revision 1398665)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/test/java/org/apache/hama/ml/regression
        • /hama/trunk/ml/src/test/java/org/apache/hama/ml/regression/VectorDoubleFileInputFormatTest.java
        • /hama/trunk/ml/src/test/resources/vd_file_sample.txt
        Edward J. Yoon added a comment -

        Fixed.

        Edward J. Yoon made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Tommaso Teofili [ teofili ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in Hama trunk #34 (See https://builds.apache.org/job/Hama%20trunk/34/)
        HAMA-651 - fixed indent (Revision 1402402)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/VectorDoubleFileInputFormat.java
        • /hama/trunk/ml/src/test/java/org/apache/hama/ml/regression/VectorDoubleFileInputFormatTest.java
        Hudson added a comment -

        Integrated in Hama-Nightly #718 (See https://builds.apache.org/job/Hama-Nightly/718/)
        HAMA-651 - fixed indent (Revision 1402402)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/GradientDescentBSP.java
        • /hama/trunk/ml/src/main/java/org/apache/hama/ml/regression/VectorDoubleFileInputFormat.java
        • /hama/trunk/ml/src/test/java/org/apache/hama/ml/regression/VectorDoubleFileInputFormatTest.java
        Hudson added a comment -

        Integrated in Hama trunk #66 (See https://builds.apache.org/job/Hama%20trunk/66/)
        HAMA-651 - add GradientDescent to the ExampleDriver (Revision 1412470)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/examples/src/main/java/org/apache/hama/examples/ExampleDriver.java
        Hudson added a comment -

        Integrated in Hama-Nightly #745 (See https://builds.apache.org/job/Hama-Nightly/745/)
        HAMA-651 - add GradientDescent to the ExampleDriver (Revision 1412470)

        Result = SUCCESS
        tommaso :
        Files :

        • /hama/trunk/examples/src/main/java/org/apache/hama/examples/ExampleDriver.java

          People

          • Assignee:
            Tommaso Teofili
            Reporter:
            Tommaso Teofili
          • Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development