Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-9966

Refactor XDR code into XDRReader and XDRWriter

Log workAgile BoardRank to TopRank to BottomAttach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskConvert to sub-taskMoveLinkCloneLabelsUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: nfs
    • Labels:

      Description

      Several methods in the current XDR class have ambiguous semantics. For example, Size() returns the actual size of internal byte array. The actual size of current buffer, is also affected by read requests, which pull data out of the buffer.

      These ambiguous semantics makes removing redundant copies on the NFS paths difficult.

      This JIRA proposes to decompose the responsibilities of XDR into two separate class: XDRReader and XDRWriter. The overall designs should closely follow Java's *Reader / *Writer classes.

        Attachments

        1. HADOOP-9966.002.patch
          10 kB
          Haohui Mai
        2. HADOOP-9966.001.patch
          10 kB
          Haohui Mai
        3. HADOOP-9966.000.patch
          10 kB
          Haohui Mai

        Issue Links

          Activity

          $i18n.getText('security.level.explanation', $currentSelection) Viewable by All Users
          Cancel

            People

              Dates

              • Created:
                Updated:

                Issue deployment