Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-9672

Upgrade Avro dependency to 1.7.4

VotersStop watchingWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 2.0.5-alpha
    • 2.1.1-beta
    • None
    • None
    • Reviewed

    Description

      Hadoop still depends on Avro-1.5.3, when the latest release is 1.7.4. I've observed this cause problems when using Hadoop 2 with Crunch, which uses a more recent version of Avro.

      Attachments

        1. HADOOP-9672.patch
          0.4 kB
          Sandy Ryza
        2. HADOOP-9672.avro-1.7.4.patch
          0.5 kB
          Kihwal Lee

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            sandyr Sandy Ryza
            sandyr Sandy Ryza
            Votes:
            0 Vote for this issue
            Watchers:
            4 Stop watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment