Hadoop Common
  1. Hadoop Common
  2. HADOOP-9576

Make NetUtils.wrapException throw EOFException instead of wrapping it as IOException

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.0, 3.0.0
    • Fix Version/s: 2.6.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      In case of EOFException, NetUtils is now wrapping it as IOException, we may want to throw EOFException as it is, since EOFException can happen when connection is lost in the middle, the client may want to explicitly handle such exception

        Issue Links

          Activity

          Steve Loughran added a comment -

          Makes sense -that wrapping was meant to cover the expected problems and make them easier to diagnose -swallowing the common exception types was never the goal.

          Steve Loughran added a comment -

          I've seen this, and yes, it should be handled and marked as "connection torn town"

          2013-06-05 10:51:36,776 [AMRM Heartbeater thread] ERROR client.AMRMClientAsync (AMRMClientAsync.java:run(287)) - IO exception on heartbeat
          java.io.IOException: Failed on local exception: java.io.EOFException; Host Details : local host is: "stevel-2.local/192.168.1.85"; destination host is: "192.168.1.85":62370; 
          	at org.apache.hadoop.net.NetUtils.wrapException(NetUtils.java:764)
          	at org.apache.hadoop.ipc.Client.call(Client.java:1307)
          	at org.apache.hadoop.ipc.Client.call(Client.java:1255)
          	at org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.invoke(ProtobufRpcEngine.java:204)
          	at com.sun.proxy.$Proxy9.allocate(Unknown Source)
          	at org.apache.hadoop.yarn.api.impl.pb.client.AMRMProtocolPBClientImpl.allocate(AMRMProtocolPBClientImpl.java:75)
          	at org.apache.hadoop.yarn.client.AMRMClientImpl.allocate(AMRMClientImpl.java:234)
          	at org.apache.hadoop.yarn.client.AMRMClientAsync$HeartbeatThread.run(AMRMClientAsync.java:279)
          Caused by: java.io.EOFException
          	at java.io.DataInputStream.readInt(DataInputStream.java:375)
          	at org.apache.hadoop.ipc.Client$Connection.receiveRpcResponse(Client.java:948)
          	at org.apache.hadoop.ipc.Client$Connection.run(Client.java:845)
          

          We'll need a corresponding Wiki page along with the code patch

          Steve Loughran added a comment -

          patch, also fixes a cut and paste text error in the NoRouteToHost handler

          Steve Loughran added a comment -

          Wiki Entry is at https://wiki.apache.org/hadoop/EOFException - I had to cover FileSystem EOFs too, as well as things like HTTP channels shutting down early

          This is what the stack trace looks like

          java.io.EOFException: EOFException from  local host is: "stevel-2.local/192.168.1.85"; destination host is: "192.168.1.85":63514; java.io.EOFException; For more details see:  http://wiki.apache.org/hadoop/EOFException
          	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
          	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
          	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
          	at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
          	at org.apache.hadoop.net.NetUtils.wrapWithMessage(NetUtils.java:790)
          	at org.apache.hadoop.net.NetUtils.wrapException(NetUtils.java:764)
          	at org.apache.hadoop.ipc.Client.call(Client.java:1307)
          	at org.apache.hadoop.ipc.Client.call(Client.java:1255)
          	at org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.invoke(ProtobufRpcEngine.java:204)
          	at com.sun.proxy.$Proxy9.allocate(Unknown Source)
          	at org.apache.hadoop.yarn.api.impl.pb.client.AMRMProtocolPBClientImpl.allocate(AMRMProtocolPBClientImpl.java:75)
          	at org.apache.hadoop.yarn.client.AMRMClientImpl.allocate(AMRMClientImpl.java:234)
          	at org.apache.hadoop.yarn.client.AMRMClientAsync$HeartbeatThread.run(AMRMClientAsync.java:279)
          Caused by: java.io.EOFException
          	at java.io.DataInputStream.readInt(DataInputStream.java:375)
          	at org.apache.hadoop.ipc.Client$Connection.receiveRpcResponse(Client.java:948)
          	at org.apache.hadoop.ipc.Client$Connection.run(Client.java:845)
          
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12586310/HADOOP-9576-001.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/2600//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2600//console

          This message is automatically generated.

          Jian He added a comment -

          Steve, thanks for taking this over.
          Not related to this patch: there's already a getHostDetailsAsString method which is only used by wrapException(), can we make use of this method for all exception types for consistency.

          Steve Loughran added a comment -

          updated patch which

          1. follows Jian He's exception
          2. adds a test
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12586310/HADOOP-9576-001.patch
          against trunk revision eace218.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/5056//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/5056//console

          This message is automatically generated.

          Steve Loughran added a comment -

          jenkins applied the 2013 patch. deleting that .patch and resubmitting

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12680636/HADOOP-9576-003.patch
          against trunk revision eace218.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/5057//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/5057//console

          This message is automatically generated.

          Jian He added a comment -

          +1, committing

          Jian He added a comment -

          Committed to trunk and branch-2. thanks Steve !

          Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #6507 (See https://builds.apache.org/job/Hadoop-trunk-Commit/6507/)
          HADOOP-9576. Changed NetUtils#wrapException to throw EOFException instead of wrapping it as IOException. Contributed by Steve Loughran (jianhe: rev 86bf8c7193013834f67e03bd67a320cc080ef32c)

          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/NetUtils.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestNetUtils.java
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #2 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/2/)
          HADOOP-9576. Changed NetUtils#wrapException to throw EOFException instead of wrapping it as IOException. Contributed by Steve Loughran (jianhe: rev 86bf8c7193013834f67e03bd67a320cc080ef32c)

          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/NetUtils.java
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestNetUtils.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk #740 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/740/)
          HADOOP-9576. Changed NetUtils#wrapException to throw EOFException instead of wrapping it as IOException. Contributed by Steve Loughran (jianhe: rev 86bf8c7193013834f67e03bd67a320cc080ef32c)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/NetUtils.java
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestNetUtils.java
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Hdfs-trunk #1930 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1930/)
          HADOOP-9576. Changed NetUtils#wrapException to throw EOFException instead of wrapping it as IOException. Contributed by Steve Loughran (jianhe: rev 86bf8c7193013834f67e03bd67a320cc080ef32c)

          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestNetUtils.java
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/NetUtils.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #1954 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1954/)
          HADOOP-9576. Changed NetUtils#wrapException to throw EOFException instead of wrapping it as IOException. Contributed by Steve Loughran (jianhe: rev 86bf8c7193013834f67e03bd67a320cc080ef32c)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/NetUtils.java
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestNetUtils.java
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #6520 (See https://builds.apache.org/job/Hadoop-trunk-Commit/6520/)
          HADOOP-9576. Merging to branch-2.6 for hadoop-2.6.0-rc1. (acmurthy: rev 44feec7122f48c6ff6ec1a90347098447b67543b)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          Arun C Murthy added a comment -

          Merged this into branch-2.6 for hadoop-2.6.0-rc1.

          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #4 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/4/)
          HADOOP-9576. Merging to branch-2.6 for hadoop-2.6.0-rc1. (acmurthy: rev 44feec7122f48c6ff6ec1a90347098447b67543b)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk #742 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/742/)
          HADOOP-9576. Merging to branch-2.6 for hadoop-2.6.0-rc1. (acmurthy: rev 44feec7122f48c6ff6ec1a90347098447b67543b)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #1932 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1932/)
          HADOOP-9576. Merging to branch-2.6 for hadoop-2.6.0-rc1. (acmurthy: rev 44feec7122f48c6ff6ec1a90347098447b67543b)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #4 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/4/)
          HADOOP-9576. Merging to branch-2.6 for hadoop-2.6.0-rc1. (acmurthy: rev 44feec7122f48c6ff6ec1a90347098447b67543b)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #1956 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1956/)
          HADOOP-9576. Merging to branch-2.6 for hadoop-2.6.0-rc1. (acmurthy: rev 44feec7122f48c6ff6ec1a90347098447b67543b)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Mapreduce-trunk-Java8 #4 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/4/)
          HADOOP-9576. Merging to branch-2.6 for hadoop-2.6.0-rc1. (acmurthy: rev 44feec7122f48c6ff6ec1a90347098447b67543b)

          • hadoop-common-project/hadoop-common/CHANGES.txt

            People

            • Assignee:
              Steve Loughran
              Reporter:
              Jian He
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development