Description
I would like to recommend some mainly stylistic changes in the recent fix of http://issues.apache.org/jira/browse/HADOOP-886. The file in question is CodeFactory.java, and the reasons for the changes are:
- It is generally preferable to avoid multiple return statements.
- It is nearly always preferable to use curly braces and a newline after an if (condition).
- There's no benefit to doing the hash lookup twice in the common case (by calling contains and then get).
(1) and (2) are commonly found in Java coding style guidelines as they make the code more readable.
I'll attach the fix shortly.
Attachments
Attachments
Issue Links
- relates to
-
HDFS-318 Building Hadoop results in a lot of warnings
- Resolved