Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-alpha, 1.1.2
    • Fix Version/s: 1.2.0, 2.1.0-beta
    • Component/s: fs
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      typo:

      Index: src/core/org/apache/hadoop/fs/FileUtil.java
      ===================================================================
      --- src/core/org/apache/hadoop/fs/FileUtil.java	(revision 1467295)
      +++ src/core/org/apache/hadoop/fs/FileUtil.java	(working copy)
      @@ -178,7 +178,7 @@
           // Check if dest is directory
           if (!dstFS.exists(dst)) {
             throw new IOException("`" + dst +"': specified destination directory " +
      -                            "doest not exist");
      +                            "does not exist");
           } else {
             FileStatus sdst = dstFS.getFileStatus(dst);
             if (!sdst.isDir()) 
      
      1. HADOOP-9473.branch-1.patch
        0.6 kB
        Suresh Srinivas
      2. HADOOP-9473.patch
        0.7 kB
        Suresh Srinivas
      3. HADOOP-9473-update-testConf-b1.2.patch
        1 kB
        Jing Zhao

        Issue Links

          Activity

          Matt Foley added a comment -

          Closed upon release of Hadoop 1.2.0.

          Jing Zhao added a comment -

          Close this jira. Will create a separate jira to fix the inconsistency.

          Jing Zhao added a comment -

          Rename the patch.

          Jing Zhao added a comment -

          The patch for branch-1.2.

          Jing Zhao added a comment -

          We also needs to fix the same typo in testConf.xml accordingly. Otherwise TestCLI will fail.

          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1399 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1399/)
          HADOOP-9473. Add change description missed in previous commit 1467694 (Revision 1467696)
          HADOOP-9473. Typo in FileUtil copy() method. Contributed by Glen Mazza. (Revision 1467694)

          Result = SUCCESS
          suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1467696
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt

          suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1467694
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FileUtil.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #1372 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1372/)
          HADOOP-9473. Add change description missed in previous commit 1467694 (Revision 1467696)
          HADOOP-9473. Typo in FileUtil copy() method. Contributed by Glen Mazza. (Revision 1467694)

          Result = FAILURE
          suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1467696
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt

          suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1467694
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FileUtil.java
          Hudson added a comment -

          Integrated in Hadoop-Yarn-trunk #183 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/183/)
          HADOOP-9473. Add change description missed in previous commit 1467694 (Revision 1467696)
          HADOOP-9473. Typo in FileUtil copy() method. Contributed by Glen Mazza. (Revision 1467694)

          Result = SUCCESS
          suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1467696
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt

          suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1467694
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FileUtil.java
          Glen Mazza added a comment -

          OK, glad to hear you committed it, Suresh. I refuse to type up JUnit test cases for typos.

          Glen Mazza added a comment -

          Suresh, please don't assign this JIRA to me – I'm just a user entering in a JIRA over a typo --the only people who should be assigned JIRAs are committers. If the Hadoop project unfortunately requires committers to need to jump through a dozen hoops in order to fix a silly typo (no other Apache project I'm aware of requires JUnit tests for typos), that's a procedural problem you guys need to change, instead of just farming out such busywork to the people reporting the errors. And the alternative of having me type up a justification of why a JUnit test is not necessary for a typo is too silly to consider.

          If my further non-participation in this JIRA item means you need to close this item as a Won't Fix while keeping the misspelling in the code base, so be it. The Hadoop team is making it too crippling a process to resolve problems with their system, with the result that fewer and fewer people are going to bother reporting issues.

          Suresh Srinivas added a comment -

          I committed the patch to trunk, branch-2, branch-1 and branch-1.2. Thank you Glen.

          Hudson added a comment -

          Integrated in Hadoop-trunk-Commit #3613 (See https://builds.apache.org/job/Hadoop-trunk-Commit/3613/)
          HADOOP-9473. Add change description missed in previous commit 1467694 (Revision 1467696)
          HADOOP-9473. Typo in FileUtil copy() method. Contributed by Glen Mazza. (Revision 1467694)

          Result = SUCCESS
          suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1467696
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt

          suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1467694
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FileUtil.java
          Siddharth Seth added a comment -

          Looks good. +1.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12578469/HADOOP-9473.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/2447//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2447//console

          This message is automatically generated.

          Glen Mazza added a comment -

          Yes, I'll be quite happy to switch to the 2.0.x branch once HADOOP-9206 is fixed, and will attach patches from now on. Thanks!

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12578463/HADOOP-9373.patch
          against trunk revision .

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2446//console

          This message is automatically generated.

          Suresh Srinivas added a comment -

          Attaching the trunk patch.

          Suresh Srinivas added a comment -

          I don't know and don't care if the problem is in trunk

          The changes in Hadoop always first go to trunk and then to older releases to keep the trunk. Hence the question.

          I will see if I can talk to the folks who can help with HADOOP-9206 and see some progress is made on that.

          Glen Mazza added a comment -

          I don't know and don't care if the problem is in trunk, HADOOP-9206 makes trunk useless for me, forcing me to have to stay with the 1.1.x branch.

          Suresh Srinivas added a comment -

          Glen, please use a patch file to post the patch, instead of description. I am posting the patch from the description, this time. Is this problem in trunk?

          Glen Mazza added a comment -

          Suresh, I just posted the patch, it's in the description.

          Suresh Srinivas added a comment -

          Glen, would you like to work on this? If you post a patch, I will commit it. I have added you as a contributor and have assigned the jira to you.


            People

            • Assignee:
              Unassigned
              Reporter:
              Glen Mazza
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development