Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-9402

Ivy dependencies don't declare that commons-net is a core dependency

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Minor
    • Resolution: Won't Fix
    • 1.2.0
    • None
    • build
    • None

    Description

      HDFS-3148 changed NetUtils to use commons-net components, and in doing so
      added a dependency on commons-net into the core JARs. Previously it was only declared as a dependency for the ftp and s3-client configs.

      This impacts local ivy builds more than anything else.

      Attachments

        1. HADOOP-9402.patch
          1.0 kB
          Steve Loughran

        Issue Links

          Activity

            People

              stevel@apache.org Steve Loughran
              stevel@apache.org Steve Loughran
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: