Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-9387

TestDFVariations fails on Windows after the merge

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha1
    • Fix Version/s: 2.1.0-beta
    • Component/s: fs
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Test fails with the following errors:

      Running org.apache.hadoop.fs.TestDFVariations
      Tests run: 4, Failures: 0, Errors: 2, Skipped: 0, Time elapsed: 0.186 sec <<< FAILURE!
      testOSParsing(org.apache.hadoop.fs.TestDFVariations)  Time elapsed: 109 sec  <<< ERROR!
      java.io.IOException: Fewer lines of output than expected
              at org.apache.hadoop.fs.DF.parseOutput(DF.java:203)
              at org.apache.hadoop.fs.DF.getMount(DF.java:150)
              at org.apache.hadoop.fs.TestDFVariations.testOSParsing(TestDFVariations.java:59)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:597)
              at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:44)
              at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
              at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:41)
              at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
              at org.junit.internal.runners.statements.FailOnTimeout$1.run(FailOnTimeout.java:28)
      
      testGetMountCurrentDirectory(org.apache.hadoop.fs.TestDFVariations)  Time elapsed: 1 sec  <<< ERROR!
      java.io.IOException: Fewer lines of output than expected
              at org.apache.hadoop.fs.DF.parseOutput(DF.java:203)
              at org.apache.hadoop.fs.DF.getMount(DF.java:150)
              at org.apache.hadoop.fs.TestDFVariations.testGetMountCurrentDirectory(TestDFVariations.java:139)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:597)
              at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:44)
              at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
              at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:41)
              at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
              at org.junit.internal.runners.statements.FailOnTimeout$1.run(FailOnTimeout.java:28)
      
      1. HADOOP-9387.trunk.2.patch
        6 kB
        Ivan Mitic
      2. HADOOP-9387.trunk.patch
        2 kB
        Ivan Mitic

        Issue Links

          Activity

          ivanmi Ivan Mitic added a comment -

          Attaching the patch.

          With the refactoring done as part of HADOOP-7487, DF#parseOutput started being invoked on Windows and failing the test.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12572937/HADOOP-9387.trunk.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/2302//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2302//console

          This message is automatically generated.

          ivanmi Ivan Mitic added a comment -

          -1 overall. Here are the results of testing the latest attachment

          TestDFVariations already fails on Windows, no need to add a new test case.

          ivanmi Ivan Mitic added a comment -

          I see regressions in HDFS tests on Windows with this patch because HDFS invokes DF#getFileSystem() which in turn calls DF#run(). Canceling the patch until I address both.

          ivanmi Ivan Mitic added a comment -

          Attaching the new patch.

          A few notes:

          • Addressed the problem around DF#getFileSystem() on Windows, added a test case for the scenario
          • Since I already touched DF.java I used the opportunity to cleanup the unused code around OS type. Please comment if you think it is more appropriate to have this fixed via a separate Jira (it's a minor change so it should generally be fine).
          hadoopqa Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12573491/HADOOP-9387.trunk.2.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 tests included appear to have a timeout.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/2324//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2324//console

          This message is automatically generated.

          cnauroth Chris Nauroth added a comment -

          Hi Ivan,

          Thanks for working on cleaning it up. This code has tripped me up in the past.

            public String getFilesystem() throws IOException {
              if (Shell.WINDOWS) {
                this.filesystem = dirFile.getCanonicalPath().substring(0, 2);
                return this.filesystem;
              } else {
                run();
                return filesystem;
              }
            }
          

          It appears that there is a pitfall if running on non-Windows. If the user of this class calls getFilesystem before calling
          getMount, then filesystem will be uninitialized. This is because on non-Windows, we assign to the filesystem member variable inside parseOutput, which gets called from getMount, but not getFilesystem. Perhaps it's safer to move all of the parsing logic back into parseExecResult.

              switch(getOSType()) {
                case OS_TYPE_AIX:
                  Long.parseLong(tokens.nextToken()); // capacity
                  Long.parseLong(tokens.nextToken()); // available
                  Integer.parseInt(tokens.nextToken()); // pct used
                  tokens.nextToken();
                  tokens.nextToken();
                  this.mount = tokens.nextToken();
                  break;
          
                case OS_TYPE_WIN:
                case OS_TYPE_SOLARIS:
                case OS_TYPE_MAC:
                case OS_TYPE_UNIX:
                default:
                  Long.parseLong(tokens.nextToken()); // capacity
                  Long.parseLong(tokens.nextToken()); // used
                  Long.parseLong(tokens.nextToken()); // available
                  Integer.parseInt(tokens.nextToken()); // pct used
                  this.mount = tokens.nextToken();
                  break;
             }
          

          The patch removes the special handling for AIX, so I think this would cause a regression if running on that platform. I've never used AIX, but what I infer from the old code is that the output of df -k on Linux places mount in column 6, whereas on AIX it goes in column 7. Therefore, we need an extra call to StringTokenizer#nextToken if running on AIX. Unfortunately, I don't have access to an AIX machine to confirm. Perhaps this code could be simplified to always look at the last column without platform checks and special cases, i.e.:

          String[] columns = line.split();
          this.mount = columns[columns.length - 1];
          

          However, that would be dependent on AIX printing mount in the last column, and without an AIX machine, I can't confirm.

          I did confirm that the patch works for Windows, so maybe the simplest path forward is to prepare a smaller patch just for fixing Windows, and then file a follow-up jira for future refactoring work. That would give more time to track down someone with access to AIX to help with testing.

          ivanmi Ivan Mitic added a comment -

          Thanks for reviewing Chris!

          Hmm, something does not add up, looks like you are looking at the older version of source code Can you please check for this? I looked up the history and HADOOP-9337 removed the above special handling for AIX.

          cnauroth Chris Nauroth added a comment -

          +1 for the current patch.

          Sorry, Ivan. I saw removal of the now-unused OSType and assumed that your patch had also removed the AIX check. Since that part of the change was already addressed in HADOOP-9337, there is no concern.

          ivanmi Ivan Mitic added a comment -

          No worries, thanks for the review!

          szetszwo Tsz Wo Nicholas Sze added a comment -

          Questions: When getExecString() will be called? And why it should never be called on Windows?

          ivanmi Ivan Mitic added a comment -

          Questions: When getExecString() will be called? And why it should never be called on Windows?

          Thanks for reviewing Nicholas. getExecString() should/will never be called on Windows, as we don't need it to compute the file system/mount point (we assume the drive latter from the given path, no need to invoke shell tools like on Unix). Shell#run() will invoke getExecString() during its execution. Let me know if this answers your question.

          szetszwo Tsz Wo Nicholas Sze added a comment -

          Thanks a lot of the explanation.

          szetszwo Tsz Wo Nicholas Sze added a comment -

          I have committed this. Thanks, Ivan!

          Also, thanks Chris for reviewing this.

          hudson Hudson added a comment -

          Integrated in Hadoop-trunk-Commit #3510 (See https://builds.apache.org/job/Hadoop-trunk-Commit/3510/)
          HADOOP-9387. Fix DF so that it won't execute a shell command on Windows to compute the file system/mount point. Contributed by Ivan Mitic (Revision 1459642)

          Result = SUCCESS
          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1459642
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/DF.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestDFVariations.java
          hudson Hudson added a comment -

          Integrated in Hadoop-trunk-Commit #3511 (See https://builds.apache.org/job/Hadoop-trunk-Commit/3511/)
          Move HADOOP-9387 to Trunk in CHANGES.txt. (Revision 1459643)

          Result = SUCCESS
          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1459643
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          Integrated in Hadoop-Yarn-trunk #163 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/163/)
          Move HADOOP-9387 to Trunk in CHANGES.txt. (Revision 1459643)
          HADOOP-9387. Fix DF so that it won't execute a shell command on Windows to compute the file system/mount point. Contributed by Ivan Mitic (Revision 1459642)

          Result = FAILURE
          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1459643
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt

          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1459642
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/DF.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestDFVariations.java
          hudson Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #1352 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1352/)
          Move HADOOP-9387 to Trunk in CHANGES.txt. (Revision 1459643)
          HADOOP-9387. Fix DF so that it won't execute a shell command on Windows to compute the file system/mount point. Contributed by Ivan Mitic (Revision 1459642)

          Result = FAILURE
          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1459643
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt

          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1459642
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/DF.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestDFVariations.java
          hudson Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1380 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1380/)
          Move HADOOP-9387 to Trunk in CHANGES.txt. (Revision 1459643)
          HADOOP-9387. Fix DF so that it won't execute a shell command on Windows to compute the file system/mount point. Contributed by Ivan Mitic (Revision 1459642)

          Result = SUCCESS
          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1459643
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt

          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1459642
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/DF.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestDFVariations.java

            People

            • Assignee:
              ivanmi Ivan Mitic
              Reporter:
              ivanmi Ivan Mitic
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development