Hadoop Common
  1. Hadoop Common
  2. HADOOP-9247

parametrize Clover "generateXxx" properties to make them re-definable via -D in mvn calls

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.0, 2.0.3-alpha, 0.23.6
    • Fix Version/s: 2.0.3-alpha, 0.23.7
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The suggested parametrization is needed in order
      to be able to re-define these properties with "-Dk=v" maven options.
      For some reason the expressions declared in clover
      docs like "$

      {maven.clover.generateHtml}

      " (see http://docs.atlassian.com/maven-clover2-plugin/3.0.2/clover-mojo.html) do not work in that way.
      However, the parametrized properties are confirmed to work: e.g.
      -DcloverGenHtml=false switches off the Html generation, if defined <generateHtml>$

      {cloverGenHtml}

      </generateHtml>.

      The default values provided here exactly correspond to Clover defaults, so
      the behavior is 100% backwards compatible.

      1. HADOOP-9247-trunk.patch
        2 kB
        Ivan A. Veselovsky

        Activity

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1328 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1328/)
        Move HADOOP-9247 to release 0.23.7 section in CHANGES.txt (Revision 1439539)

        Result = SUCCESS
        suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1439539
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1300 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1300/)
        Move HADOOP-9247 to release 0.23.7 section in CHANGES.txt (Revision 1439539)

        Result = SUCCESS
        suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1439539
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #509 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/509/)
        HADOOP-9247. Merge r1438698 from trunk (Revision 1439533)

        Result = FAILURE
        suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1439533
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Yarn-trunk #111 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/111/)
        Move HADOOP-9247 to release 0.23.7 section in CHANGES.txt (Revision 1439539)

        Result = SUCCESS
        suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1439539
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-trunk-Commit #3286 (See https://builds.apache.org/job/Hadoop-trunk-Commit/3286/)
        Move HADOOP-9247 to release 0.23.7 section in CHANGES.txt (Revision 1439539)

        Result = SUCCESS
        suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1439539
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Suresh Srinivas added a comment -

        I merged the patch to branch-2 and 0.23.

        Ivan A. Veselovsky added a comment -

        Hi, Suresh,
        can you please also commit this patch to "branch-2" and "branch-0.23"?
        thanks in advance.

        Ivan A. Veselovsky added a comment -

        Hi, Chris,
        the problem "com_cenqua_clover/CoverageRecorder" you mentioned above addressed in HADOOP-9235.

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1325 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1325/)
        HADOOP-9247. Parametrize Clover generateXxx properties to make them re-definable via -D in mvn calls. Contributed by Ivan A. Veselovsky. (Revision 1438698)

        Result = FAILURE
        suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1438698
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1297 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1297/)
        HADOOP-9247. Parametrize Clover generateXxx properties to make them re-definable via -D in mvn calls. Contributed by Ivan A. Veselovsky. (Revision 1438698)

        Result = FAILURE
        suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1438698
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Yarn-trunk #108 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/108/)
        HADOOP-9247. Parametrize Clover generateXxx properties to make them re-definable via -D in mvn calls. Contributed by Ivan A. Veselovsky. (Revision 1438698)

        Result = FAILURE
        suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1438698
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-trunk-Commit #3281 (See https://builds.apache.org/job/Hadoop-trunk-Commit/3281/)
        HADOOP-9247. Parametrize Clover generateXxx properties to make them re-definable via -D in mvn calls. Contributed by Ivan A. Veselovsky. (Revision 1438698)

        Result = SUCCESS
        suresh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1438698
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/pom.xml
        Suresh Srinivas added a comment -

        Committed the patch to trunk. Thank you Chris for the review.

        Thank you Ivan for the work.

        Suresh Srinivas added a comment -

        +1 for the patch. I will commit it shortly.

        Chris Nauroth added a comment -

        +1 The patch looks good. I applied it to a local copy of trunk and tested using -DcloverGenXml=false to suppress XML generation.

        FYI, it appears that the HADOOP-8924 change to calculate version info using a Maven plugin is not playing well with Clover. When I ran with -Pclover, I was getting the error below. I had to make a change in hadoop-maven-plugins/pom.xml to work around it. The problem is unrelated to this patch, so I filed HADOOP-9249 to follow up separately.

        [INFO] --- hadoop-maven-plugins:3.0.0-SNAPSHOT:version-info (version-info) @ hadoop-common ---
        [CLOVER] FATAL ERROR: Clover could not be initialised. Are you sure you have Clover in the runtime classpath? (class java.lang.NoClassDefFoundError:com_cenqua_clover/CloverVersionInfo)
        
        ...
        
        [ERROR] Failed to execute goal org.apache.hadoop:hadoop-maven-plugins:3.0.0-SNAPSHOT:version-info (version-info) on project hadoop-common: Execution version-info of goal org.apache.hadoop:hadoop-maven-plugins:3.0.0-SNAPSHOT:version-info failed: A required class was missing while executing org.apache.hadoop:hadoop-maven-plugins:3.0.0-SNAPSHOT:version-info: com_cenqua_clover/CoverageRecorder
        
        Ivan A. Veselovsky added a comment -

        the fix is only for pom.xml, so it does not include any test modifications.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12566513/HADOOP-9247-trunk.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in .

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/2093//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2093//console

        This message is automatically generated.

        Ivan A. Veselovsky added a comment -

        the patch HADOOP-9247-trunk.patch is applicable to all 3 target branches: trunk, branch-2, branch-0.23


          People

          • Assignee:
            Ivan A. Veselovsky
            Reporter:
            Ivan A. Veselovsky
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development