Hadoop Common
  1. Hadoop Common
  2. HADOOP-8962

RawLocalFileSystem.listStatus fails when a child filename contains a colon

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 0.23.3
    • Fix Version/s: 2.0.3-alpha, 0.23.5
    • Component/s: fs
    • Labels:
      None

      Description

      If listStatus is called on a directory that contains a file with a ':' in its name then it mistakenly thinks there is a scheme being specified and an exception is thrown because of a relative URI.

        Issue Links

          Activity

          Jason Lowe created issue -
          Jason Lowe added a comment -

          One way this occurs is when a distributed cache archive is being localized and the archive contains files with ':' in their names. The job fails to start because localization fails with an exception like this:

          2012-10-22 21:04:03,636 INFO  [main] mapreduce.Job (Job.java:monitorAndPrintJob(1308)) - Job job_1350939622571_0001 failed with state FAILED due to: Application application_1350939622571_0001 failed 1 times due to AM Container for appattempt_1350939622571_0001_000001 exited with  exitCode: -1000 due to: RemoteTrace: 
          java.lang.IllegalArgumentException: java.net.URISyntaxException: Relative path in absolute URI: Net::SSL.3pm
          	at org.apache.hadoop.fs.Path.initialize(Path.java:157)
          	at org.apache.hadoop.fs.Path.<init>(Path.java:135)
          	at org.apache.hadoop.fs.Path.<init>(Path.java:58)
          	at org.apache.hadoop.fs.RawLocalFileSystem.listStatus(RawLocalFileSystem.java:361)
          	at org.apache.hadoop.fs.FileSystem.listStatus(FileSystem.java:1419)
          	at org.apache.hadoop.fs.FileSystem.listStatus(FileSystem.java:1459)
          	at org.apache.hadoop.fs.ChecksumFileSystem.listStatus(ChecksumFileSystem.java:569)
          	at org.apache.hadoop.yarn.util.FSDownload.changePermissions(FSDownload.java:262)
          	at org.apache.hadoop.yarn.util.FSDownload.changePermissions(FSDownload.java:264)
          	at org.apache.hadoop.yarn.util.FSDownload.changePermissions(FSDownload.java:264)
          	at org.apache.hadoop.yarn.util.FSDownload.changePermissions(FSDownload.java:264)
          	at org.apache.hadoop.yarn.util.FSDownload.call(FSDownload.java:206)
          	at org.apache.hadoop.yarn.util.FSDownload.call(FSDownload.java:1)
          	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
          	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
          	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
          	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
          	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
          	at java.lang.Thread.run(Thread.java:662)
          Caused by: java.net.URISyntaxException: Relative path in absolute URI: Net::SSL.3pm
          	at java.net.URI.checkPath(URI.java:1787)
          	at java.net.URI.<init>(URI.java:735)
          	at org.apache.hadoop.fs.Path.initialize(Path.java:154)
          	... 20 more
           at LocalTrace: 
          	org.apache.hadoop.yarn.exceptions.impl.pb.YarnRemoteExceptionPBImpl: java.net.URISyntaxException: Relative path in absolute URI: Net::SSL.3pm
          	at org.apache.hadoop.yarn.server.nodemanager.api.protocolrecords.impl.pb.LocalResourceStatusPBImpl.convertFromProtoFormat(LocalResourceStatusPBImpl.java:217)
          	at org.apache.hadoop.yarn.server.nodemanager.api.protocolrecords.impl.pb.LocalResourceStatusPBImpl.getException(LocalResourceStatusPBImpl.java:147)
          	at org.apache.hadoop.yarn.server.nodemanager.containermanager.localizer.ResourceLocalizationService$LocalizerRunner.update(ResourceLocalizationService.java:824)
          	at org.apache.hadoop.yarn.server.nodemanager.containermanager.localizer.ResourceLocalizationService$LocalizerTracker.processHeartbeat(ResourceLocalizationService.java:493)
          	at org.apache.hadoop.yarn.server.nodemanager.containermanager.localizer.ResourceLocalizationService.heartbeat(ResourceLocalizationService.java:222)
          	at org.apache.hadoop.yarn.server.nodemanager.api.impl.pb.service.LocalizationProtocolPBServiceImpl.heartbeat(LocalizationProtocolPBServiceImpl.java:46)
          	at org.apache.hadoop.yarn.proto.LocalizationProtocol$LocalizationProtocolService$2.callBlockingMethod(LocalizationProtocol.java:57)
          	at org.apache.hadoop.ipc.ProtobufRpcEngine$Server$ProtoBufRpcInvoker.call(ProtobufRpcEngine.java:474)
          	at org.apache.hadoop.ipc.RPC$Server.call(RPC.java:1018)
          	at org.apache.hadoop.ipc.Server$Handler.run(Server.java:1738)
          Caused by: org.apache.hadoop.yarn.exceptions.impl.pb.YarnRemoteExceptionPBImpl: Relative path in absolute URI: Net::SSL.3pm
          	at org.apache.hadoop.yarn.exceptions.impl.pb.YarnRemoteExceptionPBImpl.getCause(YarnRemoteExceptionPBImpl.java:94)
          	at org.apache.hadoop.yarn.exceptions.YarnRemoteException.getCause(YarnRemoteException.java:25)
          	at java.lang.Throwable.printStackTrace(Throwable.java:514)
          	at org.apache.hadoop.yarn.exceptions.YarnRemoteException.printStackTrace(YarnRemoteException.java:48)
          	at org.apache.hadoop.util.StringUtils.stringifyException(StringUtils.java:70)
          	at org.apache.hadoop.yarn.server.nodemanager.containermanager.container.ContainerImpl$ResourceFailedTransition.transition(ContainerImpl.java:701)
          	at org.apache.hadoop.yarn.server.nodemanager.containermanager.container.ContainerImpl$ResourceFailedTransition.transition(ContainerImpl.java:1)
          	at org.apache.hadoop.yarn.state.StateMachineFactory$SingleInternalArc.doTransition(StateMachineFactory.java:359)
          	at org.apache.hadoop.yarn.state.StateMachineFactory.doTransition(StateMachineFactory.java:299)
          	at org.apache.hadoop.yarn.state.StateMachineFactory.access$3(StateMachineFactory.java:287)
          	at org.apache.hadoop.yarn.state.StateMachineFactory$InternalStateMachine.doTransition(StateMachineFactory.java:445)
          	at org.apache.hadoop.yarn.server.nodemanager.containermanager.container.ContainerImpl.handle(ContainerImpl.java:827)
          	at org.apache.hadoop.yarn.server.nodemanager.containermanager.container.ContainerImpl.handle(ContainerImpl.java:1)
          	at org.apache.hadoop.yarn.server.nodemanager.containermanager.ContainerManagerImpl$ContainerEventDispatcher.handle(ContainerManagerImpl.java:554)
          	at org.apache.hadoop.yarn.server.nodemanager.containermanager.ContainerManagerImpl$ContainerEventDispatcher.handle(ContainerManagerImpl.java:1)
          	at org.apache.hadoop.yarn.event.AsyncDispatcher.dispatch(AsyncDispatcher.java:128)
          	at org.apache.hadoop.yarn.event.AsyncDispatcher$1.run(AsyncDispatcher.java:77)
          	at java.lang.Thread.run(Thread.java:662)
          
          .Failing this attempt.. Failing the application.
          

          RawLocalFileSystem.listStatus is assuming that for a directory Path X it can create Path objects for each filename Y under the directory by calling Path(X, new Path(Y)), but this fails if Y contains a colon character. It needs to fully qualify the path so the Path constructor doesn't try to parse the child filename looking for a URI scheme that isn't there.

          Jason Lowe made changes -
          Field Original Value New Value
          Assignee Jason Lowe [ jlowe ]
          Jason Lowe added a comment -

          Patch to have RawLocalFileSystem.listStatus qualify the child paths to prevent the Path from mistaking any colon in a filename as being part of a URI.

          Jason Lowe made changes -
          Attachment HADOOP-8962.patch [ 12550460 ]
          Jason Lowe made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Target Version/s 2.0.3-alpha, 0.23.5 [ 12323273, 12323314 ]
          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12550460/HADOOP-8962.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/1665//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1665//console

          This message is automatically generated.

          Robert Joseph Evans added a comment -

          The patch is simple and it fixes the test. +1. It looks like Path may be something to look at too, but Path is a scarier change so I am happy to check this one in.

          Robert Joseph Evans added a comment -

          Thanks Jason,
          I put this into trunk, branch-2, and branch-0.23

          Robert Joseph Evans made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Fix Version/s 3.0.0 [ 12320357 ]
          Fix Version/s 2.0.3-alpha [ 12323273 ]
          Fix Version/s 0.23.5 [ 12323314 ]
          Resolution Fixed [ 1 ]
          Hudson added a comment -

          Integrated in Hadoop-trunk-Commit #2913 (See https://builds.apache.org/job/Hadoop-trunk-Commit/2913/)
          HADOOP-8962. RawLocalFileSystem.listStatus fails when a child filename contains a colon (jlowe via bobby) (Revision 1401325)

          Result = SUCCESS
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1401325
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/RawLocalFileSystem.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestLocalFileSystem.java
          Hudson added a comment -

          Integrated in Hadoop-Yarn-trunk #13 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/13/)
          HADOOP-8962. RawLocalFileSystem.listStatus fails when a child filename contains a colon (jlowe via bobby) (Revision 1401325)

          Result = FAILURE
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1401325
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/RawLocalFileSystem.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestLocalFileSystem.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Build #414 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/414/)
          svn merge -c 1401325 FIXES: HADOOP-8962. RawLocalFileSystem.listStatus fails when a child filename contains a colon (jlowe via bobby) (Revision 1401328)

          Result = SUCCESS
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1401328
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/RawLocalFileSystem.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestLocalFileSystem.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #1205 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1205/)
          HADOOP-8962. RawLocalFileSystem.listStatus fails when a child filename contains a colon (jlowe via bobby) (Revision 1401325)

          Result = FAILURE
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1401325
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/RawLocalFileSystem.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestLocalFileSystem.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1235 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1235/)
          HADOOP-8962. RawLocalFileSystem.listStatus fails when a child filename contains a colon (jlowe via bobby) (Revision 1401325)

          Result = SUCCESS
          bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1401325
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/RawLocalFileSystem.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestLocalFileSystem.java
          Chris Nauroth made changes -
          Link This issue breaks HADOOP-9131 [ HADOOP-9131 ]
          Thomas Graves made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          shanyu zhao made changes -
          Link This issue breaks HADOOP-9774 [ HADOOP-9774 ]
          Allen Wittenauer made changes -
          Fix Version/s 3.0.0 [ 12320357 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Patch Available Patch Available
          16h 8m 1 Jason Lowe 23/Oct/12 15:05
          Patch Available Patch Available Resolved Resolved
          1h 48m 1 Robert Joseph Evans 23/Oct/12 16:53
          Resolved Resolved Closed Closed
          106d 1h 11m 1 Thomas Graves 06/Feb/13 17:05

            People

            • Assignee:
              Jason Lowe
              Reporter:
              Jason Lowe
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development