Hadoop Common
  1. Hadoop Common
  2. HADOOP-8462

Native-code implementation of bzip2 codec

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.23.1
    • Fix Version/s: 0.23.7, 2.1.0-beta
    • Component/s: io
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed
    • Tags:
      bzip2 codec native-code

      Description

      The bzip2 codec supplied with Hadoop is currently available only as a Java implementation. A version that uses the system bzip2 library can provide improved performance and a better memory footprint. This will also make it feasible to utilize alternative bzip2 libraries that may perform better for specific jobs.

      1. HADOOP-8462-0.23.patch
        63 kB
        Govind Kamat
      2. HADOOP-8462-trunk.patch
        66 kB
        Govind Kamat
      3. HADOOP-8462-trunk.patch
        66 kB
        Govind Kamat
      4. HADOOP-8462-0.23.patch
        62 kB
        Govind Kamat
      5. HADOOP-8462-trunk.patch
        66 kB
        Govind Kamat
      6. HADOOP-8462-2.0.2a.patch
        66 kB
        Govind Kamat
      7. HADOOP-8462-0.23.patch
        62 kB
        Govind Kamat
      8. HADOOP-8462-trunk.patch
        66 kB
        Govind Kamat
      9. HADOOP-8462-2.0.2a.patch
        66 kB
        Govind Kamat
      10. HADOOP-8462-trunk.patch
        62 kB
        Govind Kamat
      11. HADOOP-8462-trunk.1.patch
        62 kB
        Govind Kamat
      12. HADOOP-8462-2.0.2a.1.patch
        62 kB
        Govind Kamat
      13. HADOOP-8462-trunk.1.patch
        62 kB
        Govind Kamat
      14. HADOOP-8462-trunk.patch
        61 kB
        Jason Lowe
      15. HADOOP-8462-2.0.2a.patch
        61 kB
        Govind Kamat
      16. HADOOP-8462-trunk.patch
        61 kB
        Govind Kamat

        Activity

        Todd Lipcon added a comment -

        Hi Govind. What performance difference have you measured here?

        Govind Kamat added a comment -

        Hello, Todd. My preliminary runs showed improvement in performance and memory use; I'm in the process of measuring that with GridMix and will post the results here as I have them.

        Govind Kamat added a comment -

        Add native-code support for the bzip2 codec.

        Govind Kamat added a comment -

        The native-code codec shows a performance improvement of 10 to 15% over the pure-Java version using GridMix. With Intel's IPP libraries, the improvement is in the range of 50% or more.

        Jason Lowe added a comment -

        Moving to Patch Available so Jenkins can comment.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12567491/HADOOP-8462-2.0.2a.patch
        against trunk revision .

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2142//console

        This message is automatically generated.

        Jason Lowe added a comment -

        Argh, Jenkins picked the wrong patch to comment on and tried to apply the 2.0.2a patch to trunk which didn't work so well.

        I tried applying the trunk patch myself and building, and it doesn't build for me when trying to build with the native code. I get the error message, "Could NOT find BZip2 (missing: BZIP2_INCLUDE_DIR)"

        Govind Kamat added a comment -

        > I tried applying the trunk patch myself and building, and it doesn't build for me when trying to build with the native code. I get the error message, "Could NOT find BZip2 (missing: BZIP2_INCLUDE_DIR)"

        You may need to install the bzip2-devel package to make the header files available.

        Jason Lowe added a comment -

        Thanks Govind, silly me. I thought I had the bzip2-devel package installed in my trunk build setup but was mistaken.

        Uploading the patch again for Jenkins.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12568007/HADOOP-8462-trunk.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        -1 javac. The patch appears to cause the build to fail.

        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2149//console

        This message is automatically generated.

        Jason Lowe added a comment -

        Jenkins is running into the same problem I did – the bzip2 devel package isn't available.

        Can we change this so it builds with bzip2 native support upon request? That way we aren't adding another required dependency for Hadoop native builds, rather an optional dependency if people want the native support. I'm thinking along the lines of what was done for Snappy and fuse in HADOOP-8620.

        Govind Kamat added a comment -

        Updated patches to make native bzip2 support optional. Will include it automatically if the bzip2 library and headers are available. The mvn option "-Drequire.bzip2" has also been added.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12569039/HADOOP-8462-2.0.2a.1.patch
        against trunk revision .

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2180//console

        This message is automatically generated.

        Govind Kamat added a comment -

        Since Jenkins builds only against trunk, upload the trunk patch once again.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12569110/HADOOP-8462-trunk.1.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common:

        org.apache.hadoop.io.compress.TestCodec

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/2181//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2181//console

        This message is automatically generated.

        Govind Kamat added a comment -

        Relax warning in TestCodec if native bzip2 support is not compiled in.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12569137/HADOOP-8462-trunk.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/2183//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2183//console

        This message is automatically generated.

        Jason Lowe added a comment -

        Thanks for the updates, Govind. One thing I missed before is that there is a mixture of spaces and tabs in the patch. The tabs should be removed and replaced with spaces so it lines up correctly regardless of the tab stop setting with which it's being viewed. Could you also post the corresponding patch for branch-0.23?

        I gave the patch a test drive on a pseudo-distributed cluster, testing building with and without the bzip2-devel package installed, running the unit tests with the native bzip2 available, and verifying require.bzip2 works as intended. I also ran some randomtextwriter jobs with a relatively small amount of data (10MB). Using the native bzip2 codec for the output format codec was around 6.5x the job runtime performance of the pure Java codec for that (admittedly not real-world) scenario.

        Jason Lowe added a comment -

        Using the native bzip2 codec for the output format codec was around 6.5x the job runtime performance of the pure Java codec

        Sorry realized this was a bit unclear. It might sound like job runtime increased by 6.5x but it was less than 1/6th the original job runtime of the pure Java codec. I also tested interoperability between the native and pure Java codecs and they were each able to decompress the other's outputs.

        Govind Kamat added a comment -

        Updated patches. Thanks, Jason, for all your work with this JIRA.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12572052/HADOOP-8462-trunk.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        -1 one of tests included doesn't have a timeout.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/2262//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2262//console

        This message is automatically generated.

        Govind Kamat added a comment -

        Carried over TestCodec change that handles case where bzip2 headers are not available.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12572114/HADOOP-8462-0.23.patch
        against trunk revision .

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2264//console

        This message is automatically generated.

        Govind Kamat added a comment -

        Added timeout parameter to tests.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12572163/HADOOP-8462-trunk.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        -1 one of tests included doesn't have a timeout.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/2265//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2265//console

        This message is automatically generated.

        Govind Kamat added a comment -

        Added timeout parameter to two more tests.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12572213/HADOOP-8462-trunk.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        -1 one of tests included doesn't have a timeout.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/2268//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2268//console

        This message is automatically generated.

        Jason Lowe added a comment -

        The trunk patch looks good to me. The test complaints are spurious, as it gets confused when whitespace is changed on the line just before a Test decorator.

        I was not able to get the branch-0.23 patch to work. It's always missing the native support in libhadoop when I build, even when the bzip2-devel package is present. Looking at the top of the C code files:

        #if defined HADOOP_BZIP2_LIBRARY
        
        #include <config.h>
        ...
        

        HADOOP_BZIP2_LIBRARY is provided by config.h so it appears the #if defined line is too early in the file and therefore the native code is always skipped by the preprocessor. The code needs to look something like this:

        #if defined HAVE_CONFIG_H
          #include <config.h>
        #endif
        
        #if defined HADOOP_BZIP2_LIBRARY
        ...
        
        Govind Kamat added a comment -

        Updated patch for branch 0.23.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12572353/HADOOP-8462-0.23.patch
        against trunk revision .

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/2278//console

        This message is automatically generated.

        Jason Lowe added a comment -

        +1 will commit shortly.

        Jason Lowe added a comment -

        Thanks, Govind! I committed this to trunk, branch-2, and branch-0.23.

        Hudson added a comment -

        Integrated in Hadoop-trunk-Commit #3427 (See https://builds.apache.org/job/Hadoop-trunk-Commit/3427/)
        HADOOP-8462. Native-code implementation of bzip2 codec. Contributed by Govind Kamat (Revision 1453608)

        Result = SUCCESS
        jlowe : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1453608
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/pom.xml
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/CMakeLists.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/config.h.cmake
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/BZip2Codec.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Compressor.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Decompressor.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Factory.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/Bzip2Compressor.c
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/Bzip2Decompressor.c
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/org_apache_hadoop_io_compress_bzip2.h
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/resources/core-default.xml
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/io/compress/TestCodec.java
        Hudson added a comment -

        Integrated in Hadoop-Yarn-trunk #148 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/148/)
        HADOOP-8462. Native-code implementation of bzip2 codec. Contributed by Govind Kamat (Revision 1453608)

        Result = SUCCESS
        jlowe : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1453608
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/pom.xml
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/CMakeLists.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/config.h.cmake
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/BZip2Codec.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Compressor.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Decompressor.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Factory.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/Bzip2Compressor.c
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/Bzip2Decompressor.c
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/org_apache_hadoop_io_compress_bzip2.h
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/resources/core-default.xml
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/io/compress/TestCodec.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #546 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/546/)
        HADOOP-8462. Native-code implementation of bzip2 codec. Contributed by Govind Kamat (Revision 1453611)

        Result = UNSTABLE
        jlowe : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1453611
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/pom.xml
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/BZip2Codec.java
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Compressor.java
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Decompressor.java
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Factory.java
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/native/Makefile.am
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/native/configure.ac
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/Bzip2Compressor.c
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/Bzip2Decompressor.c
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/org_apache_hadoop_io_compress_bzip2.h
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/resources/core-default.xml
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/io/compress/TestCodec.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1337 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1337/)
        HADOOP-8462. Native-code implementation of bzip2 codec. Contributed by Govind Kamat (Revision 1453608)

        Result = SUCCESS
        jlowe : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1453608
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/pom.xml
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/CMakeLists.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/config.h.cmake
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/BZip2Codec.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Compressor.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Decompressor.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Factory.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/Bzip2Compressor.c
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/Bzip2Decompressor.c
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/org_apache_hadoop_io_compress_bzip2.h
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/resources/core-default.xml
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/io/compress/TestCodec.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1365 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1365/)
        HADOOP-8462. Native-code implementation of bzip2 codec. Contributed by Govind Kamat (Revision 1453608)

        Result = SUCCESS
        jlowe : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1453608
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/pom.xml
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/CMakeLists.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/config.h.cmake
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/BZip2Codec.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Compressor.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Decompressor.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/compress/bzip2/Bzip2Factory.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/Bzip2Compressor.c
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/Bzip2Decompressor.c
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/native/src/org/apache/hadoop/io/compress/bzip2/org_apache_hadoop_io_compress_bzip2.h
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/resources/core-default.xml
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/io/compress/TestCodec.java

          People

          • Assignee:
            Govind Kamat
            Reporter:
            Govind Kamat
          • Votes:
            0 Vote for this issue
            Watchers:
            14 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 672h
              672h
              Remaining:
              Remaining Estimate - 672h
              672h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development