Hadoop Common
  1. Hadoop Common
  2. HADOOP-8452

DN logs backtrace when running under jsvc and /jmx is loaded

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-alpha
    • Fix Version/s: 3.0.0, 2.0.2-alpha
    • Component/s: None
    • Labels:
      None
    • Target Version/s:

      Description

      Running the data node under jsvc and requesting /jmx falls victim to a kernel bug http://marc.info/?l=linux-kernel&m=133788505209725&w=2 which results in EACCES when open()ing /proc/self/fd to attempt to count the open filedescriptors.

      Hopefully someday we will have kernels with this bug fixed; in the meantime, the log spew which results is unpleasant:

      12270 2012-05-15 21:04:41,683 ERROR org.apache.hadoop.jmx.JMXJsonServlet: getting attribute OpenFileDescriptorCount of java.lang:type=OperatingSystem threw an exception
      12271 javax.management.RuntimeErrorException: java.lang.InternalError: errno: 13 error: Unable to open directory /proc/self/fd
      12272
      12273 at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.rethrow(DefaultMBeanServerInterceptor.java:858)
      12274 at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.rethrowMaybeMBeanException(DefaultMBeanServerInterceptor.java:869)
      12275 at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getAttribute(DefaultMBeanServerInterceptor.java:670)
      12276 at com.sun.jmx.mbeanserver.JmxMBeanServer.getAttribute(JmxMBeanServer.java:638)
      12277 at org.apache.hadoop.jmx.JMXJsonServlet.writeAttribute(JMXJsonServlet.java:314)
      12278 at org.apache.hadoop.jmx.JMXJsonServlet.listBeans(JMXJsonServlet.java:292)
      12279 at org.apache.hadoop.jmx.JMXJsonServlet.doGet(JMXJsonServlet.java:192)
      12280 at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
      12281 at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      12282 at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)
      12283 at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1221)
      12284 at org.apache.hadoop.http.HttpServer$QuotingInputFilter.doFilter(HttpServer.java:932)
      12285 at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
      12286 at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:399)
      12287 at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
      12288 at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)
      12289 at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:766)
      12290 at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:450)
      12291 at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:230)
      12292 at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
      12293 at org.mortbay.jetty.Server.handle(Server.java:326)
      12294 at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542)
      12295 at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:928)
      12296 at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:549)
      12297 at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:212)
      12298 at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)
      12299 at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:410)
      12300 at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582)
      12301 Caused by: java.lang.InternalError: errno: 13 error: Unable to open directory /proc/self/fd
      12302
      12303 at com.sun.management.UnixOperatingSystem.getOpenFileDescriptorCount(Native Method)
      12304 at sun.reflect.GeneratedMethodAccessor42.invoke(Unknown Source)
      12305 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      12306 at java.lang.reflect.Method.invoke(Method.java:597)
      12307 at com.sun.jmx.mbeanserver.ConvertingMethod.invokeWithOpenReturn(ConvertingMethod.java:167)
      12308 at com.sun.jmx.mbeanserver.MXBeanIntrospector.invokeM2(MXBeanIntrospector.java:96)
      12309 at com.sun.jmx.mbeanserver.MXBeanIntrospector.invokeM2(MXBeanIntrospector.java:33)
      12310 at com.sun.jmx.mbeanserver.MBeanIntrospector.invokeM(MBeanIntrospector.java:208)
      12311 at com.sun.jmx.mbeanserver.PerInterface.getAttribute(PerInterface.java:65)
      12312 at com.sun.jmx.mbeanserver.MBeanSupport.getAttribute(MBeanSupport.java:216)
      12313 at javax.management.StandardMBean.getAttribute(StandardMBean.java:358)
      12314 at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getAttribute(DefaultMBeanServerInterceptor.java:666)
      12315 ... 25 more

      we should catch the RuntimeErrorException and make it a debug().

      1. 95db1fa.txt
        1 kB
        Andy Isaacson
      2. hadoop-8447.patch
        1 kB
        Andy Isaacson
      3. hadoop-8447-2.patch
        2 kB
        Andy Isaacson
      4. hadoop-8447-2.patch
        2 kB
        Andy Isaacson

        Activity

        Arun C Murthy made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Arun C Murthy made changes -
        Fix Version/s 2.0.2-alpha [ 12322473 ]
        Fix Version/s 2.1.0-alpha [ 12321441 ]
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1097 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1097/)
        HADOOP-8452. DN logs backtrace when running under jsvc and /jmx is loaded (Andy Isaacson via bobby) (Revision 1344733)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1344733
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/jmx/JMXJsonServlet.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1063 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1063/)
        HADOOP-8452. DN logs backtrace when running under jsvc and /jmx is loaded (Andy Isaacson via bobby) (Revision 1344733)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1344733
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/jmx/JMXJsonServlet.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #2321 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2321/)
        HADOOP-8452. DN logs backtrace when running under jsvc and /jmx is loaded (Andy Isaacson via bobby) (Revision 1344733)

        Result = FAILURE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1344733
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/jmx/JMXJsonServlet.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #2376 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2376/)
        HADOOP-8452. DN logs backtrace when running under jsvc and /jmx is loaded (Andy Isaacson via bobby) (Revision 1344733)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1344733
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/jmx/JMXJsonServlet.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #2304 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2304/)
        HADOOP-8452. DN logs backtrace when running under jsvc and /jmx is loaded (Andy Isaacson via bobby) (Revision 1344733)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1344733
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/jmx/JMXJsonServlet.java
        Robert Joseph Evans made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Fix Version/s 2.0.1-alpha [ 12321441 ]
        Fix Version/s 3.0.0 [ 12320357 ]
        Resolution Fixed [ 1 ]
        Robert Joseph Evans added a comment -

        Thanks Andy,

        I checked this into trunk and branch-2.

        Robert Joseph Evans added a comment -

        +1 yes TestViewFsTrash has been failing intermittently for some time.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12530271/hadoop-8447-2.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/1060//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1060//console

        This message is automatically generated.

        Andy Isaacson added a comment -

        Robert,

        Thanks for offering to commit the patch! I've reuploaded it with the license grant checked.

        Also, just to be completely clear – the TestViewFsTrash regression does not appear to be related to my patch; and I didn't add a regression test due to the difficulty of testing a kernel-dependent failure.

        Andy Isaacson made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Andy Isaacson made changes -
        Attachment hadoop-8447-2.patch [ 12530271 ]
        Andy Isaacson added a comment -

        Re-uploading patch with license grant ticked.

        Robert Joseph Evans made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Robert Joseph Evans added a comment -

        Andy, The patch looks good and I would like to commit it, but I need you to upload the patch again, and this time click the button marked "Grant license to ASF for inclusion in ASF works..." Otherwise I cannot check it in.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12530257/hadoop-8447-2.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common:

        org.apache.hadoop.fs.viewfs.TestViewFsTrash

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/1058//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1058//console

        This message is automatically generated.

        Andy Isaacson made changes -
        Attachment hadoop-8447-2.patch [ 12530257 ]
        Andy Isaacson added a comment -

        Previous patch failed to compile because the import was in a different git commit (with my testing code).

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12530240/hadoop-8447.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 javac. The patch appears to cause the build to fail.

        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1057//console

        This message is automatically generated.

        Eli Collins made changes -
        Target Version/s 2.0.1-alpha [ 12321441 ]
        Eli Collins made changes -
        Project Hadoop HDFS [ 12310942 ] Hadoop Common [ 12310240 ]
        Key HDFS-3473 HADOOP-8452
        Affects Version/s 2.0.0-alpha [ 12320352 ]
        Affects Version/s 2.0.0-alpha [ 12320353 ]
        Target Version/s 2.0.1-alpha [ 12321440 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12530240/hadoop-8447.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 javac. The patch appears to cause the build to fail.

        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2547//console

        This message is automatically generated.

        Andy Isaacson made changes -
        Attachment hadoop-8447.patch [ 12530240 ]
        Andy Isaacson added a comment -

        Updated patch, fixes null-value problem.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12530137/95db1fa.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 javac. The patch appears to cause the build to fail.

        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2537//console

        This message is automatically generated.

        Eli Collins made changes -
        Target Version/s 2.0.1-alpha [ 12321440 ]
        Eli Collins made changes -
        Project Hadoop Common [ 12310240 ] Hadoop HDFS [ 12310942 ]
        Key HADOOP-8447 HDFS-3473
        Affects Version/s 2.0.0-alpha [ 12320353 ]
        Affects Version/s 2.0.0-alpha [ 12320352 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12530137/95db1fa.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 javac. The patch appears to cause the build to fail.

        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1054//console

        This message is automatically generated.

        Andy Isaacson added a comment -

        With this proposed fix, the JMX json contains the following:

        ...
            "MaxFileDescriptorCount" : 32768,
            "OpenFileDescriptorCount" : null,
        ...
        

        I'm not completely sure that "null" appearing here is kosher. Any feedback appreciated.

        Andy Isaacson made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Andy Isaacson made changes -
        Field Original Value New Value
        Attachment 95db1fa.txt [ 12530137 ]
        Andy Isaacson added a comment -

        Proposed fix.

        Andy Isaacson created issue -

          People

          • Assignee:
            Andy Isaacson
            Reporter:
            Andy Isaacson
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development