Hadoop Common
  1. Hadoop Common
  2. HADOOP-845

DFS -get and DFS -cat on a zip file generate different output

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.9.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      dfs -get file.gz localfile.gz and dfs -cat file.gz > /tmp/file.gz generate different output. dfs -get geenreates corect output but dfs -cat does not geenerate the right ouput.

        Issue Links

          Activity

          Mahadev konar created issue -
          weilei made changes -
          Field Original Value New Value
          Status Open [ 1 ] Patch Available [ 10002 ]
          Affects Version/s 0.9.1 [ 12312214 ]
          Hadoop QA added a comment -

          -1, because the patch command could not apply the latest attachment (http://issues.apache.org) as a patch to trunk revision r489707. Please note that this message is automatically generated and may represent a problem with the automation system and not the patch.

          weilei added a comment -

          Some codes are added to org.apache.hadoop.dfs.DFSShell.java. then we can cat gzip file like others

          weilei made changes -
          Attachment patch.txt [ 12347820 ]
          Hairong Kuang added a comment -

          Hadoop dfs -cat does not handle non-ascii bytes correctly. So it can not cat zipped files correctly. Wendy's patch to HADOOP-628 should also be able to fix this bug.

          Hairong Kuang made changes -
          Link This issue duplicates HADOOP-628 [ HADOOP-628 ]
          Hairong Kuang added a comment -

          Weilei's patch seems to implement zcat. You may refer to the method getRecordReader in hadoop.org.apache.mapred.TextInputFormat.java for a general implementation of zcat.

          Hairong Kuang added a comment -

          It's a duplicate of HADOOP-628.

          Hairong Kuang made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Doug Cutting made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Owen O'Malley made changes -
          Component/s dfs [ 12310710 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Patch Available Patch Available
          3d 10h 24m 1 weilei 25/Dec/06 09:23
          Patch Available Patch Available Resolved Resolved
          11d 9h 36m 1 Hairong Kuang 05/Jan/07 19:00
          Resolved Resolved Closed Closed
          28d 8h 26m 1 Doug Cutting 03/Feb/07 03:27

            People

            • Assignee:
              Unassigned
              Reporter:
              Mahadev konar
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development