Hadoop Common
  1. Hadoop Common
  2. HADOOP-8386

hadoop script doesn't work if 'cd' prints to stdout (default behavior in Ubuntu)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.2
    • Fix Version/s: 1.2.0, 3.0.0, 0.23.5
    • Component/s: scripts
    • Labels:
      None
    • Environment:

      Ubuntu

    • Hadoop Flags:
      Reviewed

      Description

      if the 'hadoop' script is run as 'bin/hadoop' on a distro where the 'cd' command prints to stdout, the script will fail due to this line: 'bin=`cd "$bin"; pwd`'

      Workaround: execute from the bin/ directory as './hadoop'

      Fix: change that line to 'bin=`cd "$bin" > /dev/null; pwd`'

      1. hadoop.diff
        0.3 kB
        Christopher Berner
      2. hadoop-8386.diff
        0.5 kB
        Andy Isaacson
      3. hadoop-8386-1.diff
        0.7 kB
        Andy Isaacson
      4. hadoop-8386-1.diff
        2 kB
        Harsh J

        Activity

        Christopher Berner added a comment -

        Suggested patch

        Christopher Berner added a comment -

        Fixes the 'hadoop' script to work on Ubuntu distro and others where the 'cd' command prints to stdout

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12526303/hadoop.diff
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/977//console

        This message is automatically generated.

        Allen Wittenauer added a comment -

        Does Ubuntu re-define the shell's built-in cd? If so, probably better if we call /bin/cd or /usr/bin/cd directly to avoid other weirdo alias definitions.

        Christopher Berner added a comment -

        I'm not sure, how would I check to see if it's redefined?

        Neither /bin/cd nor /usr/bin/cd seems to exist on Ubuntu

        Allen Wittenauer added a comment -

        Run the alias command. No cd in bin?(1) Is Ubuntu trying to be the AIX(2) equivalent of Linux? Sure seems that way given some of the other "this breaks on Ubuntu" JIRAs as of late.

        (1) - Yes, cd is almost always implemented as a shell built-in and that

        {/usr}

        /bin/cd is usually a shell script that directly calls that built-in. But using that should forcibly bypass any crazy aliasing that a user may inflict upon themselves.

        (2) - I recognize that AIX has gotten less and less weird over the past decade+. I also realize that a lot of people reading this will probably have no idea what I'm talking about since those same people already freak out of when faced with actual POSIX commands instead of the GNU hacks.

        Christopher Berner added a comment -

        I checked alias, and all I see is a bunch of aliases for 'ls' and 'grep', nothing for 'cd'.

        One thing worth noting, this seems to only happen in the Ubuntu Desktop edition, the Server edition doesn't have this problem.

        Harsh J added a comment -

        Hi Christopher,

        Is it cause the default Ubuntu shell is dash (http://manpages.ubuntu.com/manpages/lucid/man1/dash.1.html doesn't prove it though)? We try to make sure the hadoop script runs as a bash script (via a shebang…), and rely on bash's default cd behavior to not cause this. Perhaps some environment specific item on your desktop has overriden the default behavior?

        The cd builtin of bash does not print, nor has an option to do so (has -L and -P AFAIK, but neither enforces such a behavior). Must be some odd function wrapper, you can probably detect via "which cd" or "type cd"? What does it say?

        Andy Isaacson added a comment -

        If it's not an alias, cd hackery almost always is done using a shell function. Also, a /bin/cd command cannot work – running it would fork a child process, change directory of the child process, and then exit, having no impact on the parent shell process.

        To figure out what your cd is doing, in bash use "type cd".

        # first, define a function foo
        $ foo() { echo bar; }
        # now, run it
        $ foo
        bar
        $ type foo
        foo is a function
        foo () 
        { 
            echo bar
        }
        $
        

        In dash, type just says foo is a shell function. I bet the original user is using bash though.

        Fixes the 'hadoop' script to work on Ubuntu distro and others where the 'cd' command prints to stdout

        My ubuntu 12.04 install doesn't have any aliases or functions defined for cd, can you find out what package is installing the evil settings in /etc/bash_completion.d (most likely) and file an upstream bug?

        ubuntu@ubu-cdh-0:~$ type cd
        cd is a shell builtin
        
        Christopher Berner added a comment -

        Just checked my installation and I'm using bash and the output of "type cd" says "cd is a shell builtin".

        Will try and test this on a fresh install of 12.04 and see if I can reproduce it.

        Christopher Berner added a comment -

        Ok, I tracked down the problem here. This only happens when you have the CDPATH environment variable set, and is the same issue noticed by the GIT team (http://lists-archives.com/git/623754-installation-failure-caused-by-cdpath-environment-variable.html). With more information available here: http://fvue.nl/wiki/Bash:_cd_sometimes_echoing_current_directory

        Let me know if I can help with anything else!

        Harsh J added a comment -

        Interesting, thanks! This is from my zsh instance (CDPATH is preset to . in it already):

        ➜  ~  echo $CDPATH
        .
        ➜  ~  cd /
        ➜  /  cd etc
        ➜  /etc  cd
        ➜  ~  unset CDPATH
        ➜  ~  cd /
        ➜  /  cd etc
        ➜  /etc  cd
        ➜  ~  
        

        And from bash:

        ➜  ~  bash
        bash-3.2$ echo $CDPATH
        
        bash-3.2$ cd /
        bash-3.2$ cd etc
        bash-3.2$ export CDPATH=.
        bash-3.2$ cd /
        bash-3.2$ cd etc
        /etc
        bash-3.2$ 
        
        Harsh J added a comment -

        Chris,

        So should we be handling this for all forms of cd use where we rely on no outputs to be transmitted? Or just this fix would do? Do you see any other instances we'll need to fix as well?

        Or maybe if there's a way to unset the behavior for our script runs alone, that'd work too.

        Christopher Berner added a comment -

        I didn't run into any other scripts that had this issue, but yes it would need to be handled everywhere as far as I can tell. I think another option (besides explicitly ignoring the output) would be to just add "unset CDPATH" at the beginning of the script. I've used that in scripts that had issues with environment variables before, and it works just fine.

        Andy Isaacson added a comment -

        The Gnu Autoconf manual has this to say:
        http://www.gnu.org/software/autoconf/manual/autoconf-2.67/html_node/Special-Shell-Variables.html

        CDPATH
        When this variable is set it specifies a list of directories to search when invoking cd with a relative file name that did not start with ‘./’ or ‘../’. Posix 1003.1-2001 says that if a nonempty directory name from CDPATH is used successfully, cd prints the resulting absolute file name. Unfortunately this output can break idioms like ‘abs=`cd src && pwd`’ because abs receives the name twice. Also, many shells do not conform to this part of Posix; for example, zsh prints the result only if a directory name other than . was chosen from CDPATH.

        In practice the shells that have this problem also support unset, so you can work around the problem as follows:

        (unset CDPATH) >/dev/null 2>&1 && unset CDPATH

        You can also avoid output by ensuring that your directory name is absolute or anchored at ‘./’, as in ‘abs=`cd ./src && pwd`’.

        So the Bash behavior is specified by Posix, alas. It is specified to write to stdout not stderr, so the patch is correct in that regard (I was concerned we might also need 2>&1 or similar).

        So, LGTM. I'll upload a patch that conforms to test-patch expectations. Thanks for the contribution, Christopher!

        Andy Isaacson added a comment -

        Uploading version of Christopher's patch that test-patch can apply.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12547060/hadoop-8386.diff
        against trunk revision .

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1543//console

        This message is automatically generated.

        Andy Isaacson added a comment -

        Let's try that again, against trunk rather than branch-1 this time.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12547070/hadoop-8386-1.diff
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common:

        org.apache.hadoop.ha.TestZKFailoverController
        org.apache.hadoop.metrics2.impl.TestMetricsSystemImpl

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/1544//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1544//console

        This message is automatically generated.

        Christopher Berner added a comment -

        Awesome, thanks Andy! Glad to see this fixed

        Harsh J added a comment -

        Thanks Chris and Andy. Fixed mapred, yarn, and hdfs scripts as well (for trunk).

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #2852 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2852/)
        HADOOP-8386. hadoop script doesn't work if 'cd' prints to stdout (default behavior in Ubuntu). Contributed by Christopher Berner and Andy Isaacson. (harsh) (Revision 1391780)

        Result = SUCCESS
        harsh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1391780
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/bin/hadoop
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
        • /hadoop/common/trunk/hadoop-mapreduce-project/bin/mapred
        • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/bin/yarn
        Harsh J added a comment -

        I've committed the fix for both trunk and branch-1 scripts.

        Thanks Christopher and Andy!

        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #2789 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2789/)
        HADOOP-8386. hadoop script doesn't work if 'cd' prints to stdout (default behavior in Ubuntu). Contributed by Christopher Berner and Andy Isaacson. (harsh) (Revision 1391780)

        Result = SUCCESS
        harsh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1391780
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/bin/hadoop
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
        • /hadoop/common/trunk/hadoop-mapreduce-project/bin/mapred
        • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/bin/yarn
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #2811 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2811/)
        HADOOP-8386. hadoop script doesn't work if 'cd' prints to stdout (default behavior in Ubuntu). Contributed by Christopher Berner and Andy Isaacson. (harsh) (Revision 1391780)

        Result = FAILURE
        harsh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1391780
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/bin/hadoop
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
        • /hadoop/common/trunk/hadoop-mapreduce-project/bin/mapred
        • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/bin/yarn
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1180 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1180/)
        HADOOP-8386. hadoop script doesn't work if 'cd' prints to stdout (default behavior in Ubuntu). Contributed by Christopher Berner and Andy Isaacson. (harsh) (Revision 1391780)

        Result = SUCCESS
        harsh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1391780
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/bin/hadoop
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
        • /hadoop/common/trunk/hadoop-mapreduce-project/bin/mapred
        • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/bin/yarn
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1211 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1211/)
        HADOOP-8386. hadoop script doesn't work if 'cd' prints to stdout (default behavior in Ubuntu). Contributed by Christopher Berner and Andy Isaacson. (harsh) (Revision 1391780)

        Result = FAILURE
        harsh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1391780
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/bin/hadoop
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
        • /hadoop/common/trunk/hadoop-mapreduce-project/bin/mapred
        • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/bin/yarn
        Robert Joseph Evans added a comment -

        I pulled this into branch-0.23

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #392 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/392/)
        svn merge -c 1391780 FIXES: HADOOP-8386. hadoop script doesn't work if 'cd' prints to stdout (default behavior in Ubuntu). Contributed by Christopher Berner and Andy Isaacson. (harsh) (Revision 1392368)

        Result = UNSTABLE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1392368
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/bin/hadoop
        • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/bin/mapred
        • /hadoop/common/branches/branch-0.23/hadoop-yarn-project/hadoop-yarn/bin/yarn

          People

          • Assignee:
            Christopher Berner
            Reporter:
            Christopher Berner
          • Votes:
            0 Vote for this issue
            Watchers:
            10 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development