Hadoop Common
  1. Hadoop Common
  2. HADOOP-8157

TestRPCCallBenchmark#testBenchmarkWithWritable fails with RTE

    Details

    • Type: Test Test
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.24.0
    • Fix Version/s: 2.0.0-alpha, 0.23.7
    • Component/s: None
    • Labels:
      None

      Description

      Saw TestRPCCallBenchmark#testBenchmarkWithWritable fail with the following on jenkins:
      Caused by: java.lang.RuntimeException: IPC server unable to read call parameters: readObject can't find class java.lang.String

        Issue Links

          Activity

          Eli Collins added a comment -

          Full stacktrace:

          java.lang.RuntimeException: Deferred
          	at org.apache.hadoop.test.MultithreadedTestUtil$TestContext.checkException(MultithreadedTestUtil.java:129)
          	at org.apache.hadoop.test.MultithreadedTestUtil$TestContext.waitFor(MultithreadedTestUtil.java:120)
          	at org.apache.hadoop.ipc.RPCCallBenchmark.run(RPCCallBenchmark.java:274)
          	at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:69)
          	at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:83)
          	at org.apache.hadoop.ipc.TestRPCCallBenchmark.testBenchmarkWithWritable(TestRPCCallBenchmark.java:30)
          	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          	at java.lang.reflect.Method.invoke(Method.java:597)
          	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:44)
          	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
          	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:41)
          	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
          	at org.junit.internal.runners.statements.FailOnTimeout$1.run(FailOnTimeout.java:28)
          Caused by: java.lang.RuntimeException: IPC server unable to read call parameters: readObject can't find class java.lang.String
          	at org.apache.hadoop.ipc.Client.call(Client.java:1159)
          	at org.apache.hadoop.ipc.WritableRpcEngine$Invoker.invoke(WritableRpcEngine.java:225)
          	at $Proxy8.echo(Unknown Source)
          	at org.apache.hadoop.ipc.RPCCallBenchmark$4.doEcho(RPCCallBenchmark.java:398)
          	at org.apache.hadoop.ipc.RPCCallBenchmark$2.doAnAction(RPCCallBenchmark.java:358)
          	at org.apache.hadoop.test.MultithreadedTestUtil$RepeatingTestThread.doWork(MultithreadedTestUtil.java:219)
          	at org.apache.hadoop.test.MultithreadedTestUtil$TestingThread.run(MultithreadedTestUtil.java:187)
          

          Standard out:

          2012-03-09 04:25:00,114 WARN  ipc.Server (Server.java:processData(1562)) - Unable to read call parameters for client 67.195.138.24on connection protocol org.apache.hadoop.ipc.TestRPC$TestProtocol for rpcKind RPC_WRITABLE
          java.lang.RuntimeException: readObject can't find class java.lang.String
          	at org.apache.hadoop.io.ObjectWritable.loadClass(ObjectWritable.java:372)
          	at org.apache.hadoop.io.ObjectWritable.readObject(ObjectWritable.java:223)
          	at org.apache.hadoop.ipc.WritableRpcEngine$Invocation.readFields(WritableRpcEngine.java:156)
          	at org.apache.hadoop.ipc.Server$Connection.processData(Server.java:1560)
          	at org.apache.hadoop.ipc.Server$Connection.processOneRpc(Server.java:1515)
          	at org.apache.hadoop.ipc.Server$Connection.readAndProcess(Server.java:1369)
          	at org.apache.hadoop.ipc.Server$Listener.doRead(Server.java:684)
          	at org.apache.hadoop.ipc.Server$Listener$Reader.doRunLoop(Server.java:483)
          	at org.apache.hadoop.ipc.Server$Listener$Reader.run(Server.java:458)
          Caused by: java.lang.ClassNotFoundException: Class java.lang.String not found
          	at org.apache.hadoop.conf.Configuration.getClassByName(Configuration.java:1151)
          	at org.apache.hadoop.io.ObjectWritable.loadClass(ObjectWritable.java:368)
          	... 8 more
          2012-03-09 04:25:00,121 ERROR test.MultithreadedTestUtil (MultithreadedTestUtil.java:threadFailed(140)) - Failed!
          java.lang.RuntimeException: IPC server unable to read call parameters: readObject can't find class java.lang.String
          	at org.apache.hadoop.ipc.Client.call(Client.java:1159)
          	at org.apache.hadoop.ipc.WritableRpcEngine$Invoker.invoke(WritableRpcEngine.java:225)
          	at $Proxy8.echo(Unknown Source)
          	at org.apache.hadoop.ipc.RPCCallBenchmark$4.doEcho(RPCCallBenchmark.java:398)
          	at org.apache.hadoop.ipc.RPCCallBenchmark$2.doAnAction(RPCCallBenchmark.java:358)
          	at org.apache.hadoop.test.MultithreadedTestUtil$RepeatingTestThread.doWork(MultithreadedTestUtil.java:219)
          	at org.apache.hadoop.test.MultithreadedTestUtil$TestingThread.run(MultithreadedTestUtil.java:187)
          2012-03-09 04:25:00,123 INFO  ipc.Server (Server.java:stop(1909)) - Stopping server on 12345
          2012-03-09 04:25:00,124 WARN  ipc.Server (Server.java:processResponse(953)) - IPC Server Responder, call 
          
          Todd Lipcon added a comment -

          This failure is super-goofy. My hunch is it's something to do with non-threadsafe use of classloaders or some other bad synchronization, but I don't have much to go on. Any ideas?

          Todd Lipcon added a comment -

          I think I understand this bug. It's probably due to an error in HADOOP-6502. Patch and explanation en route.

          Todd Lipcon added a comment -

          I believe the problem is this:
          The cache added by HADOOP-6502 used a "null" value in the map as a negative cache entry for a class not found. However, it uses a WeakHashMap to avoid leaking references. The semantics of WeakHashMap are such that we could hit the following scenario:

          • check "containsKey()" for a given key, see it was there
          • GC runs and clears that key from the map
          • call "get" and return null.
          • Now we think it was a negative cache entry and throw ClassNotFoundException

          The fix here is to stop using nulls to cache the "not found" result. Instead, we insert a special sentinel value as a negative cache entry.

          Unfortunately it's diffcult to reproduce this on my box, but we've seen TestRPCCallBenchmark fail on Hudson a lot without this patch. So if we commit this, and we stop seeing the failures, we'll know we fixed the bug.

          Eli Collins added a comment -

          +1 Nice find, patch lgtm

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12519315/hadoop-8157.txt
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in .

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/741//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/741//console

          This message is automatically generated.

          Todd Lipcon added a comment -

          Committed to 0.23 and trunk

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #1914 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1914/)
          HADOOP-8157. Fix race condition in Configuration that could cause spurious ClassNotFoundExceptions after a GC. Contributed by Todd Lipcon. (Revision 1303634)

          Result = SUCCESS
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1303634
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #1988 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1988/)
          HADOOP-8157. Fix race condition in Configuration that could cause spurious ClassNotFoundExceptions after a GC. Contributed by Todd Lipcon. (Revision 1303634)

          Result = SUCCESS
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1303634
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Commit #704 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/704/)
          HADOOP-8157. Fix race condition in Configuration that could cause spurious ClassNotFoundExceptions after a GC. Contributed by Todd Lipcon. (Revision 1303633)

          Result = SUCCESS
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1303633
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          Integrated in Hadoop-Common-0.23-Commit #713 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/713/)
          HADOOP-8157. Fix race condition in Configuration that could cause spurious ClassNotFoundExceptions after a GC. Contributed by Todd Lipcon. (Revision 1303633)

          Result = SUCCESS
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1303633
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #1923 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1923/)
          HADOOP-8157. Fix race condition in Configuration that could cause spurious ClassNotFoundExceptions after a GC. Contributed by Todd Lipcon. (Revision 1303634)

          Result = ABORTED
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1303634
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Commit #721 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/721/)
          HADOOP-8157. Fix race condition in Configuration that could cause spurious ClassNotFoundExceptions after a GC. Contributed by Todd Lipcon. (Revision 1303633)

          Result = ABORTED
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1303633
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #992 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/992/)
          HADOOP-8157. Fix race condition in Configuration that could cause spurious ClassNotFoundExceptions after a GC. Contributed by Todd Lipcon. (Revision 1303634)

          Result = FAILURE
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1303634
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Build #205 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/205/)
          HADOOP-8157. Fix race condition in Configuration that could cause spurious ClassNotFoundExceptions after a GC. Contributed by Todd Lipcon. (Revision 1303633)

          Result = SUCCESS
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1303633
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Build #233 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/233/)
          HADOOP-8157. Fix race condition in Configuration that could cause spurious ClassNotFoundExceptions after a GC. Contributed by Todd Lipcon. (Revision 1303633)

          Result = FAILURE
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1303633
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1027 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1027/)
          HADOOP-8157. Fix race condition in Configuration that could cause spurious ClassNotFoundExceptions after a GC. Contributed by Todd Lipcon. (Revision 1303634)

          Result = SUCCESS
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1303634
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Jason Lowe added a comment -

          Even though the JIRA said it was merged into 0.23, this was one of those JIRAs that was "lost" when branch-0.23 became branch-2 and branch-0.23 was recreated.

          Ran across it on 0.23 and noticed it wasn't fixed, so I pulled it into branch-0.23. Again. Thanks, Todd!

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Build #497 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/497/)
          svn merge -c 1303634 FIXES: HADOOP-8157. Fix race condition in Configuration that could cause spurious ClassNotFoundExceptions after a GC. Contributed by Todd Lipcon. (Revision 1434412)

          Result = FAILURE
          jlowe : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1434412
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java

            People

            • Assignee:
              Todd Lipcon
              Reporter:
              Eli Collins
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development