Hadoop Common
  1. Hadoop Common
  2. HADOOP-8031

Configuration class fails to find embedded .jar resources; should use URL.openStream()

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-alpha
    • Fix Version/s: 2.0.2-alpha
    • Component/s: conf
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      While running a hadoop client within RHQ (monitoring software) using its classloader, I see this:

      2012-02-07 09:15:25,313 INFO [ResourceContainer.invoker.daemon-2] (org.apache.hadoop.conf.Configuration)- parsing jar:file:/usr/local/rhq-agent/data/tmp/rhq-hadoop-plugin-4.3.0-SNAPSHOT.jar6856622641102893436.classloader/hadoop-core-0.20.2+737+1.jar7204287718482036191.tmp!/core-default.xml
      2012-02-07 09:15:25,318 ERROR [InventoryManager.discovery-1] (rhq.core.pc.inventory.InventoryManager)- Failed to start component for Resource[id=16290, type=NameNode, key=NameNode:/usr/lib/hadoop-0.20, name=NameNode, parent=vg61l01ad-hadoop002.apple.com] from synchronized merge.
      org.rhq.core.clientapi.agent.PluginContainerException: Failed to start component for resource Resource[id=16290, type=NameNode, key=NameNode:/usr/lib/hadoop-0.20, name=NameNode, parent=vg61l01ad-hadoop002.apple.com].
      Caused by: java.lang.RuntimeException: core-site.xml not found
      at org.apache.hadoop.conf.Configuration.loadResource(Configuration.java:1308)
      at org.apache.hadoop.conf.Configuration.loadResources(Configuration.java:1228)
      at org.apache.hadoop.conf.Configuration.getProps(Configuration.java:1169)
      at org.apache.hadoop.conf.Configuration.set(Configuration.java:438)

      This is because the URL

      jar:file:/usr/local/rhq-agent/data/tmp/rhq-hadoop-plugin-4.3.0-SNAPSHOT.jar6856622641102893436.classloader/hadoop-core-0.20.2+737+1.jar7204287718482036191.tmp!/core-default.xml

      cannot be found by DocumentBuilder (doesn't understand it). (Note: the logs are for an old version of Configuration class, but the new version has the same code.)

      The solution is to obtain the resource stream directly from the URL object itself.

      That is to say:

               URL url = getResource((String)name);
      -        if (url != null) {
      -          if (!quiet) {
      -            LOG.info("parsing " + url);
      -          }
      -          doc = builder.parse(url.toString());
      -        }
      +        doc = builder.parse(url.openStream());
      

      Note: I have a full patch pending approval at Apple for this change, including some cleanup.

      1. HADOOP-8031-part2.patch
        2 kB
        Ahmed Radwan
      2. HADOOP-8031.patch
        3 kB
        Ahmed Radwan
      3. hadoop-8031.txt
        3 kB
        Eli Collins
      4. 0001-fix-HADOOP-7982-class-loader.patch
        3 kB
        Elias Ross

        Issue Links

          Activity

          Elias Ross added a comment -

          Simple patch

          Eli Collins added a comment -

          Thanks for contributing Elias. Can you update TestConfiguration with a case that will fail w/o your patch?

          I've rebased your patch on trunk.

          Eli Collins added a comment -

          Patch attached.

          Elias Ross added a comment -

          Eli,

          Thanks for your response. I would like to reproduce the problem but I'd have to somehow embed the .xml file inside a .jar and adjust the test classpath to match. I'd likely have to isolate the test from the rest of the existing classpath as well. Maybe you could guide me through this?

          Thanks.

          Ahmed Radwan added a comment -

          Thanks Elias,

          I have noticed that the patch no longer applies due to the recent changes to Configuration.java. I have made the required changes so it can apply cleanly on trunk.

          Also changed:

          +        doc = builder.parse((InputStream)name);
          

          to:

          +        doc = parse(builder, (InputStream) resource);
          

          to insure the InputStream will be closed.

          Regarding testing, I am not sure if there is an easy way to reproduce this issue in a unit test.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12542098/HADOOP-8031.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/1350//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1350//console

          This message is automatically generated.

          Alejandro Abdelnur added a comment -

          +1

          Alejandro Abdelnur added a comment -

          Thanks Elias. Committed to trunk and branch-2.

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #2632 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2632/)
          HADOOP-8031. Configuration class fails to find embedded .jar resources; should use URL.openStream() (genman via tucu) (Revision 1376772)

          Result = SUCCESS
          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376772
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #2696 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2696/)
          HADOOP-8031. Configuration class fails to find embedded .jar resources; should use URL.openStream() (genman via tucu) (Revision 1376772)

          Result = SUCCESS
          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376772
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #2660 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2660/)
          HADOOP-8031. Configuration class fails to find embedded .jar resources; should use URL.openStream() (genman via tucu) (Revision 1376772)

          Result = FAILURE
          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376772
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #1144 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1144/)
          HADOOP-8031. Configuration class fails to find embedded .jar resources; should use URL.openStream() (genman via tucu) (Revision 1376772)

          Result = FAILURE
          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376772
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1175 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1175/)
          HADOOP-8031. Configuration class fails to find embedded .jar resources; should use URL.openStream() (genman via tucu) (Revision 1376772)

          Result = FAILURE
          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376772
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Todd Lipcon added a comment -

          Hey Tucu. I think this commit broke the way in which relative xincludes are handled in Configuration. I have some development confs which use xinclude with non-absolute paths, and it used to successfully pick up the included files from my conf directory. Now, it seems to be looking in the current working directory instead.

          Is it possible to fix the code so that the relative paths are resolved the same as before? I think xinclude is relatively common for deployments.

          Todd Lipcon added a comment -

          I confirmed that reverting this patch locally restored the old behavior.

          If we can't maintain the old behavior, we should at least mark this as an incompatible change. But I bet it's doable to both fix it and have relative xincludes.

          Ahmed Radwan added a comment -

          Hi Todd, It is weird that this patch caused this behavior change. The patch didn't modify the builder or the docBuilderFactory, and it is still docBuilderFactory.setXIncludeAware(true). In essence, the patch is basically using DocumentBuilder#parse(InputStream uri.openStream()) instead of DocumentBuilder#parse(String uri.toString()). Seems there is a change in implementation of both parse methods, which seems weird.

          Todd Lipcon added a comment -

          Yea, I don't know much about the underlying API, but it definitely changed the behavior. It's still trying to do the xinclude, it's just looking in cwd instead of my conf dir.

          Ahmed Radwan added a comment -

          I looked into the implementation of javax.xml.parsers.DocumentBuilder and org.xml.sax.InputSource and there is a difference when the DocumentBuilder parse(String) method is used versus parse(InputStream). Basically we need to use parse(InputStream is, String systemId) which provides a base for resolving relative URIs. Here is a new patch that fixes this issue. It needs to be applied on top of the previously committed patch. I am not sure if we need to create a new ticket since this one is already committed.

          Eli Collins added a comment -

          I'd either file a new jira explaining the bug with a new patch with fix/test, or revert this patch and post a new one that includes the fix.

          Ahmed Radwan added a comment -

          Thanks Eli! I have created HADOOP-8749.

          Todd Lipcon added a comment -

          Re-resolving this since Ahmed is addressing my issue in HADOOP-8749

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #2758 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2758/)
          HADOOP-8749. HADOOP-8031 changed the way in which relative xincludes are handled in Configuration. (ahmed via tucu) (Revision 1381703)

          Result = SUCCESS
          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1381703
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/conf/TestConfiguration.java
          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #2695 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2695/)
          HADOOP-8749. HADOOP-8031 changed the way in which relative xincludes are handled in Configuration. (ahmed via tucu) (Revision 1381703)

          Result = SUCCESS
          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1381703
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/conf/TestConfiguration.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #2719 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2719/)
          HADOOP-8749. HADOOP-8031 changed the way in which relative xincludes are handled in Configuration. (ahmed via tucu) (Revision 1381703)

          Result = FAILURE
          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1381703
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/conf/TestConfiguration.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #1158 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1158/)
          HADOOP-8749. HADOOP-8031 changed the way in which relative xincludes are handled in Configuration. (ahmed via tucu) (Revision 1381703)

          Result = FAILURE
          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1381703
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/conf/TestConfiguration.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1189 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1189/)
          HADOOP-8749. HADOOP-8031 changed the way in which relative xincludes are handled in Configuration. (ahmed via tucu) (Revision 1381703)

          Result = SUCCESS
          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1381703
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/conf/TestConfiguration.java

            People

            • Assignee:
              Elias Ross
              Reporter:
              Elias Ross
            • Votes:
              1 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development