Hadoop Common
  1. Hadoop Common
  2. HADOOP-7878

Regression HADOOP-7777 switch changes break HDFS tests when the isSingleSwitch() predicate is used

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.23.0, 0.24.0
    • Fix Version/s: 0.23.1, 0.24.0
    • Component/s: util
    • Labels:

      Description

      This doesn't show up until you apply the HDFS-2492 patch, but the attempt to make the StaticMapping topology clever by deciding if it is single rack or multi rack based on its rack->node mapping breaks the HDFS TestBlocksWithNotEnoughRacks test. Why? Because the racks go in after the switch topology is cached by the BlockManager, which assumes the system is always single-switch.

      Fix: default to assuming multi-switch; remove the intelligence, add a setter for anyone who really wants to simulate single-switch racks.

      Test: verify that a newly created simple mapping is multi switch

      1. HADOOP-7878.patch
        3 kB
        Steve Loughran
      2. HADOOP-7878.patch
        3 kB
        Steve Loughran

        Issue Links

          Activity

          Steve Loughran added a comment -

          Patch removes the option to change the (static) switch mapping at all (so as to keep tests independent). It always returns false to the query "isSingleSwitch()"

          tests updated to verify behaviour is as now expected

          Steve Loughran added a comment -

          patch that passes hadoop common and hdfs tests locally

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12505897/HADOOP-7878.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 6 new or modified tests.

          -1 javadoc. The javadoc tool appears to have generated 15 warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in .

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/427//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/427//console

          This message is automatically generated.

          Steve Loughran added a comment -

          need to fix the javadoc warnings before committing

          Steve Loughran added a comment -

          looked at the javadocs; improved but no obvious reason for patch test failures; diffs don't show any new warnings.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12506853/HADOOP-7878.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 6 new or modified tests.

          -1 javadoc. The javadoc tool appears to have generated 5 warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in .

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/462//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/462//console

          This message is automatically generated.

          Steve Loughran added a comment -

          No javadoc warnings are being generated. This patch only touches test/ files that aren't included in the javadoc targets. Local diffs of before/after only show changes in download times/bandwidth

          $ cat patchJavadocWarnings.txt
          [INFO] Scanning for projects...
          [WARNING]
          [WARNING] Some problems were encountered while building the effective model for org.apache.hadoop:hadoop-common:jar:0.24.0-SNAPSHOT
          [WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.apache.hadoop:hadoop-hdfs:test-jar -> duplicate declaration of version $

          {project.version}

          @ org.apache.hadoop:hadoop-project:0.24.0-SNAPSHOT, /Users/slo/Java/Hadoop/github/trunk/hadoop-project/pom.xml, line 140, column 19
          [WARNING]
          [WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
          [WARNING]
          [WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
          [WARNING]
          [INFO]
          [INFO] ------------------------------------------------------------------------
          [INFO] Building Apache Hadoop Common 0.24.0-SNAPSHOT
          [INFO] ------------------------------------------------------------------------
          Downloading: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-annotations/0.24.0-SNAPSHOT/maven-metadata.xml
          Downloaded: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-annotations/0.24.0-SNAPSHOT/maven-metadata.xml (797 B at 0.3 KB/sec)
          Downloading: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-annotations/0.24.0-SNAPSHOT/hadoop-annotations-0.24.0-20111210.183528-1162.pom
          Downloaded: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-annotations/0.24.0-SNAPSHOT/hadoop-annotations-0.24.0-20111210.183528-1162.pom (2 KB at 2.9 KB/sec)
          Downloading: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-project/0.24.0-SNAPSHOT/maven-metadata.xml
          Downloaded: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-project/0.24.0-SNAPSHOT/maven-metadata.xml (828 B at 2.0 KB/sec)
          Downloading: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-project/0.24.0-SNAPSHOT/hadoop-project-0.24.0-20111210.183201-566.pom
          Downloaded: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-project/0.24.0-SNAPSHOT/hadoop-project-0.24.0-20111210.183201-566.pom (24 KB at 23.4 KB/sec)
          Downloading: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-main/0.24.0-SNAPSHOT/maven-metadata.xml
          Downloaded: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-main/0.24.0-SNAPSHOT/maven-metadata.xml (611 B at 1.6 KB/sec)
          Downloading: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-main/0.24.0-SNAPSHOT/hadoop-main-0.24.0-20111210.183200-306.pom
          Downloaded: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-main/0.24.0-SNAPSHOT/hadoop-main-0.24.0-20111210.183200-306.pom (13 KB at 20.5 KB/sec)
          Downloading: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-auth/0.24.0-SNAPSHOT/maven-metadata.xml
          Downloaded: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-auth/0.24.0-SNAPSHOT/maven-metadata.xml (1008 B at 2.6 KB/sec)
          Downloading: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-auth/0.24.0-SNAPSHOT/hadoop-auth-0.24.0-20111210.183530-1134.pom
          Downloaded: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-auth/0.24.0-SNAPSHOT/hadoop-auth-0.24.0-20111210.183530-1134.pom (7 KB at 9.8 KB/sec)
          Downloading: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-annotations/0.24.0-SNAPSHOT/hadoop-annotations-0.24.0-20111210.183528-1162.jar
          Downloading: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-auth/0.24.0-SNAPSHOT/hadoop-auth-0.24.0-20111210.183530-1134.jar
          Downloaded: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-annotations/0.24.0-SNAPSHOT/hadoop-annotations-0.24.0-20111210.183528-1162.jar (17 KB at 18.2 KB/sec)
          Downloaded: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-auth/0.24.0-SNAPSHOT/hadoop-auth-0.24.0-20111210.183530-1134.jar (42 KB at 26.8 KB/sec)
          [INFO]
          [INFO] — maven-clean-plugin:2.4.1:clean (default-clean) @ hadoop-common —
          [INFO] Deleting /Users/slo/Java/Hadoop/github/trunk/hadoop-common-project/hadoop-common/target
          [INFO]
          [INFO] — maven-antrun-plugin:1.6:run (create-testdirs) @ hadoop-common —
          [INFO] Executing tasks

          main:
          [mkdir] Created dir: /Users/slo/Java/Hadoop/github/trunk/hadoop-common-project/hadoop-common/target/test-dir
          [mkdir] Created dir: /Users/slo/Java/Hadoop/github/trunk/hadoop-common-project/hadoop-common/target/test/data
          [INFO] Executed tasks
          [INFO]
          [INFO] — build-helper-maven-plugin:1.5:add-source (add-source) @ hadoop-common —
          [INFO] Source directory: /Users/slo/Java/Hadoop/github/trunk/hadoop-common-project/hadoop-common/target/generated-sources/java added.
          [INFO]
          [INFO] — maven-antrun-plugin:1.6:run (compile-proto) @ hadoop-common —
          [INFO] Executing tasks

          main:
          [INFO] Executed tasks
          [INFO]
          [INFO] — maven-antrun-plugin:1.6:run (save-version) @ hadoop-common —
          [INFO] Executing tasks

          main:
          [INFO] Executed tasks
          [INFO]
          [INFO] — maven-resources-plugin:2.4.3:resources (default-resources) @ hadoop-common —
          [INFO] Using 'UTF-8' encoding to copy filtered resources.
          [INFO] Copying 2 resources
          [INFO]
          [INFO] — maven-compiler-plugin:2.3.2:compile (default-compile) @ hadoop-common —
          [INFO] Compiling 583 source files to /Users/slo/Java/Hadoop/github/trunk/hadoop-common-project/hadoop-common/target/classes
          [INFO]
          [INFO] — build-helper-maven-plugin:1.5:add-test-source (add-test-source) @ hadoop-common —
          [INFO] Test Source directory: /Users/slo/Java/Hadoop/github/trunk/hadoop-common-project/hadoop-common/target/generated-test-sources/java added.
          [INFO]
          [INFO] — avro-maven-plugin:1.5.3:schema (generate-avro-test-sources) @ hadoop-common —
          [INFO]
          [INFO] — avro-maven-plugin:1.5.3:protocol (generate-avro-test-sources) @ hadoop-common —
          [INFO]
          [INFO] — maven-antrun-plugin:1.6:run (compile-test-proto) @ hadoop-common —
          [INFO] Executing tasks

          main:
          [INFO] Executed tasks
          [INFO]
          [INFO] — maven-antrun-plugin:1.6:run (generate-test-sources) @ hadoop-common —
          [INFO] Executing tasks

          main:
          [INFO] Executed tasks
          [INFO]
          [INFO] — maven-resources-plugin:2.4.3:testResources (default-testResources) @ hadoop-common —
          [INFO] Using 'UTF-8' encoding to copy filtered resources.
          [INFO] Copying 11 resources
          [INFO]
          [INFO] — maven-antrun-plugin:1.6:run (create-log-dir) @ hadoop-common —
          [INFO] Executing tasks

          main:
          [delete] Deleting directory /Users/slo/Java/Hadoop/github/trunk/hadoop-common-project/hadoop-common/target/test/data
          [mkdir] Created dir: /Users/slo/Java/Hadoop/github/trunk/hadoop-common-project/hadoop-common/target/test/data
          [mkdir] Created dir: /Users/slo/Java/Hadoop/github/trunk/hadoop-common-project/hadoop-common/target/log
          [copy] Copying 4 files to /Users/slo/Java/Hadoop/github/trunk/hadoop-common-project/hadoop-common/target/test-classes
          [INFO] Executed tasks
          [INFO]
          [INFO] — maven-compiler-plugin:2.3.2:testCompile (default-testCompile) @ hadoop-common —
          [INFO] Compiling 276 source files to /Users/slo/Java/Hadoop/github/trunk/hadoop-common-project/hadoop-common/target/test-classes
          [INFO]
          [INFO] — maven-surefire-plugin:2.10:test (default-test) @ hadoop-common —
          [INFO] Tests are skipped.
          [INFO]
          [INFO] >>> maven-javadoc-plugin:2.7:javadoc (default-cli) @ hadoop-common >>>
          [INFO]
          [INFO] — maven-antrun-plugin:1.6:run (create-testdirs) @ hadoop-common —
          [INFO] Executing tasks

          main:
          [INFO] Executed tasks
          [INFO]
          [INFO] — build-helper-maven-plugin:1.5:add-source (add-source) @ hadoop-common —
          [INFO] Source directory: /Users/slo/Java/Hadoop/github/trunk/hadoop-common-project/hadoop-common/target/generated-sources/java added.
          [INFO]
          [INFO] — maven-antrun-plugin:1.6:run (compile-proto) @ hadoop-common —
          [INFO] Executing tasks

          main:
          [INFO] Executed tasks
          [INFO]
          [INFO] — maven-antrun-plugin:1.6:run (save-version) @ hadoop-common —
          [INFO] Executing tasks

          main:
          [INFO] Executed tasks
          [INFO]
          [INFO] <<< maven-javadoc-plugin:2.7:javadoc (default-cli) @ hadoop-common <<<
          [INFO]
          [INFO] — maven-javadoc-plugin:2.7:javadoc (default-cli) @ hadoop-common —
          [INFO]
          ExcludePrivateAnnotationsStandardDoclet
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD SUCCESS
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 1:17.934s
          [INFO] Finished at: Sun Dec 11 17:40:12 GMT 2011
          [INFO] Final Memory: 24M/114M
          [INFO] ------------------------------------------------------------------------

          Steve Loughran added a comment -

          Because I believe the javadocs are a false alarm, I am +1 to putting into trunk and 0.23

          Steve Loughran added a comment -

          Left the (now mostly redundant) tests in place just for regression testing

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Commit #260 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/260/)
          HADOOP-7878 Regression: HADOOP-7777 switch changes break HDFS tests when the isSingleSwitch() predicate is used

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1213264
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/StaticMapping.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestStaticMapping.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #1474 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1474/)
          HADOOP-7878 Regression: HADOOP-7777 switch changes break HDFS tests when the isSingleSwitch() predicate is used

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1213263
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/StaticMapping.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestStaticMapping.java
          Hudson added a comment -

          Integrated in Hadoop-Common-0.23-Commit #270 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/270/)
          HADOOP-7878 Regression: HADOOP-7777 switch changes break HDFS tests when the isSingleSwitch() predicate is used

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1213264
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/StaticMapping.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestStaticMapping.java
          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #1400 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1400/)
          HADOOP-7878 Regression: HADOOP-7777 switch changes break HDFS tests when the isSingleSwitch() predicate is used

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1213263
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/StaticMapping.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestStaticMapping.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Commit #280 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/280/)
          HADOOP-7878 Regression: HADOOP-7777 switch changes break HDFS tests when the isSingleSwitch() predicate is used

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1213264
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/StaticMapping.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestStaticMapping.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #1422 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1422/)
          HADOOP-7878 Regression: HADOOP-7777 switch changes break HDFS tests when the isSingleSwitch() predicate is used

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1213263
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/StaticMapping.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestStaticMapping.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Build #106 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/106/)
          HADOOP-7878 Regression: HADOOP-7777 switch changes break HDFS tests when the isSingleSwitch() predicate is used

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1213264
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/StaticMapping.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestStaticMapping.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Build #124 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/124/)
          HADOOP-7878 Regression: HADOOP-7777 switch changes break HDFS tests when the isSingleSwitch() predicate is used

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1213264
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/StaticMapping.java
          • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestStaticMapping.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #893 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/893/)
          HADOOP-7878 Regression: HADOOP-7777 switch changes break HDFS tests when the isSingleSwitch() predicate is used

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1213263
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/StaticMapping.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestStaticMapping.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #926 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/926/)
          HADOOP-7878 Regression: HADOOP-7777 switch changes break HDFS tests when the isSingleSwitch() predicate is used

          stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1213263
          Files :

          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/StaticMapping.java
          • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestStaticMapping.java

            People

            • Assignee:
              Steve Loughran
              Reporter:
              Steve Loughran
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 0.5h
                0.5h
                Remaining:
                Remaining Estimate - 0.5h
                0.5h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development