HADOOP-7734 expressed the desire to support downstream projects that depends on both 0.23+ and 0.20-security releases.
In order to achieve that we need to evolve the 0.23/trunk API a little to avoid name conflicts:
- Rename AbstractMetric to ImmutableMetric, which also address a common question sink implementer ask about thread safety.
- Rename MetricsRecord to ImmutableMetrics, ditto.
- Rename MetricsVisitor to MetricVisitor.
We better do it before 0.23 is released or, it will be an "incompatible" change.