Hadoop Common
  1. Hadoop Common
  2. HADOOP-7536

Correct the dependency version regressions introduced in HADOOP-6671

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.23.0
    • Fix Version/s: 0.23.0
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      I just noticed the versions specified for dependencies have gone backward with HADOOP-6671.
      To name a few,

      • commons-logging was 1.1.1, now 1.0.4
      • commons-logging-api was 1.1, now 1.0.4
      • slf4 was 1.5.11, now 1.5.8

      There might be more.

      1. HADOOP-7536.patch
        1 kB
        Alejandro Abdelnur

        Issue Links

          Activity

          Kihwal Lee added a comment -

          I compared hadoop-project/pom.xml and the last hadoop-common/ivy/libraries.propertie.
          There is one more:

          • hsqldb.version=1.8.0.10, 1.8.0.7
          Kihwal Lee added a comment -

          I believe hsqldb is only used in mapreduce, so it doesn't have to be in hadoop-common/pom.xml. All tests in hadoop-common are passing without it. Was there any reason it was downgraded from 1.8.0.10 to 1.8.0.7? We have been on 1.8.0.10 for over two years, so it doesn't seem like a merge error.

          Alejandro Abdelnur added a comment -

          I've got the versions manually from the ivy/libraries.properties file, I've either had a typo or those were the version in common/ivy/libraries.properties.

          If hadoop-commons does not use hsqldb please submit a patch removing it from hadoop-common/pom.xml.

          Alejandro Abdelnur added a comment -

          There are also other dependencies that are dubious, and I plan to follow up with a dependencies clean up JIRA.

          Kihwal Lee added a comment -

          I just happened to notice hsqldb and there may be more. As you said, these can be cleaned up in a separate JIRA.

          + 1 for the patch. Please make sure the new ones are published to the maven repo.

          Tom White added a comment -

          +1 I successfully ran the unit tests and test-patch (no new tests since this is bumping dependency version numbers):

          -1 overall.  
          
              +1 @author.  The patch does not contain any @author tags.
          
              -1 tests included.  The patch doesn't appear to include any new or modified tests.
                                  Please justify why no new tests are needed for this patch.
                                  Also please list what manual steps were performed to verify this patch.
          
              +1 javadoc.  The javadoc tool did not generate any warning messages.
          
              +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
          
              +1 findbugs.  The patch does not introduce any new Findbugs (version 1.3.9) warnings.
          
              +1 release audit.  The applied patch does not increase the total number of release audit warnings.
          
              +1 system test framework.  The patch passed system test framework compile.
          
          Tom White added a comment -

          I've just committed this. Thanks Alejandro.

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #746 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/746/)
          HADOOP-7536. Correct the dependency version regressions introduced in HADOOP-6671. Contributed by Alejandro Abdelnur.

          tomwhite : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1158347
          Files :

          • /hadoop/common/trunk/hadoop-common/CHANGES.txt
          • /hadoop/common/trunk/hadoop-project/pom.xml

            People

            • Assignee:
              Alejandro Abdelnur
              Reporter:
              Kihwal Lee
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development