Hadoop Common
  1. Hadoop Common
  2. HADOOP-7466 Hadoop Log improvement Umbrella
  3. HADOOP-7469

add a standard handler for socket connection problems which improves diagnostics

    Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.20.203.0, 0.23.0
    • Fix Version/s: 0.23.0, 0.24.0
    • Component/s: util
    • Labels:

      Description

      connection refused, connection timed out, no route to host, etc, are classic IOExceptions that can be raised in a lot of parts of the code. The standard JDK exceptions are useless for debugging as they

      1. don't include the destination (host, port) that can be used in diagnosing service dead/blocked problems
      2. don't include any source hostname that can be used to handle routing issues
      3. assume the reader understands the TCP stack.
        It's obvious from the -user lists that a lot of people hit these problems and don't know how to fix them. Sometimes the source has been patched to insert the diagnostics, but it may be convenient to have a single method to translate some
        SocketException processIOException(SocketException e, String destHost, int destPort) {
          String localhost = getLocalHostname();
          String details = "From "+ localhost +" to "+ desthost + ":"+destPort;
          if (e instanceof ConnectException) {
            return new ConnectException(details 
                    + " -- see http://wiki.apache.org/hadoop/ConnectionRefused --" + e, e);
          }
          if (e instanceof UnknownHostException) {
            return new UnknownHostException(details 
                    + " -- see http://wiki.apache.org/hadoop/UnknownHost --" + e, e);
          }
          // + handlers for other common socket exceptions
          
        //and a default that returns an unknown class unchanged
          return e;
        }
          
        

      Testing: try to connect to an unknown host, a local port that isn't live, etc. It's hard to replicate all failures consistently. It may be simpler just to verify that if you pass in a specific exception, the string is expanded and the class is unchanged.

      This code could then be patched in to places where IO takes place. Note that Http Components and HttpClient libs already add some destination details on some operation failures, with their own HttpException tree: it's simplest to leave these alone.

      1. HADOOP-7466-connection-handler.patch
        11 kB
        Steve Loughran
      2. HADOOP-7469.patch
        18 kB
        Steve Loughran
      3. HADOOP-7469.patch
        17 kB
        Steve Loughran
      4. HADOOP-7469.patch
        10 kB
        Uma Maheswara Rao G
      5. HADOOP-7469-3.patch
        11 kB
        Steve Loughran
      6. HADOOP-7469-b023.patch
        17 kB
        Steve Loughran

        Activity

        Uma Maheswara Rao G added a comment -

        Hi Steve,

        Already similar code exist in Client.java file.

        /**
           * Take an IOException and the address we were trying to connect to
           * and return an IOException with the input exception as the cause.
           * The new exception provides the stack trace of the place where 
           * the exception is thrown and some extra diagnostics information.
           * If the exception is ConnectException or SocketTimeoutException, 
           * return a new one of the same type; Otherwise return an IOException.
           * 
           * @param addr target address
           * @param exception the relevant exception
           * @return an exception to throw
           */
          private IOException wrapException(InetSocketAddress addr,
                                                 IOException exception) {
            if (exception instanceof ConnectException) {
              //connection refused; include the host:port in the error
              return (ConnectException)new ConnectException(
                   "Call to " + addr + " failed on connection exception: " + exception)
                            .initCause(exception);
            } else if (exception instanceof SocketTimeoutException) {
              return (SocketTimeoutException)new SocketTimeoutException(
                   "Call to " + addr + " failed on socket timeout exception: "
                              + exception).initCause(exception);
            } else {
              return (IOException)new IOException(
                   "Call to " + addr + " failed on local exception: " + exception)
                                         .initCause(exception);
        
            }
          }
        

        I think we can move this part to utils (NetUtils.java ? ) and can be added extra diagnostics information as you suggested right?

        Steve Loughran added a comment -

        yes, that code looks like something I'd have written in the past, though as it doesn't include source hostname it's still got room for improvement.

        Pulling this out and making it usable elsewhere would be the ideal starting place

        Uma Maheswara Rao G added a comment -

        Attached the patch for review!.

        for socketTimeOutException, i could not find the link in hadoop wiki. So, i did not add the http link.
        --Thanks

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12487608/HADOOP-7469.patch
        against trunk revision 1149760.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 system test framework. The patch passed system test framework compile.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/761//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HADOOP-Build/761//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/761//console

        This message is automatically generated.

        Steve Loughran added a comment -

        Here's an updated version
        -made some of the strings constant
        -shortened the line lengths
        -added the SocketTimeout wiki entry [http://wiki.apache.org/hadoop/SocketTimeout]
        -change the hostname display to quote hostnames (catches spaces in them) and to explicitly show when a host is null, as that's also a sign of trouble. For the bind exception we probably don't want to do the latter, so maybe that should be made switchable.

        I can imagine testing for this by wrapping exceptions and looking for the wiki entries, which we could make constant.

        Uma Maheswara Rao G added a comment -

        Hi Steve,
        Thanks a lot for review and updating the patch.

        -added the SocketTimeout wiki entry http://wiki.apache.org/hadoop/SocketTimeout

        Thanks for updating in wiki.

        Updated patch looks nice!

        Steve Loughran added a comment -

        except the patch is now out of date with SVN and my local trunk has tree conflict. I'll fix that then resubmit

        Steve Loughran added a comment -

        patch moved to the new hadoop-common layout.

        Steve Loughran added a comment -

        Previous patch fixed up for the new layout

        Steve Loughran added a comment -

        There's no test for this yet, so it's not ready to commit. The test could consist of verifying the target exceptions were extended, and that unknown exceptions were passed through untouched.

        Steve Loughran added a comment -

        Patch updated with tests to verify wrapping

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12496801/HADOOP-7469.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 6 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in .

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/239//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/239//console

        This message is automatically generated.

        Steve Loughran added a comment -

        Cancelling patch to add one more feature: log the exceptions in the test run. For human verification that the error messages make sense/look good.

        Steve Loughran added a comment -

        updated patch; position tests after HADOOP-7668 changes

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12496917/HADOOP-7469.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 6 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in .

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/242//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/242//console

        This message is automatically generated.

        Steve Loughran added a comment -

        +1 committing to trunk

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #1069 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1069/)
        HADOOP-7469 Add a standard handler for socket connection problems

        stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1177645
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Client.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/NetUtils.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/ipc/TestIPC.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestNetUtils.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #991 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/991/)
        HADOOP-7469 Add a standard handler for socket connection problems

        stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1177645
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Client.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/NetUtils.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/ipc/TestIPC.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestNetUtils.java
        Steve Loughran added a comment -

        Patch for branch 0.23

        Steve Loughran added a comment -

        branch 0.23 version of the patch with a filename to show this

        Steve Loughran added a comment -

        backported to 0.23

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #1070 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1070/)
        HADOOP-7469 backporting to 0.23; moving in CHANGES.TXT

        stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1177672
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #992 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/992/)
        HADOOP-7469 backporting to 0.23; moving in CHANGES.TXT

        stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1177672
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Build #32 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/32/)
        HADOOP-7469 backporting to 0.23

        stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1177673
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Client.java
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/NetUtils.java
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/ipc/TestIPC.java
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestNetUtils.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #846 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/846/)
        HADOOP-7469 backporting to 0.23; moving in CHANGES.TXT
        HADOOP-7469 Add a standard handler for socket connection problems

        stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1177672
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt

        stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1177645
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Client.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/NetUtils.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/ipc/TestIPC.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestNetUtils.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #1013 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1013/)
        HADOOP-7469 backporting to 0.23; moving in CHANGES.TXT
        HADOOP-7469 Add a standard handler for socket connection problems

        stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1177672
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt

        stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1177645
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Client.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/NetUtils.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/ipc/TestIPC.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestNetUtils.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #817 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/817/)
        HADOOP-7469 backporting to 0.23; moving in CHANGES.TXT
        HADOOP-7469 Add a standard handler for socket connection problems

        stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1177672
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt

        stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1177645
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Client.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/NetUtils.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/ipc/TestIPC.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestNetUtils.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #26 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/26/)
        HADOOP-7469 backporting to 0.23

        stevel : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1177673
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Client.java
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/net/NetUtils.java
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/ipc/TestIPC.java
        • /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/net/TestNetUtils.java

          People

          • Assignee:
            Steve Loughran
            Reporter:
            Steve Loughran
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 2h
              2h
              Remaining:
              Remaining Estimate - 2h
              2h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development