Hadoop Common
  1. Hadoop Common
  2. HADOOP-7461

Jackson Dependency Not Declared in Hadoop POM

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.20.205.0
    • Fix Version/s: 1.0.0
    • Component/s: build
    • Labels:
      None
    • Target Version/s:

      Description

      (COMMENT: This bug still affects 0.20.205.0, four months after the bug was filed. This causes total failure, and the fix is trivial for whoever manages the POM – just add the missing dependency! --ben)

      This issue was identified and the fix & workaround was documented at

      https://issues.cloudera.org/browse/DISTRO-44

      The issue affects use of Hadoop 0.20.203.0 from the Maven central repo. I built a job using that maven repo and ran it, resulting in this failure:

      Exception in thread "main" java.lang.NoClassDefFoundError: org/codehaus/jackson/map/JsonMappingException
      at thinkbig.hadoop.inputformat.TestXmlInputFormat.run(TestXmlInputFormat.java:18)
      at thinkbig.hadoop.inputformat.TestXmlInputFormat.main(TestXmlInputFormat.java:23)
      Caused by: java.lang.ClassNotFoundException: org.codehaus.jackson.map.JsonMappingException

      1. HADOOP-7461.patch
        0.5 kB
        Giridharan Kesavan
      2. HADOOP-7461-1.patch
        0.5 kB
        Giridharan Kesavan

        Activity

        Ron Bodkin created issue -
        Ben Wing added a comment -

        I've upgraded this to Major in the hope that someone will pay attention. This bug still affects 0.20.205.0, four months after the bug was filed. It causes total failure when running in non-distributed mode. The fix is trivial for whoever manages the POM – just add the missing dependency! It's a bad sign that a bug like this has persisted this long.

        Ben Wing made changes -
        Field Original Value New Value
        Affects Version/s 0.20.205.0 [ 12316390 ]
        Affects Version/s 0.20.2 [ 12314203 ]
        Priority Minor [ 4 ] Major [ 3 ]
        Description This issue was identified and the fix & workaround was documented at

        https://issues.cloudera.org/browse/DISTRO-44

        The issue affects use of Hadoop 0.20.203.0 from the Maven central repo. I built a job using that maven repo and ran it, resulting in this failure:

        Exception in thread "main" java.lang.NoClassDefFoundError: org/codehaus/jackson/map/JsonMappingException
        at thinkbig.hadoop.inputformat.TestXmlInputFormat.run(TestXmlInputFormat.java:18)
        at thinkbig.hadoop.inputformat.TestXmlInputFormat.main(TestXmlInputFormat.java:23)
        Caused by: java.lang.ClassNotFoundException: org.codehaus.jackson.map.JsonMappingException



        (COMMENT: This bug still affects 0.20.205.0, four months after the bug was filed. This causes total failure, and the fix is trivial for whoever manages the POM -- just add the missing dependency! --ben)

        This issue was identified and the fix & workaround was documented at

        https://issues.cloudera.org/browse/DISTRO-44

        The issue affects use of Hadoop 0.20.203.0 from the Maven central repo. I built a job using that maven repo and ran it, resulting in this failure:

        Exception in thread "main" java.lang.NoClassDefFoundError: org/codehaus/jackson/map/JsonMappingException
        at thinkbig.hadoop.inputformat.TestXmlInputFormat.run(TestXmlInputFormat.java:18)
        at thinkbig.hadoop.inputformat.TestXmlInputFormat.main(TestXmlInputFormat.java:23)
        Caused by: java.lang.ClassNotFoundException: org.codehaus.jackson.map.JsonMappingException



        Giridharan Kesavan made changes -
        Assignee Giridharan Kesavan [ gkesavan ]
        Giridharan Kesavan added a comment -

        updated the core pom template to include the jackson dependency.

        Giridharan Kesavan made changes -
        Attachment HADOOP-7461.patch [ 12507383 ]
        Matt Foley added a comment -

        Two comments:
        First, to request/propose that a bug be fixed in a given release, please add that release to the "Target Version" field in the bug report.
        Second, if the fix is trivial, please construct a patch for the fix, test it, and upload it to the Jira, rather than complaining that no one (else) has fixed it in four months.

        Matt Foley made changes -
        Target Version/s 1.0.0 [ 12318244 ]
        Matt Foley added a comment -

        Giri, two typos:
        + <artifactId>jackson-mapper-asl</groupId>
        should be
        + <artifactId>jackson-mapper-asl</artifactId>

        and the closing
        + <dependency>
        should be
        + </dependency>

        Giridharan Kesavan added a comment -

        mybad , fixed the typos.

        tested the patch by doing mvn-install and verified if the pom includes the jackson dependency.

        steps:
        ant -Dcompile.native=true -Dcompile.c++=true mvn-install
        check the mvn cache
        ~/.m2/repository/org/apache/hadoop/hadoop-core/1.0.1-SNAPSHOT/hadoop-core-1.0.1-SNAPSHOT.pom

        Giridharan Kesavan made changes -
        Attachment HADOOP-7461-1.patch [ 12507394 ]
        Matt Foley added a comment -

        +1. Please commit to branch-1.0 and branch-1. Thanks.

        Giridharan Kesavan added a comment -

        committed to both 1 and 1.0 branches, thanks Matt

        Giridharan Kesavan made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 1.0.0 [ 12318244 ]
        Fix Version/s 1.1.0 [ 12316501 ]
        Resolution Fixed [ 1 ]
        Matt Foley added a comment -

        Closed upon release of version 1.0.0.

        Matt Foley made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Matt Foley added a comment -

        This was indeed fixed in 1.0.0, so no need to note it as fixed in 1.1.0.

        Matt Foley made changes -
        Fix Version/s 1.1.0 [ 12316501 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        152d 19h 5m 1 Giridharan Kesavan 14/Dec/11 19:18
        Resolved Resolved Closed Closed
        13d 14h 44m 1 Matt Foley 28/Dec/11 10:03

          People

          • Assignee:
            Giridharan Kesavan
            Reporter:
            Ron Bodkin
          • Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development