Hadoop Common
  1. Hadoop Common
  2. HADOOP-7457

Remove out-of-date Chinese language documentation

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.21.0
    • Fix Version/s: 0.22.0, 0.23.0
    • Component/s: documentation
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The Chinese language documentation haven't been updated (other than copyright years and svn moves) since their original contribution several years ago. Worse than no docs is out-of-date, wrong docs. We should delete them from the source tree.

      1. HADOOP-7457.patch
        1.24 MB
        Jakob Homan

        Activity

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #811 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/811/)
        HADOOP-7457. Move to 0.22 branch section in CHANGES.txt

        shv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1175206
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #841 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/841/)
        HADOOP-7457. Move to 0.22 branch section in CHANGES.txt

        shv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1175206
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #966 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/966/)
        HADOOP-7457. Move to 0.22 branch section in CHANGES.txt

        shv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1175206
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Konstantin Shvachko added a comment -

        I applied Jacob's patch and deleted docs/cn in 0.22 branch.

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #1026 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1026/)
        HADOOP-7457. Move to 0.22 branch section in CHANGES.txt

        shv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1175206
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #948 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/948/)
        HADOOP-7457. Move to 0.22 branch section in CHANGES.txt

        shv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1175206
        Files :

        • /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Common-22-branch #76 (See https://builds.apache.org/job/Hadoop-Common-22-branch/76/)
        HADOOP-7457. build.xml correction.

        shv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1175205
        Files :

        • /hadoop/common/branches/branch-0.22/common/build.xml
        Hudson added a comment -

        Integrated in Hadoop-Common-22-branch #75 (See https://builds.apache.org/job/Hadoop-Common-22-branch/75/)
        HADOOP-7457. Remove out-of-date Chinese language documentation. Contributed by Jakob Homan

        shv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1175197
        Files :

        • /hadoop/common/branches/branch-0.22/common/CHANGES.txt
        • /hadoop/common/branches/branch-0.22/common/build.xml
        • /hadoop/common/branches/branch-0.22/common/src/docs/cn
        • /hadoop/common/branches/branch-0.22/common/src/fixFontsPath.sh
        Konstantin Shvachko added a comment -

        Reopening this to port changes to 0.22 branch. Currently common build fails because of that. See HADOOP-7394 and HADOOP-7303.

        Hudson added a comment -

        Integrated in Hadoop-Common-trunk #745 (See https://builds.apache.org/job/Hadoop-Common-trunk/745/)
        HADOOP-7457. Remove out-of-date Chinese language documentation. Contributed by Jakob Homan

        eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1145839
        Files :

        • /hadoop/common/trunk/common/src/docs/cn
        • /hadoop/common/trunk/common/CHANGES.txt
        • /hadoop/common/trunk/common/build.xml
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #687 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/687/)
        HADOOP-7457. Remove out-of-date Chinese language documentation. Contributed by Jakob Homan

        eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1145839
        Files :

        • /hadoop/common/trunk/common/src/docs/cn
        • /hadoop/common/trunk/common/CHANGES.txt
        • /hadoop/common/trunk/common/build.xml
        Eli Collins added a comment -

        +1

        I've committed this. Saw your last comment after committing. I svn rm'd src/docs/cn after applying your patch. Confirmed that all the cn files were removed and ant tar works.

        Jakob Homan added a comment -

        Odd. With the patch, there are still a few files in the cn directory. Not sure why they're not being deleted - can't seem to generate a patch that gets them. I've checked that the regular docs still build. If this gets +1'ed I'll svn rm the extraneous directories during commmit.

        Jakob Homan added a comment -

        Patch that removes the chinese documentation and necessary infrastructure to build it.

        Eli Collins added a comment -

        +1


          People

          • Assignee:
            Jakob Homan
            Reporter:
            Jakob Homan
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development