Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.23.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Incompatible change, Reviewed
    • Release Note:
      Hide
      Metrics names are standardized to use CapitalizedCamelCase. Some examples of this is:
      # Metrics names using "_" is changed to new naming scheme. Eg: bytes_written changes to BytesWritten.
      # All metrics names start with capitals. Example: threadsBlocked changes to ThreadsBlocked.
      Show
      Metrics names are standardized to use CapitalizedCamelCase. Some examples of this is: # Metrics names using "_" is changed to new naming scheme. Eg: bytes_written changes to BytesWritten. # All metrics names start with capitals. Example: threadsBlocked changes to ThreadsBlocked.
    • Tags:
      metrics2

      Description

      The jira tracks the metrics instrumentation for the new framework, i.e., porting jvm and rpc metrics to the new framework.

      This issue (esp. the "incompatible change flag") depends on the outcome of the discussion (proposed in HADOOP-6728) on whether we should support backward compatibility (at some cost.)

        Attachments

        1. hadoop-6920.v6.patch
          67 kB
          Suresh Srinivas
        2. hadoop-6920-metrics2-inst-v4.patch
          66 kB
          Luke Lu

          Issue Links

            Activity

              People

              • Assignee:
                vicaya Luke Lu
                Reporter:
                vicaya Luke Lu
              • Votes:
                0 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: