Hadoop Common
  1. Hadoop Common
  2. HADOOP-6899

RawLocalFileSystem#setWorkingDir() does not work for relative names

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.20.2
    • Fix Version/s: 0.22.0
    • Component/s: fs
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      RawLocalFileSystem#setWorkingDir() does not work for relative names

      1. 6899-6.patch
        47 kB
        Sanjay Radia
      2. 6899.y20.patch
        35 kB
        Suresh Srinivas
      3. 6899-5.patch
        47 kB
        Sanjay Radia
      4. 6899-4.patch
        47 kB
        Sanjay Radia
      5. 6899-3.patch
        47 kB
        Sanjay Radia
      6. 6899-2.patch
        48 kB
        Sanjay Radia
      7. 6899.patch
        47 kB
        Sanjay Radia

        Activity

        Hudson added a comment -

        Integrated in Hadoop-Common-trunk #507 (See https://hudson.apache.org/hudson/job/Hadoop-Common-trunk/507/)
        HADOOP-6899 RawLocalFileSystem#setWorkingDir() does not work for relative names

        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #418 (See https://hudson.apache.org/hudson/job/Hadoop-Common-trunk-Commit/418/)
        HADOOP-6899 RawLocalFileSystem#setWorkingDir() does not work for relative names

        Sanjay Radia added a comment -

        Committed the patch.

        Tsz Wo Nicholas Sze added a comment -

        +1
        6899-6.patch looks good.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12458860/6899-6.patch
        against trunk revision 1031422.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 20 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        +1 system test framework. The patch passed system test framework compile.

        Test results: https://hudson.apache.org/hudson/job/PreCommit-HADOOP-Build/25//testReport/
        Findbugs warnings: https://hudson.apache.org/hudson/job/PreCommit-HADOOP-Build/25//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: https://hudson.apache.org/hudson/job/PreCommit-HADOOP-Build/25//console

        This message is automatically generated.

        Sanjay Radia added a comment -

        Attached patch fixes the warning and is updated current trunk

        Suresh Srinivas added a comment -

        y20 version of the patch

        Sanjay Radia added a comment -

        The calling of the obsolete rename was intended (the tests we ported use that).
        Add a suppress warning tag.

        Tsz Wo Nicholas Sze added a comment -

        Here is the new javac warning

            [javac] /home/tsz/hadoop/common/testpatch-trunk/src/test/core/org/apache/hadoop/fs/FSMainOperationsBaseTest.java:1056:
         warning: [deprecation] rename(org.apache.hadoop.fs.Path,org.apache.hadoop.fs.Path,org.apache.hadoop.fs.Options.Rename...)
         in org.apache.hadoop.fs.FileSystem has been deprecated
            [javac]     fSys.rename(src, dst, options);
            [javac]         ^
        

        The javadoc warnings already exists in trunk and not related to this.

        The patch also passed all unit tests.

        Tsz Wo Nicholas Sze added a comment -
             [exec] -1 overall.  
             [exec] 
             [exec]     +1 @author.  The patch does not contain any @author tags.
             [exec] 
             [exec]     +1 tests included.  The patch appears to include 20 new or modified tests.
             [exec] 
             [exec]     -1 javadoc.  The javadoc tool appears to have generated 1 warning messages.
             [exec] 
             [exec]     -1 javac.  The applied patch generated 1018 javac compiler warnings (more than the trunk's current 1017 warnings).
             [exec] 
             [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
             [exec] 
             [exec]     +1 release audit.  The applied patch does not increase the total number of release audit warnings.
        
        Tsz Wo Nicholas Sze added a comment -

        +1 patch looks good.

        Sanjay Radia added a comment -

        Addressed Nicolas's feedback.

        Sanjay Radia added a comment -

        The attached path fixes the bug. I also backported one of more extensive tests for FileContext to FileSystem.

        Sanjay Radia added a comment -

        RawLocalFileSystem#setWorkingDiectory(path) if path is itself a relative path.
        It does not bother to convert it to an absolute path internally. Also, sadly, the existing tests for
        working directory never correctly checked if the setWorkingDirectory worked.


          People

          • Assignee:
            Sanjay Radia
            Reporter:
            Sanjay Radia
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development