Hadoop Common
  1. Hadoop Common
  2. HADOOP-6653

NullPointerException in setupSaslConnection when browsing directories

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      e currently get a NullPointerException when setting up SASL RPC connection as part of browsing the filesystem after
      being redirected to a datanode.

      1. c-6653-y20.patch
        1 kB
        Owen O'Malley

        Activity

        Devaraj Das added a comment -

        This is not applicable in trunk anymore.

        Arun C Murthy added a comment -

        Seems reasonable since loginUser is never null... +1

        Owen O'Malley added a comment -

        Trivial fix for y20.

        Owen O'Malley added a comment -

        Most namenode pages are ok, but the gridnodes are still inaccessible and dropping stack traces.

        http://dn.:50075/browseDirectory.jsp?namenodeInfoPort=50070&dir=%2F still failing:

        RequestURI=/browseDirectory.jsp
        Caused by:

        java.lang.NullPointerException
        at org.apache.hadoop.ipc.Client$Connection.setupSaslConnection(Client.java:365)
        at org.apache.hadoop.ipc.Client$Connection.access$900(Client.java:187)
        at org.apache.hadoop.ipc.Client$Connection$1.run(Client.java:438)
        at org.apache.hadoop.ipc.Client$Connection$1.run(Client.java:435)
        at java.security.AccessController.doPrivileged(Native Method)
        at javax.security.auth.Subject.doAs(Subject.java:396)
        at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:832)
        at org.apache.hadoop.ipc.Client$Connection.setupIOstreams(Client.java:435)
        at org.apache.hadoop.ipc.Client$Connection.access$1800(Client.java:187)
        at org.apache.hadoop.ipc.Client.getConnection(Client.java:1003)
        at org.apache.hadoop.ipc.Client.call(Client.java:863)
        at org.apache.hadoop.ipc.RPC$Invoker.invoke(RPC.java:222)
        at $Proxy7.getProtocolVersion(Unknown Source)
        at org.apache.hadoop.ipc.RPC.getProxy(RPC.java:360)
        at org.apache.hadoop.hdfs.DFSClient.createRPCNamenode(DFSClient.java:106)
        at org.apache.hadoop.hdfs.DFSClient.(DFSClient.java:208)
        at org.apache.hadoop.hdfs.DFSClient.(DFSClient.java:175)
        at org.apache.hadoop.hdfs.DFSClient.(DFSClient.java:165)
        at org.apache.hadoop.hdfs.server.namenode.JspHelper$1.run(JspHelper.java:484)
        at org.apache.hadoop.hdfs.server.namenode.JspHelper$1.run(JspHelper.java:482)
        at java.security.AccessController.doPrivileged(Native Method)
        at javax.security.auth.Subject.doAs(Subject.java:396)
        at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:832)
        at org.apache.hadoop.hdfs.server.namenode.JspHelper.getDFSClient(JspHelper.java:481)
        at
        org.apache.hadoop.hdfs.server.datanode.browseDirectory_jsp.generateDirectoryStructure(browseDirectory_jsp.java:50)
        at org.apache.hadoop.hdfs.server.datanode.browseDirectory_jsp._jspService(browseDirectory_jsp.java:208)
        at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
        at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:502)
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1124)
        at yjava.servlet.filter.BouncerFilter.doFilter(BouncerFilter.java:411)
        at com.yahoo.hadoop.HadoopBouncerFilter.doFilter(HadoopBouncerFilter.java:62)
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1115)
        at org.apache.hadoop.http.HttpServer$QuotingInputFilter.doFilter(HttpServer.java:781)
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1115)
        at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:361)
        at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
        at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
        at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:766)
        at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:417)
        at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:230)
        at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
        at org.mortbay.jetty.Server.handle(Server.java:324)
        at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:534)
        at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:864)
        at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:533)
        at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:207)
        at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:403)
        at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:409)
        at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:522)


          People

          • Assignee:
            Owen O'Malley
            Reporter:
            Owen O'Malley
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development