Hadoop Common
  1. Hadoop Common
  2. HADOOP-6233

Changes in common to rename the config keys as detailed in HDFS-531.

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.21.0
    • Fix Version/s: 0.21.0
    • Component/s: fs
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      This jira tracks the code changes required in common to rename the config keys. The list of changed keys is attached to HDFS-531.

      1. HADOOP-6233.8.patch
        45 kB
        Jitendra Nath Pandey
      2. HADOOP-6233.7.patch
        44 kB
        Jitendra Nath Pandey
      3. HADOOP-6233.6.patch
        44 kB
        Jitendra Nath Pandey
      4. HADOOP-6233.5.patch
        44 kB
        Jitendra Nath Pandey
      5. HADOOP-6233.4.patch
        43 kB
        Jitendra Nath Pandey
      6. HADOOP-6233.3.patch
        22 kB
        Jitendra Nath Pandey
      7. HADOOP-6233.2.patch
        22 kB
        Jitendra Nath Pandey
      8. HADOOP-6233.1.patch
        18 kB
        Jitendra Nath Pandey

        Issue Links

          Activity

          Gavin made changes -
          Link This issue depends upon HDFS-531 [ HDFS-531 ]
          Gavin made changes -
          Link This issue depends on HDFS-531 [ HDFS-531 ]
          Harsh J made changes -
          Link This issue is related to HADOOP-8727 [ HADOOP-8727 ]
          Eli Collins made changes -
          Link This issue is related to MAPREDUCE-3736 [ MAPREDUCE-3736 ]
          Tom White made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Robert Chansler made changes -
          Release Note Rename configuration keys towards API standardization and backward compatibility.
          Hide
          Robert Chansler added a comment -

          Editorial pass over all release notes prior to publication of 0.21. Subtask.

          Show
          Robert Chansler added a comment - Editorial pass over all release notes prior to publication of 0.21. Subtask.
          Hide
          Hudson added a comment -

          Integrated in Hadoop-Common-trunk #102 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk/102/)
          . Rename configuration keys towards API standardization and backward compatibility. Contributed by Jithendra Pandey.

          Show
          Hudson added a comment - Integrated in Hadoop-Common-trunk #102 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk/102/ ) . Rename configuration keys towards API standardization and backward compatibility. Contributed by Jithendra Pandey.
          Hide
          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #44 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk-Commit/44/)
          . Rename configuration keys towards API standardization and backward compatibility. Contributed by Jithendra Pandey.

          Show
          Hudson added a comment - Integrated in Hadoop-Common-trunk-Commit #44 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk-Commit/44/ ) . Rename configuration keys towards API standardization and backward compatibility. Contributed by Jithendra Pandey.
          Suresh Srinivas made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Hide
          Suresh Srinivas added a comment -

          Just committed this change. Thanks Jitendra.

          Show
          Suresh Srinivas added a comment - Just committed this change. Thanks Jitendra.
          Suresh Srinivas made changes -
          Component/s fs [ 12310689 ]
          Release Note Rename configuration keys towards API standardization and backward compatibility.
          Affects Version/s 0.21.0 [ 12313563 ]
          Hide
          Jakob Homan added a comment -

          +1 for updated patch, v8

          Show
          Jakob Homan added a comment - +1 for updated patch, v8
          Hide
          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12420075/HADOOP-6233.8.patch
          against trunk revision 816752.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 4 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/53/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/53/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/53/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/53/console

          This message is automatically generated.

          Show
          Hadoop QA added a comment - +1 overall. Here are the results of testing the latest attachment http://issues.apache.org/jira/secure/attachment/12420075/HADOOP-6233.8.patch against trunk revision 816752. +1 @author. The patch does not contain any @author tags. +1 tests included. The patch appears to include 4 new or modified tests. +1 javadoc. The javadoc tool did not generate any warning messages. +1 javac. The applied patch does not increase the total number of javac compiler warnings. +1 findbugs. The patch does not introduce any new Findbugs warnings. +1 release audit. The applied patch does not increase the total number of release audit warnings. +1 core tests. The patch passed core unit tests. +1 contrib tests. The patch passed contrib unit tests. Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/53/testReport/ Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/53/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/53/artifact/trunk/build/test/checkstyle-errors.html Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/53/console This message is automatically generated.
          Jitendra Nath Pandey made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Jitendra Nath Pandey made changes -
          Attachment HADOOP-6233.8.patch [ 12420075 ]
          Jakob Homan made changes -
          Hadoop Flags [Reviewed]
          Hide
          Jakob Homan added a comment -

          +1 pending Hudson or unit tests/test patch.

          Show
          Jakob Homan added a comment - +1 pending Hudson or unit tests/test patch.
          Jitendra Nath Pandey made changes -
          Attachment HADOOP-6233.7.patch [ 12419945 ]
          Jitendra Nath Pandey made changes -
          Attachment HADOOP-6233.6.patch [ 12419710 ]
          Jitendra Nath Pandey made changes -
          Attachment HADOOP-6233.5.patch [ 12419571 ]
          Jitendra Nath Pandey made changes -
          Attachment HADOOP-6233.4.patch [ 12419358 ]
          Hide
          Jitendra Nath Pandey added a comment -

          > I'm concerned about having all the key changes for all across the project clustered in one file, and more so that there's a separate file for just the fs. It seems to me this will lead to confusion about updating those values or adding new ones. Might it be better to include that info in the relevant file?

          I think it will be better to have just one class having all the configuration keys for entire common project, i.e. we should merge fs keys and other common keys into one single file. In my opinion, it will be easier for the users and developers if there is a single place to look for config keys or to add new keys. Also, since we have common configuration files, it will be better to have a common place to hold the config keys too, like in src/java/org/apache/hadoop/conf/CommonConfigurationKeys.java.

          Show
          Jitendra Nath Pandey added a comment - > I'm concerned about having all the key changes for all across the project clustered in one file, and more so that there's a separate file for just the fs. It seems to me this will lead to confusion about updating those values or adding new ones. Might it be better to include that info in the relevant file? I think it will be better to have just one class having all the configuration keys for entire common project, i.e. we should merge fs keys and other common keys into one single file. In my opinion, it will be easier for the users and developers if there is a single place to look for config keys or to add new keys. Also, since we have common configuration files, it will be better to have a common place to hold the config keys too, like in src/java/org/apache/hadoop/conf/CommonConfigurationKeys.java.
          Hide
          Tom White added a comment -

          I think it would be good to explicitly put the word "default" in the variable names for the default values. E.g. IO_NATIVE_LIB_AVAILABLE_DEFAULT rather than IO_NATIVE_LIB_AVAILABLE. This would avoid any doubt to users that the value is the current value, for example.

          Show
          Tom White added a comment - I think it would be good to explicitly put the word "default" in the variable names for the default values. E.g. IO_NATIVE_LIB_AVAILABLE_DEFAULT rather than IO_NATIVE_LIB_AVAILABLE. This would avoid any doubt to users that the value is the current value, for example.
          Hide
          Jakob Homan added a comment -

          Gave the patch a quick look-over:

          • The patch has gone stale with the committing of HADOOP-6234. The config key umask has been changed to umaskmode and its type is now a string.
          • I'm concerned about having all the key changes for all across the project clustered in one file, and more so that there's a separate file for just the fs. It seems to me this will lead to confusion about updating those values or adding new ones. Might it be better to include that info in the relevant file?
          • In Configuration, the code readability could be improved with a private static function like addDepKey(keyName, keyValue) that handles all the boiler plate of Configuration.addDeprecation(*, new String[] { *}

            ).

          Show
          Jakob Homan added a comment - Gave the patch a quick look-over: The patch has gone stale with the committing of HADOOP-6234 . The config key umask has been changed to umaskmode and its type is now a string. I'm concerned about having all the key changes for all across the project clustered in one file, and more so that there's a separate file for just the fs. It seems to me this will lead to confusion about updating those values or adding new ones. Might it be better to include that info in the relevant file? In Configuration, the code readability could be improved with a private static function like addDepKey(keyName, keyValue) that handles all the boiler plate of Configuration.addDeprecation(*, new String[] { *} ).
          Jitendra Nath Pandey made changes -
          Attachment HADOOP-6233.3.patch [ 12418942 ]
          Jitendra Nath Pandey made changes -
          Attachment HADOOP-6233.2.patch [ 12418669 ]
          Jitendra Nath Pandey made changes -
          Attachment HADOOP-6233.1.patch [ 12418413 ]
          Hide
          Jitendra Nath Pandey added a comment -

          The attached patch is created after merging the patch of HADOOP-6105.

          Show
          Jitendra Nath Pandey added a comment - The attached patch is created after merging the patch of HADOOP-6105 .
          Jitendra Nath Pandey made changes -
          Link This issue is blocked by HADOOP-6105 [ HADOOP-6105 ]
          Jitendra Nath Pandey made changes -
          Field Original Value New Value
          Link This issue depends on HDFS-531 [ HDFS-531 ]
          Jitendra Nath Pandey created issue -

            People

            • Assignee:
              Jitendra Nath Pandey
              Reporter:
              Jitendra Nath Pandey
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development