Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.21.0
    • Fix Version/s: 0.21.0
    • Component/s: None
    • Labels:
      None

      Description

      Recent check-in's to the trunk had introduced a dependency(run-time dependency for test's) on commons-cli for streaming.

      1. HADOOP-5989.patch
        0.5 kB
        Giridharan Kesavan

        Activity

        Giridharan Kesavan added a comment -

        This fixes the dependency issues..
        tnx!

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12410102/HADOOP-5989.patch
        against trunk revision 782083.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/479/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/479/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/479/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/479/console

        This message is automatically generated.

        Giridharan Kesavan added a comment -

        hdfsproxy tests fails with the following stacktrace..
        I doesnt looks like a classpath issue with commons-cli, as we already have commons-cli in the classpath ..

        can someone take a look at this failure:
        Here is the stack trace for the error:
        http://hudson.zones.apache.org/hudson/view/Hadoop/job/Hadoop-Patch-vesta.apache.org/479/testReport/org.apache.hadoop.hdfsproxy/TestHdfsProxy/testHdfsProxyInterface/

        tnx

        Robert Chansler added a comment -

        For Zhiyong Zhang:

        Can you tell me which Hadoop version is it?

        Seems it dated back to https://issues.apache.org/jira/browse/HADOOP-5961

        The DataNode change caused some in-consistency as TestHdfsProxy used the
        DataNode.

        I cannot reproduce the error in my dev machine.

        Thanks.

        zhiyong

        Giridharan Kesavan added a comment -

        This happens on the latest trunk code..
        here is the report.
        http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/479/testReport/

        I can reproduce it in my machine..

        Giridharan Kesavan added a comment -

        steps to reproduce:

        checkout the latest trunk
        apply this path(this patch fixes the streaming test failures introduced by the DataNode changes)
        ant test-contrib

        test-junit target of hdsfproxy fails !

        Giridharan Kesavan added a comment -

        updated Affected version/s

        zhiyong zhang added a comment - - edited

        Hi,
        Could you tell me which machine are you running to get the errors?

        I tried several machines without any error.

        Here is what I did.
        svn checkout http://svn.apache.org/repos/asf/hadoop/core/trunk/ hadoop-5989
        cd hadoop-5989
        patch -p0 <../HADOOP-5989.patch
        ant test-contrib

        Thanks.

        Zhiyong.

        Giridharan Kesavan added a comment -

        Even I'm not able to reproduce the failure with the latest code updated from svn trunk.
        I going to resubmit the patch hudson and see..

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12410102/HADOOP-5989.patch
        against trunk revision 783059.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/487/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/487/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/487/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/487/console

        This message is automatically generated.

        Giridharan Kesavan added a comment -

        I'm thinkin of opening a different jira for hdfsproxy test failure.
        Its been long time since the streaming tests on trunk is failing, so I'm going to commit this and let trunk run the streaming contrib tests..

        Giridharan Kesavan added a comment -

        I just committed this!

        Opened jira hadoop-6007 for disucssing the hdfsproxy test failures.
        https://issues.apache.org/jira/browse/HADOOP-6007

        Hudson added a comment -

          People

          • Assignee:
            Giridharan Kesavan
            Reporter:
            Giridharan Kesavan
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development