+1 on the changes, though the new JobInstrumentation method should be named addWaitingMap*s* for symmetry with the other methods
Also, to ensure backward compatibility later, maybe we should port this patch to 0.20 too?
Per the taxonomy in
HADOOP-5073, the instrumentation metrics are called out as a public-stable API, and are supposed to remain unchanged except in major versions (for this patch pre-1.0, this means 0.21). If this could be applied to 0.20 at all, Sreekanth's original fix retaining the waiting_tasks metric would be the correct one by that reasoning.
Since it applies cleanly to 0.20, I'd lean towards putting it in 0.21 and let interested parties apply it themselves.