Hadoop Common
  1. Hadoop Common
  2. HADOOP-5652

Reduce does not respect in-memory segment memory limit when number of on disk segments == io.sort.factor

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.20.0
    • Fix Version/s: 0.21.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      If the number of on-disk segments is exactly io.sort.factor, then map output segments may be left in memory for the reduce contrary to the specification in mapred.job.reduce.input.buffer.percent.

      1. 5652-1.patch
        0.8 kB
        Chris Douglas
      2. 5652-0.patch
        0.8 kB
        Chris Douglas

        Activity

        Chris Douglas created issue -
        Chris Douglas added a comment -

        Easy fix

        Chris Douglas made changes -
        Field Original Value New Value
        Attachment 5652-0.patch [ 12405137 ]
        Chris Douglas added a comment -

        Better fix; should merge in-memory segments with the smallest on-disk segment

        Chris Douglas made changes -
        Attachment 5652-1.patch [ 12405143 ]
        Chris Douglas made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Assignee Chris Douglas [ chris.douglas ]
        Fix Version/s 0.21.0 [ 12313563 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12405143/5652-1.patch
        against trunk revision 763728.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/180/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/180/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/180/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/180/console

        This message is automatically generated.

        Chris Douglas added a comment -
        Test org.apache.hadoop.hdfs.server.namenode.TestReplicationPolicy FAILED
        Test org.apache.hadoop.mapred.TestMRServerPorts FAILED
        Test org.apache.hadoop.mapred.TestQueueCapacities FAILED
        

        None of the test failures were caused by the patch.

        Devaraj Das added a comment -

        +1

        Chris Douglas added a comment -

        I committed this

        Chris Douglas made changes -
        Resolution Fixed [ 1 ]
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags [Reviewed]
        Hudson added a comment -
        Owen O'Malley made changes -
        Component/s mapred [ 12310690 ]
        Tom White made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        1h 36m 1 Chris Douglas 10/Apr/09 06:27
        Patch Available Patch Available Resolved Resolved
        5d 11h 38m 1 Chris Douglas 15/Apr/09 18:05
        Resolved Resolved Closed Closed
        496d 3h 31m 1 Tom White 24/Aug/10 21:37

          People

          • Assignee:
            Chris Douglas
            Reporter:
            Chris Douglas
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development