Hadoop Common
  1. Hadoop Common
  2. HADOOP-5646

TestQueueCapacities is failing Hudson tests for the last few builds

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.20.0, 0.21.0
    • Fix Version/s: 0.20.1
    • Component/s: None
    • Labels:
      None
    1. HADOOP-5646.txt
      5 kB
      Vinod Kumar Vavilapalli

      Activity

      Vinod Kumar Vavilapalli added a comment -

      This is due to some configuration problem while creating the capacity-scheduler.xml config file.

      Configuration config = new Configuration(false);
      LocalFileSystem fs = FileSystem.getLocal(config);
      

      This snippet used to work before, it's failing now with "No FileSystem for scheme: file java.io.IOException: No FileSystem for scheme: file"

      Not sure of the exact reason why it never failed before. Loading the default configuration files solves this problem. Will upload a patch.

      Vinod Kumar Vavilapalli added a comment -

      Attaching a patch. This solves the problem by creating a configuration with default config files loaded and then accessing local file system with this configuration object. Also, replaced HDFS with local FS for the cluster so as to quicken the test a bit.

      Vinod Kumar Vavilapalli added a comment -

      Not sure of the exact reason why it never failed before. Loading the default configuration files solves this problem.

      Suman pointed out HADOOP-5585 to me. The changes on this JIRA were the cause for the failure of this test-case.

      Sreekanth Ramakrishnan added a comment -

      The patch seems fine to me.

      Vinod Kumar Vavilapalli added a comment -

      ant test-patch passed.

      Hadoop QA added a comment -

      -1 overall. Here are the results of testing the latest attachment
      http://issues.apache.org/jira/secure/attachment/12405406/HADOOP-5646.txt
      against trunk revision 765427.

      +1 @author. The patch does not contain any @author tags.

      +1 tests included. The patch appears to include 6 new or modified tests.

      +1 javadoc. The javadoc tool did not generate any warning messages.

      +1 javac. The applied patch does not increase the total number of javac compiler warnings.

      +1 findbugs. The patch does not introduce any new Findbugs warnings.

      +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

      +1 release audit. The applied patch does not increase the total number of release audit warnings.

      -1 core tests. The patch failed core unit tests.

      +1 contrib tests. The patch passed contrib unit tests.

      Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/201/testReport/
      Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/201/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
      Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/201/artifact/trunk/build/test/checkstyle-errors.html
      Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/201/console

      This message is automatically generated.

      Vinod Kumar Vavilapalli added a comment -

      The failed tests org.apache.hadoop.mapred.TestMRServerPorts.testJobTrackerPorts, org.apache.hadoop.mapred.TestMRServerPorts.testTaskTrackerPorts are not related to this patch and are fixed in HADOOP-5655 perhaps after Hudson ran the patch for this issue. I just ran both TestMRServerPorts and TestQueueCapacities on trunk with patch for this JIRA. Both passed successfully, this patch is committable.

      Vinod Kumar Vavilapalli added a comment -

      The bug is visible in branch-0.20 and trunk. The uploaded patch applies to both.

      Devaraj Das added a comment -

      I just committed this. Thanks, Vinod!

      Hudson added a comment -

        People

        • Assignee:
          Vinod Kumar Vavilapalli
          Reporter:
          Jothi Padmanabhan
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development