Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-5611

C++ libraries do not build on Debian Lenny

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 0.18.3, 0.19.0, 0.19.1, 0.20.205.0
    • Fix Version/s: 0.20.2
    • Component/s: None
    • Labels:
      None
    • Environment:

      Debian Lenny, 64 bit

    • Hadoop Flags:
      Reviewed

      Description

      The compilation of the C++ util and Hadoop Pipes code generates some errors about undefined functions. It appears there are just some missing includes that must not affect some other systems. Attaching a patch that fixes this issue.

        Attachments

          Activity

            People

            • Assignee:
              tlipcon Todd Lipcon
              Reporter:
              tlipcon Todd Lipcon
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: