Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    1. TEST-org.apache.hadoop.cli.TestCLI.txt
      434 kB
      Amareshwari Sriramadasu
    2. HADOOP-5477.patch
      2 kB
      Jakob Homan
    3. HADOOP-5477.patch
      2 kB
      Jakob Homan

      Issue Links

        Activity

        Jakob Homan added a comment -

        Works for me on trunk on OSX and RHEL:

            [junit] Running org.apache.hadoop.cli.TestCLI
            [junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 33.676 sec
        
            [junit] Running org.apache.hadoop.cli.TestCLI
            [junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 98.256 sec
        

        Any logs/output for greater detail?

        Amareshwari Sriramadasu added a comment -

        Attaching the failed test-log

        Jakob Homan added a comment -

        The problem is an edge case in the TestCLI unit test for the recently committed SLG work. This patch fixes it.

        Passes all unit tests

             [exec] +1 overall.  
             [exec] 
             [exec]     +1 @author.  The patch does not contain any @author tags.
             [exec] 
             [exec]     +1 tests included.  The patch appears to include 4 new or modified tests.
             [exec] 
             [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
             [exec] 
             [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
             [exec] 
             [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
             [exec] 
             [exec]     +1 Eclipse classpath. The patch retains Eclipse classpath integrity.
             [exec] 
             [exec]     +1 release audit.  The applied patch does not increase the total number of release audit warnings.
        
        Jakob Homan added a comment -

        Submitting patch.

        Jakob Homan added a comment -

        Actually, it was the printTopology feature that caused this (5258, not the SLG work 5358). Same fix though.

        Konstantin Shvachko added a comment -

        It makes sense to escape dots in "127.0.0.1"

        Jakob Homan added a comment -

        Updated patch to escape periods. Previously the regexp only accepted localhost as a valid hostname, now it accepts localhost*, for systems that report localhost.localdomain or such.

        Jakob Homan added a comment -

        submitting new patch.

        Tsz Wo Nicholas Sze added a comment -

        Does "localhost.*" suppose to match "localhost.localdomain" only?

        Jakob Homan added a comment -

        Does "localhost.*" suppose to match "localhost.localdomain" only?

        No, it'll match anything for the domain, which would be legal. All we care about is getting back localhost.

        Tsz Wo Nicholas Sze added a comment -

        Hi Amareshwari, what was the environment you used to reproduce the failure?

        Amareshwari Sriramadasu added a comment -

        On Linux RHEL box, the test consistently fails. Applyig the patch, test passed.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12402435/HADOOP-5477.patch
        against trunk revision 755495.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 4 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/100/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/100/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/100/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/100/console

        This message is automatically generated.

        Jakob Homan added a comment -

        The patch is worth committing because localhost.localdomain is a valid variant. However, I can't find anywhere why some machines are configured like this. Does anyone know? A question was raised, however, as to why we've not run into this issue before, since we rely on identifying localhost in other parts of the code. If we haven't failed before on this type of check, why now? Amareshwari, do you happen to know how your machine got configured like this?

        Chris Douglas added a comment -

        I committed this. Thanks, Jacob

        Hudson added a comment -

          People

          • Assignee:
            Jakob Homan
            Reporter:
            Amar Kamat
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development