Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The sub projects would have individual test jar. This would require separate driver class for each.

      1. 5217_v1.patch
        15 kB
        Sharad Agarwal
      2. 5217_v2.patch
        15 kB
        Sharad Agarwal
      3. 5217_v3.patch
        15 kB
        Sharad Agarwal

        Activity

        Hide
        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12400014/5217_v1.patch
        against trunk revision 743941.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 15 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3842/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3842/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3842/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3842/console

        This message is automatically generated.

        Show
        Hadoop QA added a comment - +1 overall. Here are the results of testing the latest attachment http://issues.apache.org/jira/secure/attachment/12400014/5217_v1.patch against trunk revision 743941. +1 @author. The patch does not contain any @author tags. +1 tests included. The patch appears to include 15 new or modified tests. +1 javadoc. The javadoc tool did not generate any warning messages. +1 javac. The applied patch does not increase the total number of javac compiler warnings. +1 findbugs. The patch does not introduce any new Findbugs warnings. +1 Eclipse classpath. The patch retains Eclipse classpath integrity. +1 release audit. The applied patch does not increase the total number of release audit warnings. +1 core tests. The patch passed core unit tests. +1 contrib tests. The patch passed contrib unit tests. Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3842/testReport/ Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3842/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3842/artifact/trunk/build/test/checkstyle-errors.html Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3842/console This message is automatically generated.
        Hide
        Jothi Padmanabhan added a comment -

        In AllTestDriver.java, instead of calling the run for each driver, a single call to pgd.driver(argv) should suffice

        Show
        Jothi Padmanabhan added a comment - In AllTestDriver.java, instead of calling the run for each driver, a single call to pgd.driver(argv) should suffice
        Hide
        Sharad Agarwal added a comment -

        Incorporated review comments.

        Show
        Sharad Agarwal added a comment - Incorporated review comments.
        Hide
        Jothi Padmanabhan added a comment -

        Looks good.
        A couple of minor points:

        1. Should we rename HdfsIntTestDriver to something more descriptive?
        2. I think java doc for the classes would be useful, especially to highlight the difference between the HdfsTestDriver and HdfsIntTestDriver classes, no?
        Show
        Jothi Padmanabhan added a comment - Looks good. A couple of minor points: Should we rename HdfsIntTestDriver to something more descriptive? I think java doc for the classes would be useful, especially to highlight the difference between the HdfsTestDriver and HdfsIntTestDriver classes, no?
        Hide
        Sharad Agarwal added a comment -

        Changed HdfsIntTestDriver name to HdfsWithMRTestDriver. Added some javadoc comments.

        Show
        Sharad Agarwal added a comment - Changed HdfsIntTestDriver name to HdfsWithMRTestDriver. Added some javadoc comments.
        Hide
        Jothi Padmanabhan added a comment -

        +1. Changes look fine.

        Show
        Jothi Padmanabhan added a comment - +1. Changes look fine.
        Hide
        Sharad Agarwal added a comment -

        I just committed this.

        Show
        Sharad Agarwal added a comment - I just committed this.
        Hide
        Hudson added a comment -

        Integrated in Hadoop-trunk #826 (See http://hudson.zones.apache.org/hudson/job/Hadoop-trunk/826/)
        . Split AllTestDriver for core, hdfs and mapred.

        Show
        Hudson added a comment - Integrated in Hadoop-trunk #826 (See http://hudson.zones.apache.org/hudson/job/Hadoop-trunk/826/ ) . Split AllTestDriver for core, hdfs and mapred.

          People

          • Assignee:
            Sharad Agarwal
            Reporter:
            Sharad Agarwal
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development