Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      There is another static FSNamesystem variable, fsn, declared in JspHelper. We should remove it.

      1. 5097_20090121.patch
        23 kB
        Tsz Wo Nicholas Sze
      2. 5097_20090126.patch
        26 kB
        Tsz Wo Nicholas Sze
      3. 5097_20090127.patch
        27 kB
        Tsz Wo Nicholas Sze
      4. 5097_20090127b.patch
        27 kB
        Tsz Wo Nicholas Sze
      5. 5097_20090128.patch
        28 kB
        Tsz Wo Nicholas Sze
      6. 5097_20090129.patch
        25 kB
        Tsz Wo Nicholas Sze

        Activity

        hudson Hudson added a comment -
        szetszwo Tsz Wo Nicholas Sze added a comment -

        The failed Chukwa tests are not related to the changes here.

        I just committed this.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12399072/5097_20090129.patch
        against trunk revision 739416.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3780/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3780/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3780/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3780/console

        This message is automatically generated.

        sureshms Suresh Srinivas added a comment -

        +1. New patch looks good

        szetszwo Tsz Wo Nicholas Sze added a comment -

        5097_20090129.patch: revert some changes in FileDataServlet so that it won't affect hdfsproxy.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12398958/5097_20090128.patch
        against trunk revision 738931.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

        -1 core tests. The patch failed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3775/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3775/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3775/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3775/console

        This message is automatically generated.

        szetszwo Tsz Wo Nicholas Sze added a comment -

        Passed all tests locally.

        szetszwo Tsz Wo Nicholas Sze added a comment -

        There were no new findbugs warnings. The problem is that hdfsproxy cannot be compiled after the changes. I guess test-patch was confused.

        5097_20090128.patch: fixed the problem with hdfsproxy.

        sureshms Suresh Srinivas added a comment -

        +1 for the patch if findbugs and test failures are fixed.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12398867/5097_20090127b.patch
        against trunk revision 738329.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        -1 findbugs. The patch appears to cause Findbugs to fail.

        +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

        -1 core tests. The patch failed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3764/testReport/
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3764/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3764/console

        This message is automatically generated.

        szetszwo Tsz Wo Nicholas Sze added a comment -

        5097_20090127b.patch: UnixUserGroupInformation.saveToConf() should be done in static. Thank Suresh for catching this.

        szetszwo Tsz Wo Nicholas Sze added a comment -

        5097_20090127.patch: changed all JspHelp methods to static and removed /** NameNode RPC address */

        shv Konstantin Shvachko added a comment -
        1. Remove comment in FSNamesystem
          /** NameNode RPC address */
        2. I do not very much like that you add JspHelper as a NameNode members. I understand the intention is not to instantiate objects on the web UI, but may be we should rather consider making most of the methods / fields of JspHelper static instead of constructing the object. In any case it is better not to introduce helper variables in NamNode and DataNode.
        szetszwo Tsz Wo Nicholas Sze added a comment -

        5097_20090126.patch: added javadoc and re-organized some methods.

        szetszwo Tsz Wo Nicholas Sze added a comment -

        5097_20090121.patch:

        • change JspHelper.fsn from "static" to "private final"
        • change a few non-static methods in JspHelper to static

          People

          • Assignee:
            szetszwo Tsz Wo Nicholas Sze
            Reporter:
            szetszwo Tsz Wo Nicholas Sze
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development