Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.18.0
    • Fix Version/s: 0.19.1
    • Component/s: fs
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      When using fully qualified URIs with FsShell, the authority element of the URI must match the default filesystem exactly, or else one may get an error message when the trash is enabled:

      $ hadoop fs -rmr hdfs://namenode1/user/foo/bar
      rmr: Wrong FS: hdfs://namenode1/user/foo/bar, expected: hdfs://namenode1.foobar.com
      Usage: java FsShell [-rmr <path>]
      $ hadoop fs -rmr hdfs://namenode1.foobar.com/user/foo/bar
      $
      

      It should be possible to use the FileSystem for the Path provided rather than the default FileSystem. 0.17 was less particular about this.

      1. 5086-0.patch
        5 kB
        Chris Douglas
      2. 5086-1.patch
        23 kB
        Chris Douglas

        Activity

        Chris Douglas created issue -
        Chris Douglas added a comment -

        Attaching patch shuffling cstr params around, added a unit test (shouldn't the unit test be in o.a.h.fs? If it were moved, this could use Trash::getCurrentTrashDir instead of hard-coding its params).

        Chris Douglas made changes -
        Field Original Value New Value
        Attachment 5086-0.patch [ 12398363 ]
        Doug Cutting added a comment -

        > shouldn't the unit test be in o.a.h.fs?

        Yes, the generic bits certainly. And it would be useful if the test were reusable by HDFS, so that it could, e.g., subclass the core test to run things on a mini cluster.

        Chris Douglas added a comment -

        it would be useful if the test were reusable by HDFS, so that it could, e.g., subclass the core test to run things on a mini cluster.

        Good idea. Moved trash tests to fs, HDFS test of trash to a subclass.

        Chris Douglas made changes -
        Attachment 5086-1.patch [ 12398443 ]
        Chris Douglas made changes -
        Assignee Chris Douglas [ chris.douglas ]
        Status Open [ 1 ] Patch Available [ 10002 ]
        Fix Version/s 0.21.0 [ 12313563 ]
        Doug Cutting added a comment -

        +1 this looks good to me.

        Chris Douglas added a comment -
             [exec] +1 overall.  
             [exec] 
             [exec]     +1 @author.  The patch does not contain any @author tags.
             [exec] 
             [exec]     +1 tests included.  The patch appears to include 15 new or modified tests.
             [exec] 
             [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
             [exec] 
             [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
             [exec] 
             [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
             [exec] 
             [exec]     +1 Eclipse classpath. The patch retains Eclipse classpath integrity.
        
        Chris Douglas added a comment -

        Passed all unit tests on my machine.

        Should this go into 0.20? This changed between 0.17 and 0.18, but not between 0.18 and trunk.

        Doug Cutting added a comment -

        > Should this go into 0.20? This changed between 0.17 and 0.18, but not between 0.18 and trunk.

        +1 It's still a regression, even if we were slow to notice it. We could, in theory, merge a fix to the 0.19 and 0.19 branches too, if we wanted.

        Chris Douglas added a comment -

        We could, in theory, merge a fix to the 0.19 [0.18?] and 0.19 branches too, if we wanted.

        Soright. I'll hold off on 0.18, since the vote for that has already been called.

        I committed this.

        Chris Douglas made changes -
        Resolution Fixed [ 1 ]
        Fix Version/s 0.19.1 [ 12313473 ]
        Fix Version/s 0.21.0 [ 12313563 ]
        Hadoop Flags [Incompatible change] [Reviewed]
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Nigel Daley made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        1d 1h 38m 1 Chris Douglas 22/Jan/09 01:20
        Patch Available Patch Available Resolved Resolved
        1d 21h 31m 1 Chris Douglas 23/Jan/09 22:52
        Resolved Resolved Closed Closed
        32d 45m 1 Nigel Daley 24/Feb/09 23:37

          People

          • Assignee:
            Chris Douglas
            Reporter:
            Chris Douglas
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development