Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.20.0
    • Fix Version/s: 0.21.0
    • Component/s: scripts
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      ant test-patch is reporting "Trunk compilation is broken?" for any patch.

      ...
           [exec] /home/tsz/apache-ant-1.7.1/bin/ant -Dversion=PATCH-a.patch -Djavac.args=-Xlint -Xmaxwarns 1000  -DHadoopPatchProcess= clean tar > /home/tsz/tmp/trunkJavacWarnings.txt 2>&1
           [exec] Trunk compilation is broken?
      
      1. HADOOP-4948.patch
        4 kB
        Giridharan Kesavan

        Issue Links

          Activity

          Giridharan Kesavan added a comment - - edited

          I'm trying to reproduce, could you please paste the info from the log file /home/tsz/tmp/trunkJavacWarnings.txt

          Thanks,
          Giri

          Giridharan Kesavan added a comment - - edited

          I'm able to reproduce the failure.

          After the the fix for HADOOP-4920, the package target depends on docs target, with inturn depends on forrest.home and java5.home

          When we call the test-patch target through ant though, we pass the forrest.home & java5.home the test-patch.sh
          script doesn't seem to pass the 2 env variables while calling the tar and findbugs target, which is causing the ant test-pach failure.

          This patch HADOOP-4849.patch cannot be tested, as it modifies the test-patch.sh itself.

          This patch is tested manually , here is the test-patch result:

          +1 overall.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

          Thanks,
          Giri

          Tsz Wo Nicholas Sze added a comment -

          +1 patch looks good.

          Tsz Wo Nicholas Sze added a comment -

          I just committed this to trunk. Thanks, Giri!

          If HADOOP-4920 is committed to 0.20, this one also should be.

          Amareshwari Sriramadasu added a comment -

          I still see the issue on the trunk, even with empty patch.

          Amareshwari Sriramadasu added a comment -

          Looks like problem was with the environment variables on my machine. Thanks Giri for helping it out.

          Hudson added a comment -

          Integrated in Hadoop-trunk #703 (See http://hudson.zones.apache.org/hudson/job/Hadoop-trunk/703/)
          . Add parameters java5.home and forrest.home to the ant commands in test-patch.sh. (Giridharan Kesavan via szetszwo)


            People

            • Assignee:
              Giridharan Kesavan
              Reporter:
              Tsz Wo Nicholas Sze
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development