Hadoop Common
  1. Hadoop Common
  2. HADOOP-4840

TestNodeCount sometimes fails with NullPointerException

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.18.3
    • Fix Version/s: 0.18.3
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Testcase: testNodeCount took 9.628 sec
      Caused an ERROR

      java.lang.NullPointerException
      at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.countNodes(FSNamesystem.java:3523)
      at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.countNodes(FSNamesystem.java:3543)
      at org.apache.hadoop.hdfs.server.namenode.TestNodeCount.testNodeCount(TestNodeCount.java:64)

      1. nodeCountNPE1-br18.patch
        0.6 kB
        Hairong Kuang
      2. nodeCountNPE1.patch
        0.6 kB
        Hairong Kuang
      3. nodeCountNPE.patch
        0.6 kB
        Hairong Kuang

        Issue Links

          Activity

          Hudson added a comment -
          Hairong Kuang added a comment -

          I've just committed this.

          Hairong Kuang added a comment -

          patch for branch 0.18.

          Tsz Wo Nicholas Sze added a comment -

          +1 patch looks good.

          Tsz Wo Nicholas Sze added a comment -

          > Can we handle only the unit test failure in this jira and handle the non-synchronized call to countNodes in a different jira?

          Sure. Let do it in a separated issue.

          Hairong Kuang added a comment -

          I totally agree with Nicholas's observation. Can we handle only the unit test failure in this jira and handle the non-synchronized call to countNodes in a different jira?

          Tsz Wo Nicholas Sze added a comment -

          FSNamesystem.countNodes(..) is called in many places including:

          • FSNamesystem.addStoredBlock(Block, DatanodeDescriptor, DatanodeDescriptor)
          • FSNamesystem.checkReplicationFactor(INodeFile)
          • FSNamesystem.decrementSafeBlockCount(Block)
          • FSNamesystem.getBlockLocationsInternal(String, INodeFile, long, long, int, boolean)
          • FSNamesystem.invalidateBlock(Block, DatanodeInfo)
          • FSNamesystem.isReplicationInProgress(DatanodeDescriptor)
          • FSNamesystem.markBlockAsCorrupt(Block, DatanodeInfo)
          • FSNamesystem.processMisReplicatedBlocks()
          • FSNamesystem.processPendingReplications()
          • FSNamesystem.updateNeededReplications(Block, int, int)

          However, some of them, e.g. getBlockLocationsInternal, call countNodes(..) without owning the fsnamesystem lock before calling . It may causes NPE in runtime.

          Hairong Kuang added a comment -

          I ran TestNodeCount for 50 times on my local machine without seeing NPE.

          Hairong Kuang added a comment -

          This patch adds the synchronization on FsNamesystem in the failed test.

          Tsz Wo Nicholas Sze added a comment -

          I think we should synchronize fsnamesystem but not blocksMap.

          Hairong Kuang added a comment -

          The error was caused by an unsynchronized access to the list of block locations. The patch fixed the problem.


            People

            • Assignee:
              Hairong Kuang
              Reporter:
              Hairong Kuang
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development