Hadoop Common
  1. Hadoop Common
  2. HADOOP-4720

docs/api does not contain the hdfs directory after building

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.19.0
    • Fix Version/s: 0.19.1
    • Component/s: build
    • Labels:
      None

      Description

      When ant package is run, the build/docs/api folder is not reflecting the "hdfs" hierarchy of packages and classes. org.apache.hadoop.hdfs is not getting created in the api folder. Instead, the build creates org.apache.hadoop.fs.

      The same can be observed here as well : http://hadoop.apache.org/core/docs/r0.19.0/api/index.html

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1h 54m 1 Ramya Sunil 25/Nov/08 11:30
        Resolved Resolved Closed Closed
        91d 12h 7m 1 Nigel Daley 24/Feb/09 23:37
        Nigel Daley made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Nigel Daley made changes -
        Fix Version/s 0.20.0 [ 12313438 ]
        Nigel Daley made changes -
        Fix Version/s 0.20.0 [ 12313438 ]
        Ramya Sunil made changes -
        Field Original Value New Value
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Ramya Sunil added a comment -

        Thanks Tom.

        Tom White added a comment -

        This is by design since users should not normally access HDFS classes directly, instead they should go through the FileSystem interface. See HADOOP-3742. You can type ant javadoc-dev to get the HDFS javadoc.

        Ramya Sunil created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Ramya Sunil
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development