Hadoop Common
  1. Hadoop Common
  2. HADOOP-3477

release tar.gz contains duplicate files

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.16.4, 0.17.0
    • Fix Version/s: 0.17.1
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Activity

      Adam Heath added a comment -

      Simple patch, one line.

      Adam Heath added a comment -

      More details:

      ==
      adam@zoot:~/code/upstream/nutch$ tar tzvf hadoop-0.17.0.tar.gz |awk '

      {print $6}

      '|sort|uniq -c|grep -v '1 '
      2 hadoop-0.17.0/contrib/hod/bin/VERSION
      2 hadoop-0.17.0/contrib/hod/bin/checknodes
      2 hadoop-0.17.0/contrib/hod/bin/hod
      2 hadoop-0.17.0/contrib/hod/bin/hodcleanup
      2 hadoop-0.17.0/contrib/hod/bin/hodring
      2 hadoop-0.17.0/contrib/hod/bin/ringmaster
      ==

      This occurs because those files are included twice in build.xml, because there is no explicit exclude on those dirs, like there is for the others. The attached patch(1-line) adds such an exclude.

      This is keeping me from using the downloaded tarball as the orig.tar.gz for a debian package.

      Doug Cutting added a comment -

      I just committed this. Thanks, Adam!

      Adam Heath added a comment -

      Could you apply the fix to 0.16 as well(creating 0.16.5)? Nutch isn't using 0.17 yet.

      Doug Cutting added a comment -

      I guess this is a regression, since it was introduced in 0.16.0 by HADOOP-2494. Unless there are objections, I will merge it into the 0.16 and 0.17 branches.

      Hudson added a comment -
      Hudson added a comment -

        People

        • Assignee:
          Adam Heath
          Reporter:
          Adam Heath
        • Votes:
          0 Vote for this issue
          Watchers:
          1 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development