Hadoop Common
  1. Hadoop Common
  2. HADOOP-2107

Hadoop examples cannot execute on a single-node cluster post HADOOP-1622

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: 0.16.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      All hadoop examples on single-node cluster, post HADOOP-1622, fail with:

      Running 10 maps.
      Job started: Fri Oct 26 17:23:51 IST 2007
      07/10/26 17:23:51 WARN mapred.JobClient: No job jar file set.  User classes may not be found. See JobConf(Class) or JobConf#setJar(String).
      07/10/26 17:23:52 INFO mapred.JobClient: Running job: job_200710261722_0001
      07/10/26 17:23:53 INFO mapred.JobClient:  map 0% reduce 0%
      07/10/26 17:24:07 INFO mapred.JobClient: Task Id : task_200710261722_0001_m_000000_0, Status : FAILED
      java.lang.RuntimeException: java.lang.RuntimeException: java.lang.ClassNotFoundException: org.apache.hadoop.examples.RandomWriter$RandomInputFormat
      	at org.apache.hadoop.conf.Configuration.getClass(Configuration.java:576)
      	at org.apache.hadoop.mapred.JobConf.getInputFormat(JobConf.java:512)
      	at org.apache.hadoop.mapred.MapTask.run(MapTask.java:156)
      	at org.apache.hadoop.mapred.TaskTracker$Child.main(TaskTracker.java:1936)
      Caused by: java.lang.RuntimeException: java.lang.ClassNotFoundException: org.apache.hadoop.examples.RandomWriter$RandomInputFormat
      	at org.apache.hadoop.conf.Configuration.getClass(Configuration.java:544)
      	at org.apache.hadoop.conf.Configuration.getClass(Configuration.java:568)
      	... 3 more
      Caused by: java.lang.ClassNotFoundException: org.apache.hadoop.examples.RandomWriter$RandomInputFormat
      	at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
      	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
      	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
      	at java.lang.Class.forName0(Native Method)
      	at java.lang.Class.forName(Class.java:242)
      	at org.apache.hadoop.conf.Configuration.getClassByName(Configuration.java:524)
      	at org.apache.hadoop.conf.Configuration.getClass(Configuration.java:542)
      	... 4 more
      

      The examples work once I reverted the HADOOP-1622 patch.

      1. err.txt
        24 kB
        Arun C Murthy

        Activity

        Arun C Murthy added a comment -

        The command to run the examples was:

        $ hadoop jar build/hadoop-0.16.0-dev-examples.jar randomwriter -Dtest.randomwrite.bytes_per_map=1000000 /rw/in
        

        I've attached the complete error file.

        Owen O'Malley added a comment -

        I rolled back HADOOP-1622.

        Dennis Kubes added a comment -

        This is due to a bug in the createJobJar method in JobClient not using the context classloader to resolve classes. I have created a patch for this and am in final testing right now. I have also brought the patch up to the current trunk level. Patch should be posted within an hour.

        Dennis Kubes added a comment -

        This issue has been resolved and a patch posted to HADOOP-1622.


          People

          • Assignee:
            Dennis Kubes
            Reporter:
            Arun C Murthy
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development