Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-16829 Über-jira: S3A Hadoop 3.3.1 features
  3. HADOOP-16835

catch and downgrade all exceptions trying to load openssl native libs through wildfly

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.2.1
    • Fix Version/s: 3.3.0
    • Component/s: fs/azure, fs/s3
    • Labels:
      None

      Description

      I am getting reports of problems loading the wildfly/openSSL binding even on a build which should have HADOOP-16405 on. I'm not sure that really is the case, but given that we have had problems here which surface aa NPEs, and we may end up having other linkage problems in future -I think we should catch all exceptions raised trying to instantiate the wildfly SSL bindings and fall back to the JVM.

      I do want to log@warn here, because it is a sign of a problem. A full stack can come in at debug

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                stevel@apache.org Steve Loughran
                Reporter:
                stevel@apache.org Steve Loughran
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: