Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-16588

Update commons-beanutils version to 1.9.4 in branch-2

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.10.0
    • Component/s: None
    • Labels:
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Similar to HADOOP-16542 but we need to do it differently.
      In branch-2, we pull in commons-beanutils through commons-configuration 1.6 --> commons-digester 1.8

      [INFO] +- commons-configuration:commons-configuration:jar:1.6:compile
      [INFO] |  +- commons-digester:commons-digester:jar:1.8:compile
      [INFO] |  |  \- commons-beanutils:commons-beanutils:jar:1.7.0:compile
      [INFO] |  \- commons-beanutils:commons-beanutils-core:jar:1.8.0:compile
      

      I have a patch to update version of the transitive dependency.

        Attachments

        1. HADOOP-16588-branch-2.002.patch
          2 kB
          Jonathan Hung
        2. HADOOP-16588.branch-2.001.patch
          2 kB
          Wei-Chiu Chuang

          Issue Links

            Activity

              People

              • Assignee:
                weichiu Wei-Chiu Chuang
                Reporter:
                weichiu Wei-Chiu Chuang
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: